Ubuntu

crashes with IndexError when xorg.conf does not have a Module section

Reported by Hristo Numerov on 2007-06-09
46
Affects Status Importance Assigned to Milestone
Mythbuntu
Wishlist
Unassigned
restricted-manager (Ubuntu)
High
Martin Pitt

Bug Description

ProblemType: Crash
Date: Sat Jun 9 15:55:41 2007
ExecutablePath: /usr/bin/restricted-manager
InterpreterPath: /usr/bin/python2.5
ProcCmdline: /usr/bin/python /usr/bin/restricted-manager
ProcCwd: /home/icko
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=bg_BG.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/restricted-manager']
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/restricted-manager", line 137, in on_renderer_toggled
     self.action(path)
   File "/usr/bin/restricted-manager", line 158, in action
     handler.enable()
   File "/usr/lib/python2.5/site-packages/RestrictedManager/xorg_driver.py", line 87, in enable
     self.xorg_conf.getSections("module")[0].removeModule(m)
 IndexError: list index out of range

where is the problem !!!

2007/6/9, Marco Rodrigues <email address hidden>:
>
> ** Changed in: restricted-manager (Ubuntu)
> Sourcepackagename: None => restricted-manager
>
> --
> Freeze system
> https://bugs.launchpad.net/bugs/119562
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I do not understand you.Who do I edit ? The system freezes over.The Caps Lock and Scroll Lock blinking light.

Martin Pitt (pitti) wrote :

This restricted-manager crash does not have anything to do with the system freeze. Let's devote this bug to the r-m crash, since there is no further information about the freeze.

Changed in restricted-manager:
status: Unconfirmed → Confirmed
description: updated
Download full text (25.9 KiB)

Martin Pitt wrote:
> This restricted-manager crash does not have anything to do with the
> system freeze. Let's devote this bug to the r-m crash, since there is no
> further information about the freeze.
>
> ** Changed in: restricted-manager (Ubuntu)
> Status: Unconfirmed => Confirmed
>
> ** Summary changed:
>
> - Freeze system
> + crashes with IndexError
>
> ** Description changed:
>
> ProblemType: Crash
> Date: Sat Jun 9 15:55:41 2007
> ExecutablePath: /usr/bin/restricted-manager
> InterpreterPath: /usr/bin/python2.5
> ProcCmdline: /usr/bin/python /usr/bin/restricted-manager
> ProcCwd: /home/icko
> ProcEnviron:
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
> LANG=bg_BG.UTF-8
> SHELL=/bin/bash
> - ProcMaps:
> - 08048000-0813f000 r-xp 00000000 08:03 1290145 /usr/bin/python2.5
> - 0813f000-08164000 rw-p 000f6000 08:03 1290145 /usr/bin/python2.5
> - 08164000-08a5f000 rw-p 08164000 00:00 0 [heap]
> - b6894000-b689e000 r-xp 00000000 08:03 1224066 /lib/libgcc_s.so.1
> - b689e000-b689f000 rw-p 0000a000 08:03 1224066 /lib/libgcc_s.so.1
> - b689f000-b6987000 r-xp 00000000 08:03 1291260 /usr/lib/libstdc++.so.6.0.9
> - b6987000-b698a000 r--p 000e8000 08:03 1291260 /usr/lib/libstdc++.so.6.0.9
> - b698a000-b698c000 rw-p 000eb000 08:03 1291260 /usr/lib/libstdc++.so.6.0.9
> - b698c000-b6992000 rw-p b698c000 00:00 0
> - b6992000-b6a60000 r-xp 00000000 08:03 1290629 /usr/lib/libapt-pkg-libc6.4-6.so.3.53.0
> - b6a60000-b6a62000 rw-p 000ce000 08:03 1290629 /usr/lib/libapt-pkg-libc6.4-6.so.3.53.0
> - b6a6c000-b6a8a000 r-xp 00000000 08:03 131670 /usr/lib/python2.5/site-packages/apt_pkg.so
> - b6a8a000-b6a8d000 rw-p 0001d000 08:03 131670 /usr/lib/python2.5/site-packages/apt_pkg.so
> - b6a8d000-b6a91000 r-xp 00000000 08:03 131587 /usr/lib/python2.5/lib-dynload/zlib.so
> - b6a91000-b6a93000 rw-p 00003000 08:03 131587 /usr/lib/python2.5/lib-dynload/zlib.so
> - b6a93000-b6ab6000 r-xp 00000000 08:03 132235 /usr/lib/python2.5/site-packages/_xmlplus/parsers/pyexpat.so
> - b6ab6000-b6ab9000 rw-p 00023000 08:03 132235 /usr/lib/python2.5/site-packages/_xmlplus/parsers/pyexpat.so
> - b6ab9000-b6be4000 r-xp 00000000 08:03 49371 /usr/lib/i686/cmov/libcrypto.so.0.9.8
> - b6be4000-b6bf9000 rw-p 0012a000 08:03 49371 /usr/lib/i686/cmov/libcrypto.so.0.9.8
> - b6bf9000-b6bfc000 rw-p b6bf9000 00:00 0
> - b6bfc000-b6c39000 r-xp 00000000 08:03 49372 /usr/lib/i686/cmov/libssl.so.0.9.8
> - b6c39000-b6c3d000 rw-p 0003c000 08:03 49372 /usr/lib/i686/cmov/libssl.so.0.9.8
> - b6c3f000-b6c45000 r-xp 00000000 08:03 131554 /usr/lib/python2.5/lib-dynload/bz2.so
> - b6c45000-b6c47000 rw-p 00005000 08:03 131554 /usr/lib/python2.5/lib-dynload/bz2.so
> - b6c47000-b6c52000 r-xp 00000000 08:03 131545 /usr/lib/python2.5/lib-dynload/_socket.so
> - b6c52000-b6c55000 rw-p 0000a000 08:03 131545 /usr/lib/python2.5/lib-dynload/_socket.so
> - b6c55000-b6c58000 r-xp 00000000 08:03 131570 /usr/lib/python2.5/lib-dynload/math.so
> - b6c58000-b6c59000 rw-p 00002000 08:03 131570 /usr/lib/python2.5/lib-dynload/math.so...

I"m seeing this on gutsy as well. It appears to have trouble parsing a xorg.conf that is generated during the live env. If you manually run nvidia-xconfig and then reverse the changes via restricted manager, the issue is absolved and r-m works as expected.

Mario Limonciello (superm1) wrote :

Because of this bug, nvidia-xconfig and aticonfig --initial are being used in mythbuntu. Once things have been updated regarding restricted-manager, mythbuntu's ubiquity will need to be updated too.

Changed in mythbuntu:
importance: Undecided → Wishlist
Martin Pitt (pitti) on 2007-06-20
Changed in restricted-manager:
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) on 2007-06-20
Changed in restricted-manager:
importance: Undecided → High
Martin Pitt (pitti) wrote :

Fixed in bzr head.

Changed in restricted-manager:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 restricted-manager (0.22) gutsy; urgency=low
 .
   [ Matteo Zandi ]
   * restricted-manager: moved back the linux-restricted-modules-$(uname -r)
     check to its original place (called only if no params are given), since
     it caused r-m to popup a message dialog on startup.
 .
   [ Martin Pitt ]
   * RestrictedManager/core.py: Introduce function get_os_name() which reads
     the OS name from lsb_release -is; this falls back to 'the operating
     system'.
   * RestrictedManager/core.py, RestrictedManager/ipw3945.py,
     restricted-manager: Avoid the word 'Ubuntu' where possible and replace it
     with a call to get_os_name() in the remaining cases, to avoid branding
     issues for derivatives.
   * po/de.po: Update again to test i18n.
   * Add RestrictedManager/restricted24.png to avoid
     blurry icon in the panel menu, and RestrictedManager/restricted.svg to get
     a non-blurry icon in the application window. Thanks to Jef! (LP: #103513)
     Remove the 32x32 pixel variant, since it's the same as the scalable one.
   * Move icons from RestrictedManager/ into icons/, since there are quite a
     few of them now.
   * *.desktop.in: Fix capitalization of Comment:. (LP: #105230)
   * restricted-manager: Raise notification timeout from five to ten seconds.
     (LP: #106278)
   * RestrictedManager/xorg_driver.py, enable()/disable(): Do not crash if
     Section "Modules" does not exist. Create it if necessary. (LP: #119562)
   * RestrictedManager/bcm43xx.py: Call parent methods properly.
   * RestrictedManager/core.py, FWHandler.enable(): unbind and re-bind all
     devices from the module to trigger reloading of the firmware. This avoids
     the necessity of a reboot. Do trigger the reboot notification for
     disable() though, since we do not have a chance of hot-removing the
     firmware from devices.
   * RestrictedManager/core.py, install_package(), uninstall_package(): Keep
     track of installed and removed packages in
     /var/cache/restricted-manager/installed_packages.
   * Add debian/restricted-manager.ubiquity: ubiquity hook to install all
     packages into the target system that have been installed with r-m. Since
     we copy xorg.conf, we need to copy video driver packages, too, to avoid
     wrecking the X in the target system. Install the script as
     /usr/lib/ubiquity/target-config/31restricted_manager_pkgs. (LP: #114296)

Changed in restricted-manager:
status: Fix Committed → Fix Released
Changed in mythbuntu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers