can't resolve domain names starting with a dash (minus sign)

Bug #668926 reported by Delan Azabani on 2010-10-30
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
resolvconf (Ubuntu)
Undecided
Unassigned

Bug Description

There are websites that people on Windows and OSX seem to be able to visit, but I can't, failing with "can't find server" or similar messages for failed name resolution, because the domain name starts with a dash. Test case: http://-inevitablelament.tumblr.com/

Fabio Marconi (fabiomarconi) wrote :

Reproduced in VB

Changed in ubuntu:
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Hello Delan
I'ved reproduced this issue in Virtualbox running windows, There I.E. and FF resolve this, only in Ubuntu with FF or Chromium it cannot resolve.
I've tried disbling ipv6 but not solve.
On wich package you think to look ?
Thanks
Fabio

Fabio Marconi (fabiomarconi) wrote :

Hello Delan
I've tested others linux distro and noone can reach this site, so looking at the rules it seems that this is a not regular site because the name cannot start with a minus.
Fabio

Delan Azabani (azabani) wrote :

If so, what allows domain names like that to exist, be registered just fine on domain name servers, and be resolved on other operating systems?

tuxcayc (tuxcayc) wrote :

It happens to me too! It's a tumblr site too. Any updates on this stuff?
Thanks,
Cristian.

Fabio Marconi (fabiomarconi) wrote :

That isn't a regular site.

http://tools.ietf.org/html/rfc952

The first character must be an alpha character. The last character must not be
   a minus sign or period.

mean that the first character has to be an alphabetical, and not alphanumerical.
If we have rules, we have to follow it, we are professional.
I close this report as Invalid
Thanks
Fabio

Changed in ubuntu:
status: Confirmed → Invalid
summary: - can't resolve domain names starting with a dash
+ can't resolve domain names starting with a dash (minus sign)
Alexey Osipov (lion-simba) wrote :

It's not so clear as it seems.

RFC952 was written for plain old HOSTS.TXT method of network names resolution.

Since then DNS appeared and RFC952 was appended and relaxed by other RFCs such as:

- RFC2181 (http://tools.ietf.org/html/rfc2181), section 11 says:
"The DNS itself places only one restriction on the particular labels that can be used to identify resource records. That one restriction relates to the length of the label and the full name. The length of any one label is limited to between 1 and 63 octets. A full domain name is limited to 255 octets (including the separators). ... Those restrictions aside, any binary string whatever can be used as the label of any resource record."

- RFC1123 (http://tools.ietf.org/html/rfc1123), section 2.1 says:
"The syntax of a legal Internet host name was specified in RFC-952 [DNS:4]. One aspect of host name syntax is hereby changed: the restriction on the first character is relaxed to allow either a letter or a digit. Host software MUST support this more liberal syntax."
Not telling anything about a "minus" though.

- RFC1035 (http://tools.ietf.org/html/rfc1035), section 2.3.1 says:
"When creating a new host name, the old rules for HOSTS.TXT should be followed. This avoids problems when old software is converted to use domain names."
Please note that there is word "should" not "must". And the main reason to follow those rules stated is capability with _old_ software. Given that RFC952 is more than 25 years old and there ARE client software that is capable of handling not-rfc952-compliant domain names, some companies just USE those domain names. There are no reasons for them to NOT using it, because RFC1035 doesn't strict domain names to be RFC952 compliant.

Let's go away from all those RFCs for a minute. What we have in real world? We have some real domain names with probably valuable information we can't visit from Ubuntu, and you say everything is okay?

> If we have rules, we have to follow it, we are professional.
If we have favorite sites, we want to visit it, we are users.

Fabio Marconi (fabiomarconi) wrote :

Let's call someone more expert than me on this kind of things.
Obviously 'we are professional' is related to the Ubuntu system, and actually I cannot see any other report similar to this.
Feel free to reopen it by clicking on the status tag and select New and assign it to the right package clicking on the little triangle near Ubuntu tag.
Thanks to share your opinion.
Fabio

Changed in ubuntu:
status: Invalid → Confirmed
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

David Grossberg (davidgro) wrote :

I took a guess what package this might be. Please change it to the correct one if wrong.

More tumblr and presumably other sites are going to be affected by this over time. Following an old RFC that is obviously not being enforced at the server end is Clearly the wrong behavior for the client. The sentiment behind RFC 1958 section 3.9 applies very well here:
Be strict when sending and tolerant when receiving.

affects: ubuntu → resolvconf (Ubuntu)
Changed in resolvconf (Ubuntu):
status: New → Confirmed
David Grossberg (davidgro) wrote :

Found a bug that this is a dupe of: bug 144431

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers