20.10 groovy proposed: resolvconf-pull-resolved.service fails to start if resolvconf is installed at the same time

Bug #1890804 reported by Boudhayan Bhattacharya on 2020-08-07
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
resolvconf (Debian)
Fix Released
Unknown
resolvconf (Ubuntu)
Undecided
Unassigned

Bug Description

I was trying to find some resolutions when I found this fresh debian bug report: https://<email address hidden>/msg1759183.html

Is likely reproducible similarly but I can't since all my machines were hit by this bug and barely made one working and virtualbox-dkms is broken on 5.8.0-12-generic (filed that one too). This made all my fallback kernels,recovery unbootable! The solution discussed there is to remove the offending package resolvconf. I tried that in recovery mode root shell (graphical won't boot), but dpkg hangs when it tries to reload daemons but it can't asking me to restart after 20 minutes leaving with a host of broken packages but the system is finally bootable.

Journalctl logspam:

Journal file /var/log/journal/383ea8c95927438c95c2011a5f5bbfbb/system@0005ac4607f96c17-321a00afc15a51fc.journal~ is truncated, ignoring file.
-- Logs begin at Fri 2020-08-07 06:46:27 UTC, end at Fri 2020-08-07 10:35:32 UTC. --
Aug 07 06:46:27 systemd[1]: Failed to start resolvconf-pull-resolved.service.
 Subject: A start job for unit resolvconf-pull-resolved.service has failed
 Defined-By: systemd
Support: http://www.ubuntu.com/support
 A start job for unit resolvconf-pull-resolved.service has finished with a failure.
 The job identifier is 1649803534 and the job result is failed.
Aug 07 06:46:29 systemd[1]: resolvconf-pull-resolved.service: Start request repeated too quickly.
Aug 07 06:46:29 systemd[1]: resolvconf-pull-resolved.service: Start request repeated too quickly.
Aug 07 06:46:29 systemd[1]: resolvconf-pull-resolved.service: Start request repeated too quickly.
Aug 07 06:46:29 systemd[1]: resolvconf-pull-resolved.service: Start request repeated too quickly.
Aug 07 06:46:29 systemd[1]: resolvconf-pull-resolved.service: Start request repeated too quickly.
Aug 07 06:46:29 systemd[1]: resolvconf-pull-resolved.service: Start request repeated too quickly.
Aug 07 06:46:29 systemd[1]: resolvconf-pull-resolved.service: Start request repeated too quickly.
Aug 07 06:46:29 systemd[1]: resolvconf-pull-resolved.service: Start request repeated too quickly.
.............

systemd 246-2ubuntu1
systemd-sysv 246-2ubuntu1
resolvconf 1.82ubuntu1
Kernel: 5.8.0-12-generic x86_64
Distro: Ubuntu 20.10 (Groovy Gorilla) (*Proposed)

Just to note the bug probably came with systemd 246-2ubuntu1 today for me since it was working fine yesterday, not sure. Also some other systemd services are failing since moving to proposed like UFW (filed one too.)

description: updated
Dan Streetman (ddstreet) on 2020-08-07
tags: added: resolvconf-resolved
tags: added: resolved-resolvconf
removed: resolvconf-resolved
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in resolvconf (Ubuntu):
status: New → Confirmed
Sønke Lorenzen (solorenzen) wrote :

This also happened for me on a 20.10 with resolvconf yesterday, I do not have proposed enabled on that system.

I used the chroot process described at https://help.ubuntu.com/community/LiveCdRecovery to be able to get into that system and then uninstalling resolvconf after finding this bug and the mentioned debian bug.

That fixed it. I have that system since 12.10 so before systemd. On another 20.10 I have installed as 19.10 there is no resolvconf installed and that did not see this problem.

Changed in resolvconf (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.