Sync resiprocate 1.8.12-2 (universe) from Debian unstable (main)

Bug #1208927 reported by Daniel Pocock on 2013-08-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
resiprocate (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects ubuntu/resiprocate
 status new
 importance wishlist
 subscribe ubuntu-sponsors
 done

Please sync resiprocate 1.8.12-2 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * debian/rules: Add -lcrypto to LDFLAGS to fix FTBFS.
Fixed upstream

Changelog entries since current saucy version 1.8.5-3ubuntu1:

resiprocate (1.8.12-2) unstable; urgency=high

  * Suppress recon tests on non-Intel builds due to sipXtapi bug

 -- Daniel Pocock <email address hidden> Tue, 06 Aug 2013 10:19:09 +0200

resiprocate (1.8.12-1) unstable; urgency=high

  * New upstream release
  * Upstream has fixed various issues, Debian patches dropped

 -- Daniel Pocock <email address hidden> Mon, 05 Aug 2013 22:26:40 +0200

resiprocate (1.8.11-4) unstable; urgency=high

  * Fix for 64-bit IPv6 Tuple comparison issue

 -- Daniel Pocock <email address hidden> Fri, 19 Jul 2013 12:36:53 +0200

resiprocate (1.8.11-3) unstable; urgency=low

  * Fix for big-endian build issues
  * Stop distributing libb2bua

 -- Daniel Pocock <email address hidden> Thu, 18 Jul 2013 20:51:23 +0200

resiprocate (1.8.11-2) unstable; urgency=low

  * Disable librecon build on non-Linux architectures

 -- Daniel Pocock <email address hidden> Thu, 18 Jul 2013 13:48:31 +0200

resiprocate (1.8.11-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Thu, 18 Jul 2013 11:10:22 +0200

resiprocate (1.8.10-5) unstable; urgency=low

  * Disable recon test cases

 -- Daniel Pocock <email address hidden> Sun, 23 Jun 2013 14:10:53 +0200

resiprocate (1.8.10-4) unstable; urgency=low

  * Disable apps/clicktocall test case

 -- Daniel Pocock <email address hidden> Sun, 23 Jun 2013 12:09:33 +0200

resiprocate (1.8.10-3) unstable; urgency=low

  * Remove DM-Upload-Allowed
  * Update for standards version 3.9.4
  * Enable test cases

 -- Daniel Pocock <email address hidden> Sat, 22 Jun 2013 17:52:06 +0200

resiprocate (1.8.10-2) unstable; urgency=low

  * Disable MOHParkServer build

 -- Daniel Pocock <email address hidden> Sat, 22 Jun 2013 13:12:54 +0200

resiprocate (1.8.10-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Sat, 22 Jun 2013 12:19:23 +0200

resiprocate (1.8.9-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Thu, 20 Jun 2013 23:45:01 +0200

resiprocate (1.8.8-2) unstable; urgency=low

  * Add libsrtp-dev to build-depends

 -- Daniel Pocock <email address hidden> Wed, 08 May 2013 14:27:23 +0200

resiprocate (1.8.8-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Tue, 07 May 2013 22:38:49 +0200

resiprocate (1.8.7-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Fri, 05 Apr 2013 17:40:45 +0200

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJSATG1AAoJEOm1uwJp1aqD/uIP/j5OKwQpZWmhdXUYVA2x4BeH
MZbqFgt/ewD2Bq3+RtKwXd6uYspMUZvbkikxfp1CKr5kcZqCkrPGEGK6Ic/vOX0a
BGsYmaOSHwJWoH2l+Fov81tuE30SXXfrhyhmUIqLm2wKDhvbWDeLy+GkB/VGrfqt
F0iiobO9/H0r+pLUGLRkevYqq5/GrUwPLdyNFAFJZm3meqK7TkR1jUKsybvuY2gx
5FBNtIgulJQ5o2POkyO0fcs2H2HdkOVntZOPfziyEq+W1RMdizeGL5Ex2vB5qBgX
k3lsM4D9N1HR4cls3cI5bxscggkqouA+u/8rGqD6kb//padFaqp2gxmsXD7NdWOX
xmf9+XhKfcuGNyD+Jfr0mVMjfyFIgGQomDyikMsvJqVdxI9xNy+JFWsN6D1H4Jk8
7oHT5RSu5Kotkahb1lHtLl8hZYtd8uXQxYyfr98OWmmAzUnFAaGdywo3rfIXTtFD
804scKMVS1KNl/Sda851QPS8CoJZcociUV5Ph6mxwIVk9TKo/a2UHc6Lpwm29QoV
oEllD1EzEoTTEvYMplbFepwKa2TUdhB1CsGRmX6/kADcfamKLTQtoxii+rbQnTZU
Z5oSL8RhTFVpcOnB0g3fSoWvQGYVYyX9BAnCaNajivjRJQWES9yiKjNpStp4LEHK
/+9XRCzXhs10vq9bBGwD
=MIqJ
-----END PGP SIGNATURE-----

Dmitry Shachnev (mitya57) wrote :

This bug was fixed in the package resiprocate - 1.8.12-2
Sponsored for Daniel Pocock (daniel-pocock)

---------------
resiprocate (1.8.12-2) unstable; urgency=high

  * Suppress recon tests on non-Intel builds due to sipXtapi bug

 -- Daniel Pocock <email address hidden> Tue, 06 Aug 2013 10:19:09 +0200

resiprocate (1.8.12-1) unstable; urgency=high

  * New upstream release
  * Upstream has fixed various issues, Debian patches dropped

 -- Daniel Pocock <email address hidden> Mon, 05 Aug 2013 22:26:40 +0200

resiprocate (1.8.11-4) unstable; urgency=high

  * Fix for 64-bit IPv6 Tuple comparison issue

 -- Daniel Pocock <email address hidden> Fri, 19 Jul 2013 12:36:53 +0200

resiprocate (1.8.11-3) unstable; urgency=low

  * Fix for big-endian build issues
  * Stop distributing libb2bua

 -- Daniel Pocock <email address hidden> Thu, 18 Jul 2013 20:51:23 +0200

resiprocate (1.8.11-2) unstable; urgency=low

  * Disable librecon build on non-Linux architectures

 -- Daniel Pocock <email address hidden> Thu, 18 Jul 2013 13:48:31 +0200

resiprocate (1.8.11-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Thu, 18 Jul 2013 11:10:22 +0200

resiprocate (1.8.10-5) unstable; urgency=low

  * Disable recon test cases

 -- Daniel Pocock <email address hidden> Sun, 23 Jun 2013 14:10:53 +0200

resiprocate (1.8.10-4) unstable; urgency=low

  * Disable apps/clicktocall test case

 -- Daniel Pocock <email address hidden> Sun, 23 Jun 2013 12:09:33 +0200

resiprocate (1.8.10-3) unstable; urgency=low

  * Remove DM-Upload-Allowed
  * Update for standards version 3.9.4
  * Enable test cases

 -- Daniel Pocock <email address hidden> Sat, 22 Jun 2013 17:52:06 +0200

resiprocate (1.8.10-2) unstable; urgency=low

  * Disable MOHParkServer build

 -- Daniel Pocock <email address hidden> Sat, 22 Jun 2013 13:12:54 +0200

resiprocate (1.8.10-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Sat, 22 Jun 2013 12:19:23 +0200

resiprocate (1.8.9-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Thu, 20 Jun 2013 23:45:01 +0200

resiprocate (1.8.8-2) unstable; urgency=low

  * Add libsrtp-dev to build-depends

 -- Daniel Pocock <email address hidden> Wed, 08 May 2013 14:27:23 +0200

resiprocate (1.8.8-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Tue, 07 May 2013 22:38:49 +0200

resiprocate (1.8.7-1) unstable; urgency=low

  * New upstream release

 -- Daniel Pocock <email address hidden> Fri, 05 Apr 2013 17:40:45 +0200

Changed in resiprocate (Ubuntu):
status: New → Fix Released
Dmitry Shachnev (mitya57) wrote :

/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so: undefined reference to `timer_create'
/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so: undefined reference to `timer_settime'
/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so: undefined reference to `timer_getoverrun'
/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so: undefined reference to `timer_delete'
collect2: error: ld returned 1 exit status

Any thoughts on that? I'm currently on my Debian box, and can't reproduce that here.

Changed in resiprocate (Ubuntu):
status: Fix Released → Incomplete

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 06/08/13 21:26, Dmitry Shachnev wrote:
> /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so:
> undefined reference to `timer_create'
> /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so:
> undefined reference to `timer_settime'
> /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so:
> undefined reference to `timer_getoverrun'
> /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so:
> undefined reference to `timer_delete' collect2: error: ld returned
> 1 exit status
>

That is from the sipxtapi source package (I also maintain it in Debian)

Is that error from a build of the sipxtapi source package or a build
of the resiprocate package?

If you haven't tried already, can you try a rebuild of the sipxtapi
source package?

> Any thoughts on that? I'm currently on my Debian box, and can't
> reproduce that here.
>
> ** Changed in: resiprocate (Ubuntu) Status: Fix Released =>
> Incomplete
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBCAAGBQJSAVE8AAoJEOm1uwJp1aqDVWoP/R/ItUzkNWDXyqR7naKtInMX
Y4fjJJYOxR/vZ2dMMN5l9/b2eh8UOIztVw/Yf6XNA2H3SUSUbBPNccZMa6gRgn/L
afbIGCTU5wo9ZYfP+p4eNipBNyd2gbeAyG3mv9caxL9pVxrbAMs+cm5PFKzUKXV2
Z7wb/Wfqev56ze9rohpK11fBRdm9HnvfZYEgEllebKZWCnmmDwmbxQiGJ0JbTPvt
M2kaX+ghefJbdIz0jkutdhFgkXEwB3cLUCYlJ0eCfjkhJtTJWTfz6k0Pu+as8wiQ
GKAMFSWcK047APBf3lDFCzpS1ciDiJmJYirkxRSZVoEB2zrBxFG2L8Y2rThm6wVo
0MsiawJJ+NiZQyIT+TPJ/rjZf91yS8Q2WNwibn2SUlkBHuatWoTlna1sR5pf1NoJ
OwOuylMj5zu4jT8Fx2L1nihQBPA6ZOsTsTGLG1qmVsrYtFjY15eF8tHJKUJYz7BO
c8BSxh4RdFe0HSu4/pEMVLQzuOCkYByFLaXtI2aucfn8QYVoN07oVk7Jddpfx3Kq
Mk1WYg4AJVDqi4dXEbXas/ixB1mXKU37XYtiyTMDQOWuPco9pCPwslxsYow6SoOc
4YL15rO+3iN1XN8mZmWTwU4JdXzDopaJ3ACq0PR7aWlbIPmh4WO5vy7gHnuWtWaU
LpSZxlnOTwvrlC2VlIkX
=0DWt
-----END PGP SIGNATURE-----

Daniel Pocock (daniel-pocock) wrote :

On 06/08/13 21:40, Daniel Pocock wrote:
>
> On 06/08/13 21:26, Dmitry Shachnev wrote:
>> /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so:
>> undefined reference to `timer_create'
>> /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so:
>> undefined reference to `timer_settime'
>> /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so:
>> undefined reference to `timer_getoverrun'
>> /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libsipXmedia.so:
>> undefined reference to `timer_delete' collect2: error: ld returned
>> 1 exit status
>
>
> That is from the sipxtapi source package (I also maintain it in Debian)
>
> Is that error from a build of the sipxtapi source package or a build
> of the resiprocate package?
>
> If you haven't tried already, can you try a rebuild of the sipxtapi
> source package?
>

I just checked sipxtapi source package. It was missing "-lrt" in the
LDFLAGS. I've just pushed 3.3.0~test11-1 into Debian unstable with a
fix - please try that. You can also get it directly from the Debian VCS
if you don't want to wait for it to appear on the mirrors:

Vcs-Git: git://git.debian.org/pkg-voip/sipxtapi.git

Vcs-Browser: http://git.debian.org/?p=pkg-voip/sipxtapi.git;a=summary

>
>> Any thoughts on that? I'm currently on my Debian box, and can't
>> reproduce that here.
>
>> ** Changed in: resiprocate (Ubuntu) Status: Fix Released =>
>> Incomplete
>
>

Dmitry Shachnev (mitya57) wrote :

That was from resiprocate's build log.

I now see that sipxtapi added -lrt flag in sipXmediaLib's Makefile in
3.3.0~test11, which should fix the problem.

I will sync new sipxtapi to Ubuntu and try to rebuild resiprocate. Thanks
for the pointer!

Dmitry Shachnev (mitya57) wrote :

I've added a patch that links librutil.so with -lpthread, please consider applying it in Debian/upstream. Thanks!

Changed in resiprocate (Ubuntu):
status: Incomplete → Fix Committed
Daniel Pocock (daniel-pocock) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 09/08/13 18:20, Dmitry Shachnev wrote:
> I've added a patch that links librutil.so with -lpthread, please
> consider applying it in Debian/upstream. Thanks!
>

There have been efforts to fix a bunch of issues like this upstream
(there is a LIBPTHREAD_LIBADD macro in 1.8.12 now, although it wasn't
added to rutil)

Can you let me know when Ubuntu informed upstream about the issue?
I'm keen to work out why it wasn't fixed properly in 1.8.12 or a prior
release

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBCAAGBQJSBR/1AAoJEOm1uwJp1aqDTtsP/3+GXg6Q06chm7ct5i5niTBx
8VXEQLM80mEzQrg2CKUbZ9oQLbcnKn5FJ6dBhxVroHv/duWsWKrVLMxzPjWHsQfP
pbNF04c815r5g4VhjC8ZDj20OkiPF8/5ljBApELDU8K9U2Q0AIFW/attd7ZUWLvJ
19aCKyp9VQm+OTQp9X92pnvHQv6A0m6UJzGyvjeSq3+fLAPVmdFxmVY4HfBT0Yfo
WzMh4XCfv5uXVghtoHQAEUgKwOpUMfuvcLnh/YnwJrz5crd56OGPZRh1Bq8i1vmc
LQNReh2mzFs5uH8FEjZVqfx15e45oz4GAC5MrlluZVX6m3hrn4OpUHLeBXpnlrOr
rNwH7xUND22i1aol5bFX6TXsEhay95boS19VU0G3x7cR1wdJOFnaQpdmztGnnLnj
W6oVZpmimmTJgqg8LgMYDBcp1Ov8lH6OQWJaFuypnaQ/cNzp2z/p1k+1xQkA/OaE
WcxFRJqdm6WjNqr0lzBjXy4dMGysIdimF8oGoqz3i3oqHsDinzolEPvndke4AHZ0
AVGCzNxRnCoRuSZ5LKnvrGnNnBnLTAEsWd/36E+EhQJiS6m4l3sJppq5RZxeDWng
mPuE8Yq6Cf5HS3I6EgB+JV4XSPMi6NsD6nIYjFJZCRug7hWE7LYAZIZ+4gT6R2Mk
XoKtTMba/tZl5xNHDvkJ
=K/cx
-----END PGP SIGNATURE-----

Dmitry Shachnev (mitya57) wrote :

> Can you let me know when Ubuntu informed upstream about the issue?
> I'm keen to work out why it wasn't fixed properly in 1.8.12 or a prior release

I've noticed the issue two days ago, and haven't yet informed upstream — I'm not really sure if it's upstream issue (given that the build goes fine in Debian).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package resiprocate - 1.8.12-2ubuntu1

---------------
resiprocate (1.8.12-2ubuntu1) saucy; urgency=low

  * Link rutil library with -lpthread to fix build failure. (LP: #1208927)
 -- Dmitry Shachnev <email address hidden> Fri, 09 Aug 2013 18:57:56 +0400

Changed in resiprocate (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers