freeze after exiting rescue shell

Bug #60423 reported by Martin Pitt on 2006-09-14
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rescue (Ubuntu)
Medium
Unassigned

Bug Description

ppc alternate 20060914: getting a rescue shell works fine. After I exit it, I see the partition dialog again, but keyboard navigation does not work at all any more. The only thing that I can do is switch to VT2 to get a shell, but when I switch back to VT1, I get

  _pSLsys_getkey: EIO error

written all over the screen.

At that time, my root partition is still mounted to /target, nothing unusual in dmesg or /var/log/syslog.

Martin Pitt (pitti) wrote :

same on amd64.

Oliver Grawert (ogra) wrote :

same in edubuntu ... it also looks weird to me that we execute /bin/sh in the target, that will leave us in dash on a edgy system

Martin Pitt (pitti) wrote :

High time to confirm this, this has happened for two releases across all architectures.

Changed in rescue:
status: Unconfirmed → Confirmed
Martin Pool (mbp) wrote :

Reproducible for me too in i386 alt 20070313

Paul Sladen (sladen) wrote :

Okay, what /should/ be happening? Should boot-up continue; should the shell respawn; the system reboot?

Matt Zimmerman (mdz) wrote :

Confirmed here in VMWare/i386 with Feisty beta candidate 20070322.1, with exactly the same symptoms as in the original description. The rescue shell worked fine, but upon returning to the menu, there was no response at all to the up/down arrow keys. Switching to vt2 worked, and I could use that shell, but upon switching back (and only then), the menu was gone and replaced with many instances of "_pSLsys_getkey: EIO error" separated by linefeeds. Screenshot attached.

Matt Zimmerman (mdz) wrote :

What should happen is that the menu should function as normal, offering the user the chance to open another shell, run grub, reboot, etc.

Matt Zimmerman (mdz) wrote :

Note that when this happens, /target seems to still be mounted read/write

Brian Murray (brian-murray) wrote :

I ran into this again with the ubuntu-server daily image from 20070411.

x (xk2c-deactivatedaccount) wrote :

I ran into this as of today with alt 20070415

Kyle Simek (ksimek) wrote :

I just experienced this with the official Feisty release 7.04.

Martin Pitt (pitti) wrote :

I just tested the Tribe-4 Ubuntu alternate amd64 candidate, and this is the first time when it didn't hang. This needs some more confirmation, though.

Changed in rescue:
status: Confirmed → Incomplete
Brian Murray (brian-murray) wrote :

Tested with the Tribe 4 Ubuntu alternate i386 candidate dated 20070808.1 and it did not hang for me either.

Changed in rescue:
importance: Undecided → Medium
description: updated
Colin Watson (cjwatson) wrote :

I just tested this and it works fine for me too now. I'd love to know why this happened, but it seems to have departed as mysteriously as it arrived.

Changed in rescue:
status: Incomplete → Fix Released
Srikrishna Das (srikrishna) wrote :

Can someone point me to the fix? Can't find attachment or anything.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers