'reinstall grub' option missing when rescuing encrypted LVM system (or any system with separate /boot)

Bug #1045409 reported by Paul Larson
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rescue (Ubuntu)
Fix Released
Medium
Colin Watson
Quantal
Fix Released
Medium
Colin Watson

Bug Description

Image: Quantal Beta 1 amd64 20120903.2

I installed a system with encrypted LVM, then rebooted and picked the option to boot rescue mode from the boot media. I was able to mount root just fine, and execute a shell in it, but the only options in the 'rescue operations' menu are:
Execute a shell in /dev/beta1-server/root
Execute a shell in the installer environment
Choose a different root file system
Reboot the system

Workaround:
jibel pointed out that you can get the option to reinstall grub if you execute the shell in your root, then manually mount /boot and exit the shell. Once you do this, the option will show up on the menu

Paul Larson (pwlars)
tags: added: rls-q-incoming
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1045409

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson)
affects: debian-installer (Ubuntu) → rescue (Ubuntu)
Changed in rescue (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Paul Larson (pwlars)
tags: added: qa-manual-testing
Colin Watson (cjwatson)
Changed in rescue (Ubuntu Quantal):
assignee: nobody → Colin Watson (cjwatson)
tags: removed: rls-q-incoming
Revision history for this message
Colin Watson (cjwatson) wrote :

This is sort of another instance of bug 320183. However, I'm keeping it separate for now because it might make sense UI-wise to do something about this just for the "reinstall GRUB" option.

summary: - 'reinstall grub' option missing when rescuing encrypted LVM system
+ 'reinstall grub' option missing when rescuing encrypted LVM system (or
+ any system with separate /boot)
Colin Watson (cjwatson)
Changed in rescue (Ubuntu Quantal):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rescue - 1.33ubuntu1

---------------
rescue (1.33ubuntu1) quantal; urgency=low

  * If the target system has a separate /boot, offer to try to mount it, to
    make it easier to do things like reinstalling boot loaders (LP: #320183,
    #1045409).
 -- Colin Watson <email address hidden> Thu, 20 Sep 2012 15:00:21 +0100

Changed in rescue (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers