repowerd not having a build powerpc, ppc64el and s390x makes autopkgtests fail

Bug #1612646 reported by Timo Jyrinki
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
repowerd (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Critical
Timo Jyrinki
ubuntu-system-settings (Ubuntu RTM)
Undecided
Timo Jyrinki

Bug Description

This bug report is inspired by the problem vivid and xenial are seeing when executing ubuntuone-credentials tests. A regression is detected by the autopkgtest infrastructure:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial-ci-train-ppa-service-landing-070/xenial/ppc64el/u/ubuntuone-credentials/20160812_085933@/log.gz

This happens for ppc64el and s390x (powerpc does not have test infrastructure). The reason for the failure is a dependence on installing repowerd which does not have builds for these three architectures.

The bug can be freely modified to address the issue at hand in the best way.

Options include at least:
1. Have "stub" functionality in repowerd for these architectures.
2. Have ubuntu-system-settings (is it the only one?) depend on powerd (transitional package to repowerd) only on the four other architectures.

Update: original powerd didn't have these archs either ->
3. If the problem is u-s-s depending on "powerd" transitional package (available on all architectures), switch the dependency to repowerd instead.

Related branches

description: updated
Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → 13
status: New → Confirmed
description: updated
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

It might be that the option 3. I added reveals the real problem and the easiest fix, in ubuntu-system-settings.

description: updated
description: updated
Revision history for this message
Alexandros Frantzis (afrantzis) wrote :

u-s-s depends on powerd (>=0.15) | gnome-settings-daemon

Since powerd is missing (and always has been missing) on ppc64el, I would expect the dependency to be fulfilled by gnome-settings-daemon, but, if I understand the log correctly, the log indicates that gnome-setting-daemon couldn't be installed, which is highly suspect, since it exists on that arch, but for some reason is not installable.

The related log part:

Investigating (0) ubuntu-system-settings [ ppc64el ] < none -> 0.4+16.04.20160810-0ubuntu1 > ( gnome )
Broken ubuntu-system-settings:ppc64el Depends on powerd [ ppc64el ] < none -> 2016.08+16.04.20160811-0ubuntu1 > ( oldlibs ) (>= 0.15)
  Considering powerd:ppc64el 0 as a solution to ubuntu-system-settings:ppc64el 5
  Holding Back ubuntu-system-settings:ppc64el rather than change powerd:ppc64el
Broken ubuntu-system-settings:ppc64el Depends on gnome-settings-daemon [ ppc64el ] < none -> 3.18.2-0ubuntu3 > ( universe/gnome )
  Considering gnome-settings-daemon:ppc64el 1 as a solution to ubuntu-system-settings:ppc64el 5
  Holding Back ubuntu-system-settings:ppc64el rather than change gnome-settings-daemon:ppc64el
  Or group keep for ubuntu-system-settings:ppc64el

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

It is confirmed now that https://code.launchpad.net/~timo-jyrinki/ubuntu-system-settings/switch_dep_powerd_to_repowerd/+merge/302934 is the fix, vivid green on also ppc64el for ubuntuone-credentials and ubuntu-system-settings-online-accounts https://requests.ci-train.ubuntu.com/static/britney/ticket-1801/landing-012-xenial/excuses.html

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in ubuntu-system-settings (Ubuntu RTM):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: New → Fix Released
Changed in repowerd (Ubuntu):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.4+16.10.20160817.2-0ubuntu1

---------------
ubuntu-system-settings (0.4+16.10.20160817.2-0ubuntu1) yakkety; urgency=medium

  [ jonas-drange ]
  * rewrite the system update panel

 -- <email address hidden> (Jonas G. Drange) Wed, 17 Aug 2016 11:18:39 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers