Please merge reportbug 4.5 (universe) from debian unstable (main)

Bug #401925 reported by Andres Rodriguez
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
reportbug (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: reportbug

 reportbug (4.5) unstable; urgency=low
 .
   [ Sandro Tosi ]
   * reportbug/__init__.py
     - bump reportbug version
   * reportbug/debianbts.py
     - force to enter the package name and short description while reporting a
       wnpp bug; thanks to Sam Morris for the report and to Carl Chenet for the
       idea about how to fix it; Closes: #456344
   * bin/reportbug
     - offer a default value (text) for UI at configuration time; thanks to Carl
       Chenet for the report and patch; Closes: #529981
     - make clear reportbug can work without smtphost, while proposing
       configuration; thanks to Andrei Popescu for the report and to Carl Chenet
       for the patch; Closes: #526630
     - in case of multiple packages selection, clarified that pressing ENTER only
       will exit reportbug; thanks to Carl Chenet for the report and patch;
       Closes: #532260
     - add possibility to specify a proxy server when '--configure'; thanks to
       Chris Chiappa for the report and to Carl Chenet for the patch;
       Closes: #247885
   * bin/reportbug, conf/reportbug.conf, debian/control, man/reportbug.*,
     po4a/po/*, reportbug/utils.py
     - removed support for 'af' mail user agent, since it's no more in Debian;
       thanks to Carl Chenet for the report and (partial) patch; Closes: #529987
   * reportbug/utils.py
     - improved checks for MUA with commands name different from MUA name; thanks
       to Carl Chenet for the report and patch; Closes: #531741
   * debian/{compat, control}
     - use debhelper 7
   * debian/rules
     - use dh_prep instead of "dh_clean -k"
     - improved clean rule
     - removed dh_desktop call (no-op now)
   * debian/control
     - moved python to b-d (needed for clean) removing python-dev (not needed)
     - bump Standards-Version to 3.8.2 (no changes needed)
   * share/presubj
     - clarified to include the reportbug output when reporting bug agains us;
       thanks for the suggestion to Reuben Thomas (from #532295)
   * reportbug/{debianbts.py, ui/text_ui.py}
     - try to decode BTS page as they are parsed, replacing bad UTF-8 character;
       this will solve all those UTF-8 conversion problems; thanks to Alexandre
       Rossi for the report and patch; Closes: #531911
   * debian/copyright
     - correctly link to GPL-2 for GPLv2+ licensed files (lintian warning)
 .
   [ Luca Bruno ]
   * reportbug/ui/gtk2_ui.py:
     - add get_password() support; thanks to Arian Sanusi for the report;
       Closes: #530685
     - check whether the progress bar is present or not before dropping it in
       the bug page; thanks to Arian Sanusi for the report; Closes: #530686

Related branches

Changed in reportbug (Ubuntu):
status: New → Confirmed
Revision history for this message
Andres Rodriguez (andreserl) wrote :

Attaching debdiff

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package reportbug - 4.5ubuntu1

---------------
reportbug (4.5ubuntu1) karmic; urgency=low

  * Merge from debian unstable (LP: #401925), remaining changes:
   - bin/reportbug
      + Make reportbug stop working for bts=ubuntu and refer to "ubuntu-bug"
        instead.
      + exit with an error, if bts=ubuntu (or unconfigured).
    - reportbug/__init__.py: Match reportbug version with package version.
    - debian/control: Add prominent note to package description.

reportbug (4.5) unstable; urgency=low

  [ Sandro Tosi ]
  * reportbug/__init__.py
    - bump reportbug version
  * reportbug/debianbts.py
    - force to enter the package name and short description while reporting a
      wnpp bug; thanks to Sam Morris for the report and to Carl Chenet for the
      idea about how to fix it; Closes: #456344
  * bin/reportbug
    - offer a default value (text) for UI at configuration time; thanks to Carl
      Chenet for the report and patch; Closes: #529981
    - make clear reportbug can work without smtphost, while proposing
      configuration; thanks to Andrei Popescu for the report and to Carl Chenet
      for the patch; Closes: #526630
    - in case of multiple packages selection, clarified that pressing ENTER only
      will exit reportbug; thanks to Carl Chenet for the report and patch;
      Closes: #532260
    - add possibility to specify a proxy server when '--configure'; thanks to
      Chris Chiappa for the report and to Carl Chenet for the patch;
      Closes: #247885
  * bin/reportbug, conf/reportbug.conf, debian/control, man/reportbug.*,
    po4a/po/*, reportbug/utils.py
    - removed support for 'af' mail user agent, since it's no more in Debian;
      thanks to Carl Chenet for the report and (partial) patch; Closes: #529987
  * reportbug/utils.py
    - improved checks for MUA with commands name different from MUA name; thanks
      to Carl Chenet for the report and patch; Closes: #531741
  * debian/{compat, control}
    - use debhelper 7
  * debian/rules
    - use dh_prep instead of "dh_clean -k"
    - improved clean rule
    - removed dh_desktop call (no-op now)
  * debian/control
    - moved python to b-d (needed for clean) removing python-dev (not needed)
    - bump Standards-Version to 3.8.2 (no changes needed)
  * share/presubj
    - clarified to include the reportbug output when reporting bug agains us;
      thanks for the suggestion to Reuben Thomas (from #532295)
  * reportbug/{debianbts.py, ui/text_ui.py}
    - try to decode BTS page as they are parsed, replacing bad UTF-8 character;
      this will solve all those UTF-8 conversion problems; thanks to Alexandre
      Rossi for the report and patch; Closes: #531911
  * debian/copyright
    - correctly link to GPL-2 for GPLv2+ licensed files (lintian warning)

  [ Luca Bruno ]
  * reportbug/ui/gtk2_ui.py:
    - add get_password() support; thanks to Arian Sanusi for the report;
      Closes: #530685
    - check whether the progress bar is present or not before dropping it in
      the bug page; thanks to Arian Sanusi for the report; Closes: #530686

 -- Andres Rodriguez <email address hidden> Mon, 20 Jul 2009 15:47:06 -0500

Changed in reportbug (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers