Please merge reportbug 4.2 (universe) from Debian unstable (utils)

Bug #378591 reported by Kow
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
reportbug (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: reportbug

Changes in 4.2 (there are numerous others since 3.48... too lengthy, see Debian Changelog)

   [ Sandro Tosi ]
   * reportbug/__init__.py
     - bump reportbug version
   * bin/reportbug
     - resolved regression about not being able to select ui from cli, moving the
       check for attachments existance out of the ui check code. Now all the
       attachment files are checked for existance and it won't exit at the first
       missing. Thanks to Michael Meskes, Goncalo Marrafa and Florentin Duneau
       for the reports; Closes: #525407, #524857, #526054
     - added max number of characters allowed for report subject; thanks to Hong
       Jen Yee for the report and Carl Chenet for the patch; Closes: #364626
     - decode also email address (previously only realname was) when offering
       configuration; thanks to James Vega for the report and to Carl Chenet for
       the patch: Closes: #524297
     - clarified in the warning message that reportbug.debian.org superseded
       master|bugs.d.o as smtphost; also merged the check fo the previous 2
       hosts; thanks to Goswin von Brederlow for the report; Closes: #525856
   * reportbug/utils.py
     - fixed a typo in redirecting to /dev/null when calling lsb_release; thanks
       to Carl Chenet for the report and patch; Closes: #523684
     - handle import of pwd and tempfile in a try..catch, since they are platform
       specific, so that there is a minimum of functionalities available even if
       those modules are not present; thanks to Ritesh Raj Sarraf for the report
       and patch; Closes: #523816
   * bin/querybts
     - replaced the exit messages, with a less confusing one; thanks to A Costa
       for the report and to Carl Chenet for the patch; Closes: #358555

   [ Luca Bruno ]
   * reportbug/ui/gtk2_ui.py
     - display report message in a dialog at the end, in substitution of pager
       and stdout
     - forward page when the user hits ENTER either on an entry or a menu
     - respect given order in menus
     - wrap text in menus and disable the horizontal scrollbar; partially fixes
       #521162
     - ui focus and layout improvements

   [ Y Giridhar Appaji Nag ]
   * Remove Y Giridhar Appaji Nag from Uploaders

Related branches

Kow (kow)
Changed in reportbug (Ubuntu):
assignee: nobody → Kow (kow)
status: New → In Progress
Revision history for this message
Kow (kow) wrote :

Old Ubuntu -> New Ubuntu Candidate debdiff available upon request. Will submit "--install-layout=deb" bug upstream to debian if/when this package is accepted.

Changed in reportbug (Ubuntu):
assignee: Kow (kow) → nobody
status: In Progress → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package reportbug - 4.2ubuntu1

---------------
reportbug (4.2ubuntu1) karmic; urgency=low

  [ Kenneth E. Drake ]
  * Merge with Debian unstable (LP: #378591), remaining changes:
    - Make reportbug stop working for bts=ubuntu and refer to
      "ubuntu-bug" instead
    - reportbug: exit with an error, if bts=ubuntu (or unconfigured)
    - Match reportbug version with package version.
    - debian/control: add prominent note to package description
    - debian/rules:
      + Append "--install-layout=deb" to distutils install command.
       This ensures installation to the correct directory with python2.6.
      + Remove dh_desktop, no longer does anything.

  [ Iain Lane ]
  * bin/reportbug: Modify Ubuntu error message to be slightly more explicit.

 -- <email address hidden> (Kenneth E. Drake) Wed, 20 May 2009 02:29:33 -0500

Changed in reportbug (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers