reportbug shouldn't unconditionally attempt to relay via fiordland

Bug #123414 reported by Daniel Hahler
16
Affects Status Importance Assigned to Milestone
reportbug (Ubuntu)
Fix Released
Medium
Unassigned
Nominated for Hardy by Matthew Flaschen

Bug Description

Binary package hint: reportbug

Using reportbug 3.38ubuntu2, it fails with:
----------------------------------------------------
Report will be sent to "Ubuntu Bug Tracking System" <email address hidden>
Attachments:
 /tmp/apt-listchanges-ignore-setlocale-failure.diff

Connecting to fiordland.ubuntu.com via SMTP...
SMTP send failure: {'<email address hidden>': (554, '<email address hidden>: Relay access denied'), '<email address hidden>': (554, '<email address hidden>: Relay access denied')}
----------------------------------------------------

Related branches

Revision history for this message
William Grant (wgrant) wrote :

AFAIK, fiordland only allows routing from @ubuntu.com addresses. reportbug shouldn't be trying to use it for everyone.

Changed in reportbug:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Philipp Kern (pkern) wrote :

It should lookup the MX of lists.ubuntu.com and connect there. Whatever the comment of William Grant says, it might be misleading:

[troubadix] ~ > telnet fiordland.ubuntu.com 25
[...]
MAIL FROM:<pkern(ät)ubuntu.com>
250 Ok
RCPT TO:<email address hidden>
554 <email address hidden>: Relay access denied
[...]

Revision history for this message
James Westby (james-w) wrote :

Whatever solution should preferably allow sending reports to Debian with
reportbug -B debian by default.

I would be happy to moderate these messages if that was possible, and
there was concerns about allowing relay to bugs.debian.org.

Thanks,

James

Daniel Hahler (blueyed)
Changed in reportbug:
status: Confirmed → Triaged
Revision history for this message
Zooko Wilcox-O'Hearn (zooko) wrote :

I just tried to use reportbug 3.39ubuntu3 on Hardy, and I got this failure.

Hm... Scanning the bugs of the reportbug package in Hardy, it appears to me that what is going on is that Ubuntu developers use it to report bugs to Debian, but that it has never worked for Ubuntu users (I see some bug reports including ones that I contributed to from four years ago). This makes me angry that Ubuntu developers have decided to leave something lying around which is labelled as a tool that I can use to report bugs, so then I spend my precious time writing up bug reports for you, and then the tool wastes my bug reports. Don't you respect my time more than that? There is a simple solution: add one sentence to the package description which says "THIS IS NOT FOR USERS TO REPORT BUGS IN UBUNTU -- THIS IS USED ONLY BY UBUNTU DEVELOPERS TO REPORT BUGS IN DEBIAN.".

Now, something else that I have noticed is that over the last four or so years, many people have many times requested that Ubuntu stop distributing this "broken" reportbug which leads users to think that they can use it to report bugs and then silently wastes their bug reports. (See e.g. https://bugs.launchpad.net/ubuntu/+source/reportbug/+bug/228183 ). What happens every time is this: a user asks Ubuntu to stop distributing this broken tool which wastes their precious time, then some other people say "Oh, but we should *really* fix Ubuntu bug reporting this way or that way.", and then nothing gets done. The solution to this, too is simple: *first* fix the problem that reportbug is wasting people's time and their goodwill, by either removing it from Ubuntu or at the very least by adding the warning message to the package description as mentioned above. *Then* start thinking about how to fix various problems, such as the fact that old versions of reportbug are still distributed in older Ubuntu releases, and how to make a good reportbug-alike that works for Ubuntu, and so forth.

Got that? Do not reply to this message with talk about how to improve reportbug. Instead, add the aforementioned warning message or remove reportbug from Ubuntu. Then reply to this message talking about how to make a new improved one. Thank you.

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (4.9 KiB)

This bug was fixed in the package reportbug - 3.47ubuntu1

---------------
reportbug (3.47ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes:
    - Make reportbug stop working for bts=ubuntu and refer to
      "ubuntu-bug" instead (LP: #228183, #123414)
    - reportbug: exit with an error, if bts=ubuntu (or unconfigured)
    - debian/control: add prominent note to package description

reportbug (3.47) unstable; urgency=low

  * reportbuglib/reportbug_ui_text.py
    - added filter for bugs reports, removing all the additional info not
      needed; thanks to Ryo Igarashi for the report; Closes: #504424

reportbug (3.46) unstable; urgency=low

  * debian/control
    - updated my email address
  * reportbuglib/reportbug_ui_text.py
    - convert BTS output from UTF-8 to local encoding; thanks to Mark Hobley,
      Gregor Herrmann and Klaus Ethgen for the bug reports and to Vincent
      Fourmond for the patch; Closes: #497641, #496159, #504005

reportbug (3.45) unstable; urgency=low

  * reportbuglib/reportbug_ui_urwid.py
    - added get_password function; thanks to Torsten Wiebke and Jan Muszynski
      for the reports; Closes: #494509, #491328
  * reportbuglib/debianbts.py
    - added removal of cruft from BTS parsed page; thanks to Davide Prina, Dan
      Greene and Paul Menzel for the reports; Closes: #494545, #495018, #495050

reportbug (3.44) unstable; urgency=medium

  [ Chris Lawrence ]
  * reportbug
    + Yet another character set issue fix. (Closes: #492240)

  [ Sandro Tosi ]
  * debian/control
    - changed build-dep-indep from python-dev to python
    - bump required Python version to >= 2.5; thanks to Gilles Sadowski for
      the report; Closes: #492490 (RC bug, hence urgency set to medium)

reportbug (3.43) unstable; urgency=medium

  [ Ben Finney ]
  * reportbuglib/reportbug_ui_urwid.py
    + Ensure 'spawn_editor' is available for 'urwid' interface
      (closes: #488928).

  [ Sandro Tosi ]
  * reportbuglib/reportbug.py, reportbug
    - reports status of suggested packages; thanks to Ari Pollak for the
      report; Closes: #441056
  * reportbug
    - fixed packages list generation for a file search if run not in a tty (or
      via --template); thanks to Dan Jacobson for the report; Closes: #489515
    - for serious bugs, clearly states that "unknown" section downgrades to
      normal; thanks to Michael Meskes for the report; Closes: #362947
    - --template now includes "Package-specific info"; thanks to Marc Haber
      for the report; Closes: #396899
  * reportbuglib/reportbug.py
    - show system information only if the bug is not against wnpp; thanks to
      Francois Marier for the report; Closes: #448806
    - reinforce that RM bugs for testing are for testing only; thanks to
      Adeodato Simó for the report; Closes: #491013
  * README.Users
    - added how to usertag a bug at submit-time
  * TODO
    - removed CVS location (outdated and now supported with Vcs-Svn in
      debian/control)
    - removed item for migration to python-btsutils, filed a bug instead:
      #490548
  * debian/copyright
    - shortened Format-Specification, removing the GET parameter on the URL
      (lintian war...

Read more...

Changed in reportbug:
status: Triaged → Fix Released
Revision history for this message
auspex (auspex) wrote :

report-bug has NEVER worked on Ubuntu, and yet self-centred developers insist its more important that the command be available to them, using that name, than that they should have to use some other command. Preventing report-bug from sending emails for anybody but developers is not a fix. Leaving the command in place and "referring" users to "ubuntu-bug" is not a fixed. When is this distro going to concentrate on its users, instead of its developers?

Revision history for this message
Daniel Hahler (blueyed) wrote :

auspex: reportbug works for me and helps _a lot_ in reporting/forwarding bugs to Debian!
Now, that you explicitly need to configure it and its purpose is mentioned in the description, I see no reason to longer request its removal.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers