Remmina package doesn't provide .desktop file

Bug #931336 reported by Julien Olivier on 2012-02-13
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
remmina (Debian)
Fix Released
Unknown
remmina (Ubuntu)
Low
Unassigned

Bug Description

In remmina's latest package, there is not '/usr/share/applications/remmina.desktop'. Thus, remmina doesn't appear in the application menu, and, when launched, it is impossible to keep it in gnome-shell's dash.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: remmina 1.0.0-1
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic-pae 3.2.5
Uname: Linux 3.2.0-15-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Mon Feb 13 11:08:33 2012
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
SourcePackage: remmina
UpgradeStatus: Upgraded to precise on 2011-09-23 (143 days ago)

Related branches

Julien Olivier (julo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in remmina (Ubuntu):
status: New → Confirmed
David Clayton (dcstar) wrote :

Just upgraded Remmina on my two 12.04 Alpha test systems and while the 0.99.9.1 package fixed another bug, there is no menu entry in Gnome 3 or Unity.

Changed in remmina (Debian):
status: Unknown → Confirmed
Peter Meiser (meiser79) wrote :

Please find attached a debdiff to install the desktop file. The patch is based on the upstream GIT commits 569d9bb702d06c061dfbbf3c590d57ea83a04369 and f7d1038ba358a295fb46c681db5c47e4ead97306 .

The package is named 1.0.0-1ubuntu2 as I also provided a debdiff for #926619 named 1.0.0-1ubuntu1.

Peter Meiser (meiser79) wrote :

And here a debdiff to include everything for this bug report #931336 and #926619.

Changed in remmina (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package remmina - 1.0.0-1ubuntu1

---------------
remmina (1.0.0-1ubuntu1) precise; urgency=low

  * debian/control, debian/rules: Build with appindicator
    support. (LP: #926619)
  * debian/patches/trayicon_option.patch: Add -i option to
    only start as a tray icon.
  * debian/patches/install_desktop_file.patch: Add desktop file.
    (LP: #931336)
 -- Whoopie <email address hidden> Wed, 15 Feb 2012 13:27:09 +0100

Changed in remmina (Ubuntu):
status: Fix Committed → Fix Released
Changed in remmina (Debian):
status: Confirmed → Fix Released
John Pye (jdpipe) wrote :

this bug is still present in Ubuntu 12.04 package. any way I can get the upgraded package on this release?

Peter Meiser (meiser79) wrote :

@John Pye: it's absolutely fixed, do you have precise-updates activated?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.