Login option 'GNOME + Remmina' not working

Bug #1851007 reported by corrado venturini on 2019-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
remmina (Ubuntu)
Low
Unassigned

Bug Description

Selecting Login option 'GNOME + Remmina' I'm just returned to login panel with no message.

corrado@corrado-p13-ff-1101:~$ inxi -Fx
System: Host: corrado-p13-ff-1101 Kernel: 5.3.0-18-generic x86_64 bits: 64 compiler: gcc v: 9.2.1 Desktop: Gnome 3.34.1
           Distro: Ubuntu 20.04 LTS (Focal Fossa)
Machine: Type: Desktop Mobo: ASRock model: H110M-G/M.2 serial: <root required> UEFI: American Megatrends v: P1.10
           date: 05/11/2017
CPU: Topology: Dual Core model: Intel Core i3-7100 bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 3072 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31199
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800
Graphics: Device-1: Intel HD Graphics 630 vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0
           Display: wayland server: X.Org 1.20.5 driver: i915 resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 19.2.1 direct render: Yes
Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
           bus ID: 00:1f.3
           Sound Server: ALSA v: k5.3.0-18-generic
Network: Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:44:7b:86
Drives: Local Storage: total: 931.51 GiB used: 5.30 GiB (0.6%)
           ID-1: /dev/sda vendor: Toshiba model: DT01ACA100 size: 931.51 GiB
Partition: ID-1: / size: 15.62 GiB used: 5.30 GiB (33.9%) fs: ext4 dev: /dev/sda13
           ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 37.5 C mobo: N/A
           Fan Speeds (RPM): N/A
Info: Processes: 197 Uptime: 7m Memory: 7.49 GiB used: 1.00 GiB (13.4%) Init: systemd runlevel: 5 Compilers:
           gcc: 9.2.1 Shell: bash v: 5.0.3 inxi: 3.0.36
corrado@corrado-p13-ff-1101:~$

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu9
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sat Nov 2 08:17:56 2019
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation HD Graphics 630 [8086:5912] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: ASRock Incorporation HD Graphics 630 [1849:5912]
InstallationDate: Installed on 2019-11-01 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20191101)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
 Bus 001 Device 002: ID 058f:6377 Alcor Micro Corp. AU6375 4-LUN card reader
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-18-generic root=UUID=062c7ec4-2948-49df-934f-d054f397e4c4 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/11/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.10
dmi.board.name: H110M-G/M.2
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.10:bd05/11/2017:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH110M-G/M.2:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: To Be Filled By O.E.M.
dmi.product.name: To Be Filled By O.E.M.
dmi.product.sku: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

tags: removed: wayland-session
Sebastien Bacher (seb128) wrote :

Could you add a journalctl log from a session having the issue?

affects: xorg (Ubuntu) → remmina (Ubuntu)
Changed in remmina (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

adding journalctl

Sebastien Bacher (seb128) wrote :

Thanks for the log, that was informative, the issue is

gnome-session-binary[1634]: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Clipboard'
gnome-session-binary[1634]: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Mouse'

Those plugins got removed from gnome-settings-daemon but are still listed as requiredcomponents
https://gitlab.com/Remmina/Remmina/blob/master/data/desktop/remmina-gnome.session

Editing /usr/share/gnome-session/sessions/remmina-gnome.session to removed those items should be enough to get past that issue if you want to try that workaround.

Confirming the bug, that should also probably sent upstream

Changed in remmina (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers