Copy and Paste not Working in 15.04, 15.10, 16.04

Bug #1439478 reported by Lonnie Lee Best on 2015-04-02
182
This bug affects 38 people
Affects Status Importance Assigned to Milestone
remmina
Fix Released
Unknown
remmina (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

Remmina is probably one of the top 3 Linux applications "I need working right" to efficiently complete my work day.

So, I consider it a critical bug that "copy and pasting" between "local and remote desktops" is not working in the 15.04 beta 2.

This is one of those things, where if this is not fixed, I will have to return to Ubuntu 14.04, or figure out a way to install a version of Remmina that actually works correctly in 15.04.

This bug has reared its ugly head before:
https://bugs.launchpad.net/remmina/+bug/937522

However, the status of that bug seems to be practically closed, so that's the reason for this new posting. I want to do all I can to get this bug the attention it needs. Remmina is crucial for my work.

I'm currently dealing with the fact that it crashes a few times a day, but this "copy and paste not working" is a real deal-breaker for me to stay on 15.04.

description: updated

This has been an on-going issue. I haven't been able to copy/paste through rdesktop reliably for over a decade.

For me, I usually have to make sure my user account is logged out of the Windows server (i.e. don't click the 'x' to end your session, instead hit start->logoff) and then I sign back in. If it's broken, that has a ~50% chance of fixing it for me.

I eventually got so sick and tired of dealing with it, I did three things:
1 - Set up VPN tunnels to all my client networks so I no longer have to RDP in for a handful of use-cases (copying/pasting info to web forms for example)
2 - Installed a Windows VM under VirtualBox so I could copy/paste when I absolutely had to do it over RDP.
3 - Installed xfreerdp which allows me to copy/paste, but seems to crash from time to time when connecting to newer Windows servers.

Remmina was facilitating copy and paste between remote and local desktop with tolerable reliability in Ubuntu 14.04.

I understand that in 15.04, Ubuntu has moved to SystemD. Would that fact be totally unrelated to this issue?

Changed in remmina (Ubuntu):
status: New → Confirmed

Launchpad would not allow me to add this upstream report:
https://github.com/FreeRDP/Remmina/issues/533

wrabacon (wrabacon) wrote :

I too have this bug
(unable to copy / paste between remote sessions)
 in Ubutnu 14.04. Remmina Version: 0.9.99.1

wrabacon (wrabacon) wrote :

POSSIBLE WORKAROUND:

Ok, I was reading the README in the new source code. I got to the line were it says: install dependencies:

$ sudo apt-get install cmake intltool libgtk-3-dev libssh-dev libavahi-ui-gtk3-dev libvte-2.90-dev libxkbfile-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
cmake is already the newest version.

Suggested packages:
  autoconf2.13 autoconf-archive gnu-standards autoconf-doc libtool
  libgtk-3-doc libssh-doc
The following NEW packages will be installed:
  autoconf automake autotools-dev intltool libatk-bridge2.0-dev
  libavahi-client-dev libavahi-common-dev libavahi-glib-dev libavahi-ui-gtk3-0
  libavahi-ui-gtk3-dev libdbus-1-dev libgtk-3-dev libssh-dev libssl-dev
  libssl-doc libvte-2.90-dev libvte-2.90-doc libwayland-dev libxkbcommon-dev
  libxkbfile-dev
0 upgraded, 20 newly installed, 0 to remove and 0 not upgraded.
Need to get 4,839 kB of archives.
After this operation, 28.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y

Once I installed that, I tested the old version I am currently using, Remmina 0.9.99.1 runs, (as it did) but copy paste functionality has resumed!

The source for version 1 still failed to compile, that's a bummer, but as long as i can copy and paste in a relatively new version, I'm ok with this solution. Try it if you like. I'll look into compiling the new version later.

At this point, the bug would seem to be a dependency issue. perhaps there are log files that will give more information about this.

A successful work-around (for me) was achieved by running the following (in one command-line):

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next ; sudo apt-get update ; sudo apt-get install remmina remmina-plugin-rdp

You may have to reboot after this to see the new version of Remmina that this installs (I did).

Does anyone have the authority to make this (below) the upstream bug for this report? :

https://github.com/FreeRDP/Remmina/issues/533

Alex (alexander-stehlik) wrote :

I can confirm that upgrading to the latest version as suggested by Lonnie Lee Best fixes the issue for me in Kubuntu 15.04.

tags: added: upgrade-software-version
tags: added: wily
summary: - Critical bug - Copy and Paste not Working in 15.04
+ Copy and Paste not Working in 15.04
Changed in remmina (Ubuntu):
importance: Undecided → Medium

For anyone using the remmina-next PPA, I also had to manually upgrade the libfreerdp-plugins-standard package; for some reason the dependencies weren't properly set and the drive sharing wasn't working due to a missing library:

[10:00:37:014] [18886:2095822592] [ERROR][com.winpr.library] - LoadLibraryA: /usr/lib/x86_64-linux-gnu/freerdp/libdrive-client.so: cannot open shared object file: No such file or directory

To fix, make sure you upgrade the libfreerdp-plugins-standard package as well:

sudo apt-get install libfreerdp-plugins-standard

The full instructions:

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next
sudo apt-get update
sudo apt-get install libfreerdp-plugins-standard remmina remmina-plugin-rdp

Lukic (paunchpad-net) wrote :

I updated today to ubuntu 15.10, tried this fix and did not help. From my PC to remote clipboard passing works, from remote PC to my not. This is really bad as i can't copy validations emails, email links and so on..

After upgrading to Ubuntu 15.10, I enjoyed "copy and paste" working for about 2 or 3 weeks, and then it stopped again.

To fix I had to upgrade to the Remmina Next repository, which I installed like this:

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next ; sudo apt-get update ; sudo apt-get install remmina remmina-plugin-rdp

After rebooting, the "copy and paste" functionality began working again.

However, I want to emphasize that this remains an outstanding bug in the main repositories of Ubuntu 15.10, 15.04, 14.10, and I think even 14.04.3.

Since the Remmina Next repository works better than what is in the main repositories, I don't understand why "someone with the authority to do so" doesn't just replace what's in the main repositories with what's currently in Remmina Next.

tags: added: xenial
max5555 (max-ph) wrote :

I have apgraded remmina from remmina-next repository, but copy-paste doesn't work :(
My current remmina version is 1.1.2.

Marcus_w (mwienk) wrote :

It didn't work for me as wel (on 1.1.2), but after disabling the Clipboard sync (on the advanced tab of the connection) it did work. Though of course only copy-pasting within a session.

On 16.04 still no copy-paste... version 1.1.2-3ubuntu1

Krisztian Poos (rocky-poos) wrote :

Right, 1.1.2 on ubuntu 16.04 is also effected at me as well... :(

Are there any chance to fix this bug ?

This problem came across several ubuntu versions, It never works well.
I recently upgrade my laptop from Ubuntu 12.04 to 16.04 64 bits and It still have problems.

tags: removed: upgrade-software-version

I don't understand why the package has not been updated yet. I've been recommending that the main repository be updated to the version that's in the Remmina Next repository since two versions ago.

If you want it work right, run this as one long command and reboot:

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next ; sudo apt-get update ; sudo apt-get install remmina remmina-plugin-rdp

tags: added: upgrade-software-version
summary: - Copy and Paste not Working in 15.04
+ Copy and Paste not Working in 15.04, 15.10, 16.04
Tim K (kelletim) wrote :

Jesus this is STILL not working?

Saurabh Gupta (bhaismachine) wrote :

I did a quick check. Seems like if text is copied from the remote computer to the local computer by using a mouse to select the required text, then the copy-paste functionality does not work.

I tried selecting text on the remote computer using just the keyboard, and then I was able to successfully copy text from the remote computer to the local computer.

I tried this around 10-15 of times and it worked each time, whereas using mouse is very unreliable. Until a fix is released I am going to use this as a workaround.

I am using Ubuntu 16.04, and I did not install/upgrade Remmina through any PPAs.

Hope it works for others as well. Thanks !

Dmitry Alexandrov (dimzon541) wrote :

sometimes this can help:
1. Kill the process rdpclip.exe using the task manager in the remote computer
2. Go to RUN command and start the application rdpclip.exe

tags: added: trusty
removed: vidid
Dzumret Pelivani (dzumret) wrote :

I don't understand why the package has not been updated yet.

16.04
sudo apt-add-repository ppa:remmina-ppa-team/remmina-next
sudo apt update
sudo apt upgrade

Fixes the problem. Remmina and plug-ins are updated after running commands above.

Changed in remmina:
importance: Undecided → Unknown
status: New → Unknown
Changed in remmina:
status: Unknown → Fix Released
Julian Alarcon (alarconj) wrote :

Ok, Ubuntu 17.10 with latest updates, remmina version 1.1.2 (1.1.2-4ubuntu1)

Still have this issue, in previous versions I updated to remmina-next and the issue was solved, but as there is still no PPAs for 17.10 I can't get install that version (I don't want to mix packages from different versions)

Jeremy Bicha (jbicha) on 2017-10-28
Changed in remmina (Ubuntu):
status: Confirmed → Fix Committed
Changed in remmina (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
Jeremy Bicha (jbicha) wrote :

Remmina 1.2~ will be available in Ubuntu 18.04 LTS.

https://launchpad.net/ubuntu/+source/remmina/1.2.0-rcgit.24-1ubuntu2

Changed in remmina (Ubuntu):
status: Fix Committed → Fix Released
Julian Alarcon (alarconj) wrote :

That's great Jeremy!

For a workaround you can use the official Remmina PPA (it already have Ubuntu 17.10 builds)

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next
sudo apt update
sudo apt install remmina
sudo apt upgrade

Mychajlo Chodorev (ralfeus) wrote :

I use Mint 19 and have same problem.
Remmina and RDP plugin version - 1.2.30.1

tags: added: bionic
amias (amias) wrote :

this is still a problem in 18.04.

This is making it hard to use secure passwords because of a lack of pasting.

lets not let ubuntu drag down the basic level of security because of bug that was fixed several years ago not being in the latest package.

I do have the same problem. Also using the workaround of installing remmina from the repo ppa:remmina-ppa-team/remmina-next I cannot copy text from the host and pasting it into the guest.

My host is a Ubuntu 18.04 machine while my guest is a container running Ubuntu 16.04.

remmina version is 1.2.31.4
xrdp server version is 0.6.1-2

architecture used is a Intel Core i5 8th gen.

This configuration is fundamental for my work since I use Ubuntu 16.04 as a build system for Yocto that is only test on this Ubuntu version and of course I want to keep the possibility to run a newer OS for everything else.

I think anyway this is a quite usual usage scenario and it is actually one of the possible applications containers are used for.

helix84 (helix84) wrote :

Upstream issue (source and bug tracker moved from GitHub to GitLab):

https://gitlab.com/Remmina/Remmina/issues/533

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.