Window size larger than workspace

Bug #1370014 reported by Lonnie Lee Best on 2014-09-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
remmina (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Trusty
Medium
Unassigned
Utopic
Medium
Unassigned

Bug Description

Please view this video of the bug I'm reporting:
http://youtu.be/wKGLff7HhS8

To reproduce this bug, you will have to Enable Workspaces In Ubuntu Unity, like this:

System Settings > Appearance > Behavior > Enable Workspaces

Essentially, when using the Unity desktop (using workspaces), Remmina is launching remote sessions into a window larger than the workspace to which I'm launching it.

Another thing to note about my set up, is that I do use Ubuntu's scaling feature to make things about 10% larger than the default size (to accommodate my otherwise straining eyes). Some times I use large text too. These facts may be totally unrelated to the bug, but I thought I would at least mention them. Also, I do use multiple monitors, but this too might be unrelated to the bug. I think the essential thing, is that I have Workspaces enabled.

I'm using a fully update Ubuntu 14.04 Desktop 64bit.

description: updated

This may be a bug in Unity, but I've also posted to what I think is upstream for Remmina:
https://sourceforge.net/p/remmina/bugs/94/

Love Debberman (inxistlasha) wrote :

I am seeing the same problem as Lonnie where the window launching opens larger than the display size of the screen I'm looking at.

 I'm using Ubuntu 14.04 32bit with Unity desktop. I also am using the dual monitor setup but without scaling the size like Lonnie uses.

I'm trying to find a way to set the size in Remmina so I can view everything in one window that's smaller than the size of my screen and without having to mess with scroll bars. Most adjustments I try just makes the window oversized again (right off the bottom edge of my screen).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in remmina (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: upgrade-software-version

Is this bug fixed in later versions? Perhaps the 14.04 package needs upgrading?

In Ubuntu 14.04, I'm running this version:

remmina:amd64/trusty 1.0.0-4ubuntu3 uptodate

You can see what version you are running by running the following in one command line:

sudo apt-get install apt-show-versions ; sudo apt-show-versions remmina

This remains an issue for me.

I you view the video of this bug (on YouTube), under it is a message board where Brendan Hide said this:

"I've had this exact same bug running ArchLinux. Seems to have been fixed in the latest version however. My pacman log shows I updated Remmina on Thursday October 17th from v1.0.0 to v1.1.1."

Video: http://youtu.be/wKGLff7HhS8

Since Ubuntu 14.04 is an LTS, the Remmina package should be upgraded in the Ubuntu repositories to version 1.1.1 (or later perhaps).

Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in remmina (Ubuntu):
importance: Undecided → Medium

Can someone please upgrade this package in 14.04 LTS, so that an update is released via Ubuntu Software Updater?

You can detect which version of remmina you are using by running this as one command:

sudo apt-get install apt-show-versions ; sudo apt-show-versions remmina

In Ubuntu 14.01 this returns:

remmina:amd64/trusty 1.0.0-4ubuntu3 uptodate

What version is being run in Ubuntu 14.10?

It seems like I tested 14.10 and did not have this bug we are reporting here. I'm hoping we can get the corrected version of Remmina into the 14.01 LTS. Is this likely?

Please upgrade the software version for Remmina in the Ubuntu 14.04 repository.

I use Ubuntu exclusively, on my work-computer, and Remmina is among the most important Linux programs I use on a daily basis. This bug is driving me crazy.

Ubuntu 14.04 is a Long Term Release. A bug like this should not have to be endured for 4 years. Please assist.

description: updated
description: updated
Robert Ancell (robert-ancell) wrote :

Lonnie - we don't update to newer versions of packages in stable releases, see https://wiki.ubuntu.com/StableReleaseUpdates

tags: removed: upgrade-software-version
Robert Ancell (robert-ancell) wrote :

As I understand it the sourceforge.net project is obsolete and Remmina is now developed on https://github.com/FreeRDP/Remmina. That will probably be why there is no response to your bug report. I think the current developers don't have access to the old project to remove it.

Robert Ancell (robert-ancell) wrote :

You suggest that version 1.1.1 has this fixed so I had a look through the log to see what has changed. I *think* this may be the fix you need:
https://github.com/FreeRDP/Remmina/commit/348e01d27869a577ad5df9bf6286f876b34a40c0

no longer affects: unity (Ubuntu)
no longer affects: unity
Changed in remmina (Ubuntu):
status: Confirmed → Triaged
Changed in remmina (Ubuntu Precise):
status: New → Triaged
Changed in remmina (Ubuntu Trusty):
status: New → Triaged
Changed in remmina (Ubuntu Utopic):
status: New → Triaged
importance: Undecided → Medium
Changed in remmina (Ubuntu Trusty):
importance: Undecided → Medium
Changed in remmina (Ubuntu Precise):
importance: Undecided → Medium
Changed in remmina (Ubuntu):
status: Triaged → Fix Released
Changed in remmina (Ubuntu Trusty):
assignee: nobody → Robert Ancell (robert-ancell)
status: Triaged → In Progress
summary: - Remmina Launching Remote Sessions Larger than Workspace
+ Window size larger than Workspace
summary: - Window size larger than Workspace
+ Window size larger than workspace
Robert Ancell (robert-ancell) wrote :

I'm having trouble reproducing this in my setup but it you are able to please try building a package with the patch and see if that solves it:

$ sudo apt-get build-dep remmina
$ bzr branch lp:~robert-ancell/+junk/remmina-lp1370014
$ cd remmina-lp1370014
$ bzr-buildpackage

and install the appropriate .debs with dpkg -i from ../build-area

@Robert : Thanks for your attention on this. I see that a fix has been released, does that mean it should be available via Software Updater soon?

Also, I've reported another bug here:
https://bugs.launchpad.net/compiz/+bug/1418078

It is not the same problem as this bug, but it did contribute to making this bug worse.

Robert, I removed remmina from my system, then I built and installed these debs (from your repository):
- remmina-common_1.0.0-4ubuntu4_all
- remmina_1.0.0-4ubuntu4_amd64
- remmina-plugin-rdp_1.0.0-4ubuntu4_amd64

Here is a screen shot of how tall Remmina launched from the bottom-workspace's perspective:
http://neartalk.com/ss/2015-03-24_001_1911x1077.png

It's vertical dimensions are the height of two workspaces!

Here's the top workspace's perspective:
http://neartalk.com/ss/2015-03-24_002_1920x1079.png

You may have to have more than one monitor to reproduce this (I'm not sure).

I've reinstalled 1.0.0-4ubuntu3, and I've found a work around by changing the "Default View Mode" to "Scrolled Window" instead of "Automatic":
http://neartalk.com/ss/2015-03-24_003_763x633.png

This opens a very small window that I can at least maximize easily. I'd rather it already be maximized upon launching of an RDP session, but this small window is much better than the over-sized window problem when using "Automatic" for Default View Mode.

Rolf Leggewie (r0lf) wrote :

utopic has seen the end of its life and is no longer receiving any updates. Marking the utopic task for this ticket as "Won't Fix".

Changed in remmina (Ubuntu Utopic):
status: Triaged → Won't Fix
Changed in remmina (Ubuntu Trusty):
assignee: Robert Ancell (robert-ancell) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers