no rdp sound redirection possible

Bug #1215477 reported by Thomas on 2013-08-22
84
This bug affects 18 people
Affects Status Importance Assigned to Milestone
remmina (Ubuntu)
Medium
Unassigned

Bug Description

It is not possible to redirect rdp sound to local client. with xfreerdp and --plugin rdpsnd --data alsa -- option it is possible.

With --plugin rdpsnd --data pulse -- xfreerdp will crash (i open a seperate ticket about it)

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: remmina 1.0.0-4ubuntu3
ProcVersionSignature: Ubuntu 3.11.0-2.5-generic 3.11.0-rc5
Uname: Linux 3.11.0-2-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
Date: Thu Aug 22 16:49:32 2013
InstallationDate: Installed on 2013-08-19 (2 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130724)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: remmina
UpgradeStatus: No upgrade log present (probably fresh install)

Thomas (t.c) wrote :
tags: added: audio remmina sound
Thomas (t.c) on 2013-08-22
tags: added: rdp
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in remmina (Ubuntu):
status: New → Confirmed
Brett Johnson (linuxturtle) wrote :

Confirm that this bug exists in 13.04/raring as well. No sound is possible using remmina, but "xfreerdp --plugin rdpsnd" works fine for me (no crash).

tags: added: raring
Johan van Zoomeren (amain) wrote :

Still a problem in 13.10. xfreerdp --plugin rdpsnd works fine.

Brett Johnson (linuxturtle) wrote :

Still there in current trusty (not surprising, since it's the same package version as in saucy -- 1.0.0-4ubuntu3)

tags: added: trusty

It affects a non-essential hardware component (removable network card, camera, web-cam, music player, sound card, power management feature, printer...).

Changed in remmina (Ubuntu):
importance: Undecided → Medium
BestSteve (ibmibmibm) wrote :

I founded that xfreerdp sets settings->audio_playback to true when using rdpsnd plugin, but remmina does not set this option.
I make a patch for this, and add 'alsa' as the default audio driver.
Just put this file into debian/patches/fix-rdpsnd-no-sound, and build the package like 'debuild' or others.

The attachment "fix-rdpsnd-no-sound" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Brett Johnson (linuxturtle) wrote :

I can confirm that @BestSteve's patch works for me (after figuring out that his instructions left out the step of adding the patch to the end of the debian/patches/series file :) Thanks @BestSteve!

brietman (brietman) wrote :

Ok how can I add this patch to remmina in Lubuntu 14.04? I am bit of a noob I Guess. I can run some commands and stuff, but I don't know where to find the /deban/patch location (if it's folder?)

Hope someone can help me.

Léo Lam (leolino-lam) wrote :

@brietman: it is in the source. You need to get the source and then build it.

Léo Lam (leolino-lam) wrote :

Simply use `apt-get source remmina` to get the source and `sudo apt-get build-dep remmina` to get the required build deps.

brietman (brietman) wrote :

Ok made the patch file. But when compiling somethings go wrong... The readme says run: mkdir build (thats easy) then: Cmake --build=build but then it tells me i din't excist (sudo also)

Next thing I tried the Remmina compile guide: https://github.com/FreeRDP/Remmina/wiki/Compile-on-Ubuntu-14.04 well that worked I guess and opening Remmina from "opt/remmina_devel" works also. But sound is still not avaiable.

Shawn Wilson (swilson) wrote :

I can confirm that this patch works also. Why wasn't it included with 14.10? It's only 3 lines of code to add...

Shawn Wilson (swilson) wrote :

Oops, I mean 5 lines of code

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers