should use keywords in its .desktop entry

Bug #1024480 reported by Sebastien Bacher on 2012-07-13
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
remmina
New
Undecided
Unassigned
remmina (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Impact:
It makes remmina hard to find in the dash

Test Case:
Open the unity dash, type "VNC" or "XDMCP" or "RDP", any of those should find remmina

Regression potential:
remmina will be listed as matching some new keywords, shouldn't create any issue

---

See http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html, the "Keywords" key

Without those looking for "VNC" in the dash gives no result and makes it quite impossible to find remmina if you don't know its name

suggested "Keywords=VNC;XDMCP;RDP;" since it seems to be the protocols supported by default

Changed in remmina (Ubuntu):
importance: Undecided → Low
tags: added: keywords
Changed in remmina (Ubuntu):
status: New → Confirmed
description: updated
Changed in remmina (Ubuntu Precise):
importance: Undecided → Low
Changed in remmina (Ubuntu):
status: Confirmed → Fix Committed
Changed in remmina (Ubuntu Precise):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package remmina - 1.0.0-1ubuntu8

---------------
remmina (1.0.0-1ubuntu8) quantal; urgency=low

  * debian/patches/09_keywords.patch:
    - backport upstream patch to set keywords in the desktop entry,
      it makes easier to find remmina in the unity dash or gnome-shell
      (lp: #1024480)
 -- Sebastien Bacher <email address hidden> Fri, 27 Jul 2012 16:57:29 +0200

Changed in remmina (Ubuntu):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

Needs test case, etc from https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template before it's accepted for testing.

Changed in remmina (Ubuntu Precise):
status: In Progress → Incomplete
Changed in remmina (Ubuntu Precise):
status: Incomplete → In Progress
description: updated

Hello Sebastien, or anyone else affected,

Accepted remmina into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/remmina/1.0.0-1ubuntu6.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in remmina (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

root@sahal:~# dpkg -S /usr/share/applications/remmina.desktop
remmina-common: /usr/share/applications/remmina.desktop
root@sahal:~# dpkg -l | grep remmina-common
ii remmina-common 1.0.0-1ubuntu6.2 common files for remmina remote desktop client
root@sahal:~# grep Keywords /usr/share/applications/remmina.desktop
root@sahal:~# debsums -sa remmina-common
root@sahal:~#

Marking verification-failed as the fix isn't applied to the binary package.

tags: added: verification-failed
removed: verification-needed
Brian Murray (brian-murray) wrote :

This is not fixed in Quantal either so I am setting that task back to Triaged.

Changed in remmina (Ubuntu):
status: Fix Released → Triaged
Changed in remmina (Ubuntu Precise):
status: Fix Committed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package remmina - 1.0.0-4ubuntu1

---------------
remmina (1.0.0-4ubuntu1) raring; urgency=low

  [ Alex Chiang ]
  * Merge from Debian unstable.
    - Dropped in favor of upstream debian's patches:
      . install_desktop_file.patch => desktop_file.patch
      . scroll_smooth.patch => scroll.patch
      . trayicon_option.patch => systray.patch
  * Remaining changes:
    - debian/patches/indicator_set_title.patch:
      . set a title so the unity-hud doesn't list as "untitled" (lp: #943434)
    - debian/patches/translations.patch,
      debian/rules:
      . improve translation support, add a .desktop.in, update potfiles.in
        lists, call intltool-update on build (lp: #943279)
    - debian/patches/keywords.patch:
      . backport upstream patch to set keywords in the desktop entry,
        it makes easier to find remmina in the unity dash or gnome-shell
        (lp: #1024480)
    - debian/patches/unity_launcher_list.patch: unity launcher list support
      thanks Nekhelesh Ramananthan (lp: #938026)

  [ Iain Lane ]
  * Add Breaks and Replaces from remmina to remmina-common as the .desktop
    file has moved across.

remmina (1.0.0-4) unstable; urgency=low

  [ Martijn van Brummelen ]
  * debian/patches/clipboard.patch:
    - Clipboard support (Closes: #659755).

  [ Luca Falavigna ]
  * debian/patches/fullname.patch:
    - Use X-GNOME-FullName in .desktop file (Closes: #625939).
  * debian/patches/scroll.patch:
    - Fix some issues with scrolling (Closes: #670535).
  * debian/patches/systray.patch:
    - Implement --icon/-i option (Closes: #661893).
  * debian/control:
    - Add dbus-x11 to remmina Depends field (Closes: #668018).
    - Add Jean-Louis to Uploaders field.
    - Move VCS repository under collab-maint.

remmina (1.0.0-3) unstable; urgency=low

  * debian/patches/desktop_file.patch:
    - Fix installation path of the desktop file.
  * debian/rules:
    - Check for existence of remmina-common directory before trying
      to access it, fix FTBFS.

remmina (1.0.0-2) unstable; urgency=low

  * debian/patches/desktop_file.patch:
    - Restore installation of the .desktop file (Closes: #659542).
  * debian/patches/toolbar.patch:
    - Mark main toolbar as a primary toolbar (Closes: #659781).
  * debian/patches/datadir.patch:
    - Adjust location of REMMINA_DATADIR to allow install of icons
      in the correct location.
  * debian/control:
    - Improve description of the remmina-plugin-gnome package.
    - Bump Standards-Version to 3.9.3.
  * debian/copyright:
    - Format now points to copyright-format site.
 -- Alex Chiang <email address hidden> Thu, 17 Jan 2013 16:31:24 +0000

Changed in remmina (Ubuntu):
status: Triaged → Fix Released
Bruno Medeiros (brunojcm) wrote :

When will it be accepted in proposal? This bug is really annoying, and we have a lot of features in remmina since the old 1.0.0-1ubuntu6.1 version in precise.

Sebastien Bacher (seb128) wrote :

The bug is fixed in raring and newer version of you, what do you mean by "accepted in proposal"?

Bruno Medeiros (brunojcm) wrote :

I mean accepted in precise-proposed, since it's triaged in precise.

Sebastien Bacher (seb128) wrote :

Oh, somebody needs to do a precise stable update there... I can review/sponsor it if you want to work on that

Changed in remmina (Ubuntu):
status: Fix Released → In Progress
Bruno Medeiros (brunojcm) wrote :

I'm not a GTK developer, but I can try to help. Could you point some docs teaching me how to branch and request pull for ubuntu packages?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package remmina - 1.0.0-4ubuntu3

---------------
remmina (1.0.0-4ubuntu3) saucy; urgency=low

  * debian/patches/keywords.patch: update remmina.desktop as well,
    the file is not updated during the build (lp: #1024480)
 -- Sebastien Bacher <email address hidden> Mon, 15 Jul 2013 16:27:18 +0200

Changed in remmina (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

> I'm not a GTK developer, but I can try to help. Could you point some docs teaching me how to branch and request pull for ubuntu packages?

Thanks, I found a free slot in my schedule to fix the patch so I just did it. But for reference, if you feel like helping on some other fix: https://wiki.ubuntu.com/ContributeToUbuntu has pointers to the documentation you might need

Bruno Medeiros (brunojcm) wrote :

Thank you, Sebastien.

When will we have this on precise?

Sebastien Bacher (seb128) wrote :

when somebody from the SRU team review it in the queue and accept it as an update

Steve Langasek (vorlon) wrote :

Hello Sebastien, or anyone else affected,

Accepted remmina into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/remmina/1.0.0-1ubuntu6.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in remmina (Ubuntu Precise):
status: Triaged → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Bruno Medeiros (brunojcm) wrote :

I did the following:

    brunojcm@brunojcm-desktop:~$ sudo apt-get install remmina/precise-proposed remmina-common/precise-proposed remmina-plugin-rdp/precise-proposed remmina-plugin-vnc/precise-proposed

After that, I tried to use the words vnc and rdp (both in lower and upper case) and Remmina appeared as the first option.

Thank you very much for backporting it to precise, I hope to see this update in precise-updates soon!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package remmina - 1.0.0-1ubuntu6.3

---------------
remmina (1.0.0-1ubuntu6.3) precise; urgency=low

  * debian/patches/09_keywords.patch:
    - backport upstream patch to set keywords in the desktop entry,
      it makes easier to find remmina in the unity dash or gnome-shell
      (lp: #1024480)
 -- Sebastien Bacher <email address hidden> Mon, 15 Jul 2013 13:11:44 +0200

Changed in remmina (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers