Ubuntu

Boot splash screen always disappears at reiserfs check.

Reported by MB on 2006-02-22
68
This bug affects 2 people
Affects Status Importance Assigned to Milestone
reiserfsprogs (Ubuntu)
Low
Unassigned

Bug Description

Everytime the system is booting, the splash screen goes away when the HDs are checked.

I have 2 linux software raids, formatted with reiserfs; and 1 disk with ext3. The 2 reiserfs partitions take some time at every boot, this is when the splash screen disapears.

Furthermore, between grub and the bootup, some text is shortly displayed. Suse has had a perfect boot splash with no text for several years now (suse, but especialy the nld9 boot, is a beauty) (the beautiful suse/novell splash works at bootup AND shutdown). Why not look at what has been proven to work over the years instead of reinventing the wheel ?

(with suse I have not problem with my reiserfs disks, the splash screen is always there).

usplash has to flip due to lack of fsck progress, if it were able to use that, it could behave better

Id2ndR (id2ndr) wrote :

Unmark as duplicate since usplash fix of Bug #38303 only fix ext2/3 FS.

Id2ndR (id2ndr) on 2008-04-07
Changed in usplash:
status: New → Confirmed
Id2ndR (id2ndr) wrote :

I have seen that /sbin/fsck tool is in e2fsprogs package. But /sbin/fsck.reiserfs is in reiserfsprogs so I have change affected package to this one.

Id2ndR (id2ndr) wrote :

I have a workaround based on this comment post before fix for ext2/3 : https://bugs.launchpad.net/ubuntu/+source/sysvinit/+bug/38303
Look at attached patch. (Timeout may be decrease to 30)

Id2ndR (id2ndr) wrote :

I have a workaround based on this comment post before fix for ext2/3 : https://bugs.launchpad.net/ubuntu/+source/sysvinit/+bug/38303
Look at attached patch. (Timeout may be decrease to 30)

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in current 8.04 or 8.10 alpha?

Changed in reiserfsprogs:
importance: Medium → Low
status: Confirmed → Incomplete
Sam Brightman (sambrightman) wrote :

Yes, happens every boot on Hardy. I have never seen a "clean" boot using reiserfs.

Changed in reiserfsprogs:
status: Incomplete → Confirmed
TRiSS (triss) wrote :

I can also confirm this issue in 9.04 beta (kubuntu)

Jim H (jh-333) wrote :

I am also getting this on Kubuntu Jaunty.

The Resierfs filesystems on md RAID are checked every time (I'm shutting down the computer normally) so bootup takes a long time. This is a 1TB filesystem raided over two SATA drives in RAID1 setup.

However, on my eeepc netbook/laptop I have a reiserfs filesystem on solid state drive and it starts quite quickly. Possibly the issue is specific to ResierFS on RAID.

Carl Vondrick (carl-vondrick) wrote :

Happens on a single hard drive (1 TB) using Resier3 on every boot.

Phillip Susi (psusi) wrote :

This looks like it was a problem in usplash, not reiserfsprogs, and usplash has been replaced with plymouth, which handles this correctly.

Changed in reiserfsprogs (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers