HAL not working

Bug #221272 reported by Alessio Dessi on 2008-04-24
2
Affects Status Importance Assigned to Milestone
refpolicy (Ubuntu)
Undecided
Unassigned

Bug Description

After the last upgrade HAL is not able to start anymore due to policy preventing it to work

Caleb Case (calebcase) wrote :

Thanks for the report. Can you please post more information? I cannot duplicate this bug. Please add at least the following:

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.
2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.
3) What you expected to happen
4) What happened instead
5) The denial messages, via 'dmesg | grep avc'.
6) The status of selinux, via 'sestatus'.

Thanks,

Caleb

Caleb Case (calebcase) on 2008-04-24
Changed in refpolicy:
status: New → Incomplete

2008/4/24, Caleb Case <email address hidden>:
>
> Thanks for the report. Can you please post more information? I cannot
> duplicate this bug. Please add at least the following:
>
> 1) The release of Ubuntu you are using, via 'lsb_release -rd' or System ->
> About Ubuntu.
>
Ubuntu 8.04

2) The version of the package you are using, via 'apt-cache policy
> packagename' or by checking in Synaptic.

hal:
  Installato: 0.5.11~rc2-1ubuntu7
  Candidato: 0.5.11~rc2-1ubuntu7
  Tabella versione:
 *** 0.5.11~rc2-1ubuntu7 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

3) What you expected to happen
>
hal running and for example panel applet (network ì-manager and all the
other applet working properly

4) What happened instead

hal wasn't able to start due to policy preventing it to work properly

5) The denial messages, via 'dmesg | grep avc'.

[ 38.086277] audit(1209063630.829:4): avc: denied { mmap_zero } for
pid=4912 comm="vbetool" scontext=system_u:system_r:initrc_t
tcontext=system_u:system_r:initrc_t tclass=memprotect

6) The status of selinux, via 'sestatus'.

SELinux status: enabled
SELinuxfs mount: /selinux
Current mode: enforcing
Mode from config file: enforcing
Policy version: 21
Policy from config file: refpolicy

Thanks,

you are welcome

Caleb

Alessio

--
> HAL not working
> https://bugs.launchpad.net/bugs/221272
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
ciao,
Alessio

Alessio Dessi (alessio-dessi) wrote :

sent the info requested so this bug is confirmed

Changed in refpolicy:
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments