Redshift crashes on login 21.04

Bug #1910270 reported by Bill (franksmcb)
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
redshift (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu MATE 21.04 daily.

On login Redshift crashes and report system dialogue pops-up.

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: redshift 1.12-4
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
Uname: Linux 5.8.0-25-generic x86_64
ApportVersion: 2.20.11-0ubuntu55
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: MATE
Date: Tue Jan 5 10:35:56 2021
InstallationDate: Installed on 2021-01-05 (0 days ago)
InstallationMedia: Ubuntu-MATE 21.04 "Hirsute Hippo" - Alpha amd64 (20210105)
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: redshift
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Bill (franksmcb) (franksmcb) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1910270

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in redshift (Ubuntu):
status: New → Confirmed
Revision history for this message
Bill (franksmcb) (franksmcb) wrote :

Log files included.

Revision history for this message
Daniel Corrêa (dan-rc-br) wrote :

I've tried a cuple of weeks ago after installed Xubuntu 21.04 and confirmed the bug.

However, today (6/17) i tried to install redshift again and works fine.

Some informatins about my device:

Linux 5.11.0-18-generic #19-Ubuntu SMP Fri May 7 14:22:03 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
Redshift package (1.12-4) installed by gnome-software application from ubuntu-hirsute-universe repository.

Revision history for this message
Norbert (nrbrtx) wrote :

Crash report on first login maybe fixed by manual masking of RedShift service for LightDM greeter and its user:

```
sudo mkdir -p /var/lib/lightdm/.config/systemd/user
sudo ln -sf /dev/null /var/lib/lightdm/.config/systemd/user/redshift.service
sudo ln -sf /dev/null /var/lib/lightdm/.config/systemd/user/redshift-gtk.service
sudo chown -R lightdm: /var/lib/lightdm/.config
```

and then reboot.

Revision history for this message
Norbert (nrbrtx) wrote :

Startup for current user maybe disabled by normal usual way:

```
systemctl --user mask redshift.service redshift-gtk.service
```

And then user can add `redshift-gtk` to Startup Applications (mate-session-properties).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers