gtk-redshift appindicator not working in Ubuntu 13.10

Bug #1244880 reported by Debabrata Das on 2013-10-26
90
This bug affects 19 people
Affects Status Importance Assigned to Milestone
redshift (Ubuntu)
Undecided
Unassigned

Bug Description

On installing gtk-redshift in Ubuntu 13.10, there is no appindicator icon for it. It worked properly in Ubuntu 13.04. So, may be some change in Ubuntu 13.10 is causing this bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in redshift (Ubuntu):
status: New → Confirmed

Redshift itself does seem to work. Invoking it with the -v flag, shows output

$ redshift -v
Location: 52.349998, 4.920000
Brightness: 1.00
Gamma: 1.000, 1.000, 1.000
Using method `randr'.
Period: Daytime
Color temperature: 6500K
Period: Daytime
Color temperature: 6499K
Period: Daytime
Color temperature: 6499K
Period: Daytime
Color temperature: 6500K
Period: Daytime
Color temperature: 6500K
Period: Daytime
Color temperature: 6499K

Also, calling with the -O flag and a very low temp setting, shows that redshift is able to change settings.

$ redshift -v -O 3500K
Brightness: 1.00
Gamma: 1.000, 1.000, 1.000
Using method `randr'.
Color temperature: 3500K

(Same holds for invoking gtk-redshift)

Debabrata Das (debabrata) wrote :

Yup! I mentioned in bug description, that only appindicator (i.e. gtk gui part of the app) is not working.
It uses appindicator python module and if not avialble fallsback to use gtk.StatusIcon() to create app indicator.
It looks like Ubuntu 13.10 removed libappindicator pkg from default installtion.
And I don't have any idea about gtk.StatusIcon() support in ubuntu.

kapad (rohankapadia) wrote :

sudo apt-get install python-appindicator solved the issue for me.

Evan Derickson (derickson-e) wrote :

Confirmed, fixed it for me as well.

ftkw (ftkw) wrote :

This is still an issue in Ubuntu 14.04. The package python-appindicator needs to be set as a dependency for the .deb package of redshift-gtk.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package redshift - 1.8-0ubuntu6

---------------
redshift (1.8-0ubuntu6) trusty; urgency=low

  * Added python-appindicator as a dependency for redshift-gtk.
    Fixes gtk-redshift appindicator not working in Ubuntu 13.10.
    (LP: #1244880)
 -- Svenn-Arne Dragly <email address hidden> Mon, 10 Mar 2014 22:11:42 +0100

Changed in redshift (Ubuntu):
status: Confirmed → Fix Released
Fred (eldmannen+launchpad) wrote :

The icon shows up in Unity for me.
But not in gnome-panel on gnome-session-flashback. :(

Fred (eldmannen+launchpad) wrote :

Re: my previous post

The redshift-gtk app indicator now shows up in gnome-panel again when using gnome-session-flashback.

niedzwiedz (wiecz-m) wrote :

Still doesn't work in xubuntu 14.04, no app indicator in the panel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers