gtk-redshift don't work at startup

Bug #1188961 reported by Ihor Romanyshyn on 2013-06-08
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
redshift (Ubuntu)
Medium
Unassigned

Bug Description

The problem is to startup application 'redshift' with parameters like 'gtk-redshift -l geoclue -t 6500:4500'. This application can't run, while guake, dropbox, indicator-multiload (without parameters) works perfectly on any startup. Where I'm wrong?

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-session-bin 3.6.2-0ubuntu5
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
Date: Sat Jun 8 17:40:59 2013
ExecutablePath: /usr/bin/gnome-session-properties
InstallationDate: Installed on 2013-04-26 (42 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Ihor Romanyshyn (iromanyshyn) wrote :
Ihor Romanyshyn (iromanyshyn) wrote :
affects: gnome-session (Ubuntu) → redshift (Ubuntu)
summary: - Startup applications can't start with parameters
+ gtk-redshift don't work at startup
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in redshift (Ubuntu):
status: New → Confirmed
Eric Bartels (ebartels) wrote :

I just did a clean install of 13.10. I experienced two problems with gtk-redshift that prevented it from starting correctly. Both are related to to missing dependencies.

1) An error with geoclue. This problem also affected the command line redshift as well. The solution was to install geoclue-hostip.
see: https://bugs.launchpad.net/ubuntu/+source/redshift/+bug/868904

2) The second problem was another missing dependency. For me gtk-redshift would not show an app indicator in the panel unless python-appindicator was installed. For some reason python-appindicator is not listed as a dependency for gtk-redshift.

Install those two packages, and it should work.

Gatoso (gatoso) wrote :

I am havgin the same problem.

When I tried to launch gtk-redshift, I get:

$ gtk-redshift
(process:10232): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed

So, according to the previous post, I installed the package geoclue-hostip, but, now I get this:

$ gtk-redshift
Started Geoclue provider `Geoclue Master'.
Usando el proveedor `geoclue'.

** (process:10404): WARNING **: Could not get location, 3 retries left.

** (process:10404): WARNING **: Could not get location, 2 retries left.

e
** (process:10404): WARNING **: Could not get location, 1 retries left.

** (process:10404): WARNING **: Provider does not have a valid location available.
Incapaz de obtener localización desde el proveedor.

Then, I tried out installing the package: python-appindicator, but I am getting the same error, that one previously mentioned.

I can't start gtk-redshift

I am on Mint 15 (Ubuntu Raring), and KDE 4.10.5

Chris Kankiewicz (phlak) wrote :

Installing geoclue-hostip as Eric Bartels mentioned fixed this issue for me.

Daniel Hahler (blueyed) wrote :

@Ihor: it's not clear from your description, if it only fails during autostart for you?

I guess this could get closed as duplicate of bug 868904 probably.

Changed in redshift (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Mélodie (meets) wrote :

Hi,

For me redshift-gtk failed too, in Vivid:
installé : 1.9.1-4ubuntu1
Candidat : 1.9.1-4ubuntu1

I have pulled a strace out of it, which I include in the present bug report.

Looking into an Archlinux PKGBUILD for the package, seeing "librsvg" in the quoted depends, I did a search for "rsvg" and found "python-rsvg" whose description seemed to meet the need:

“This package contains a module that allows one to use librsvg to read and write SVG files from Python applications.”

And now, it is Ok to start, even from the menus.

I therefore suggest to add python-rsvg to the list of dependencies.
http://packages.ubuntu.com/vivid/python-rsvg

and in the previous editions of redshift-gtk too.

I am not finished yet, will try the other packages mentioned by ebartels. Also I don't know why the redshift-gtk I have doesn't provide any type of user interface configuration options to fine tune my config file. I have provided my configuration file as an example in this previous bug report (done just before this one):
https://bugs.launchpad.net/ubuntu/+source/redshift/+bug/1449421

Best regards,
Mélodie

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers