Apache::Authn::Redmine broken in precise

Bug #953981 reported by Jorge Salamero Sanz on 2012-03-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
redmine (Ubuntu)
Undecided
Unassigned

Bug Description

Apache::Authn::Redmine /usr/share/redmine/extra/svn/Redmine.pm is broken in precise, changes needed:

30c30
< aptitude install libapache-dbi-perl libapache2-mod-perl2 libdbd-mysql-perl libdigest-sha-perl
---
> aptitude install libapache-dbi-perl libapache2-mod-perl2 libdbd-mysql-perl
102c102
< use Digest::SHA;
---
> use Digest::SHA1;

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in redmine (Ubuntu):
status: New → Confirmed
Malte S. Stretz (mss) wrote :

It (looks like it) works for me. For a while already and nobody complained. Digest::SHA ist shipped with perl 5.14.2-6ubuntu2.2 (which Replaces libdigest-sha-perl). Maybe I did some magic to fix something up but can't really remember.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers