liblogthread-dev is missing pkg-config file

Bug #627291 reported by Florian Haas on 2010-08-31
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
redhat-cluster (Ubuntu)
Low
Unassigned
Lucid
Undecided
Unassigned

Bug Description

liblogthread-dev should contain a pkg-config description, /usr/lib/pkgconfig/liblogthread.pc. The upstream Debian package, version 3.0.12-2 has this file. It is absent from the current Ubuntu version, 3.0.2-2ubuntu3.

This breaks the build process for any packages using liblogthread functionality in conjunction with pkg-config.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: liblogthread-dev 3.0.2-2ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Aug 31 10:57:36 2010
SourcePackage: redhat-cluster

Florian Haas (fghaas) wrote :
Andres Rodriguez (andreserl) wrote :

Hi Florian,

Could you please provide me with any example package that uses liblogthread-dev to build so I can test, and provide the adequate fix.

Thank you!

Florian Haas (fghaas) wrote :

Andres, I'm not aware of any package that uses this at this point, but the missing pkg-config file is keeping me from building clusternet on ubuntu.

Try this:
git clone git://github.com/fabbione/clusternet.git
cd clusternet
./autogen.sh
./configure

and then you get:

checking for logt... configure: error: Package requirements (liblogthread) were not met:
No package 'liblogthread' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables logt_CFLAGS
and logt_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

liblogthread-dev is of course installed, it's just missing the appropriate .pc file.

Andres Rodriguez (andreserl) wrote :

Florian,

Thank you. I'll take care of this!

Changed in redhat-cluster (Ubuntu):
importance: Undecided → Low
status: New → In Progress
assignee: nobody → Andres Rodriguez (andreserl)
Andres Rodriguez (andreserl) wrote :

Florian,

Sorry for the delay. Do you still need this fixed?

Please test the new package that is located at my ppa, if you have the chance:

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:andreserl/ha

Andres Rodriguez (andreserl) wrote :

debdiff which fixes this is attached to bug #627174

Changed in redhat-cluster (Ubuntu):
assignee: Andres Rodriguez (andreserl) → nobody
status: In Progress → Confirmed
Martin Pitt (pitti) wrote :

Since maverick has 3.0.12-2ubuntu2, I assume this is fixed in maverick/natty.

Changed in redhat-cluster (Ubuntu):
status: Confirmed → Fix Released
Changed in redhat-cluster (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed

Accepted redhat-cluster into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package redhat-cluster - 3.0.2-2ubuntu3.1

---------------
redhat-cluster (3.0.2-2ubuntu3.1) lucid-proposed; urgency=low

  * SRUs:
    - debian/liblogthread-dev: Install missing pkg-config file (LP: #627291)
    - debian/rules: Remove drbd.sh and drbd.metadata because DRBD already
      ships them. (LP: #627174)
 -- Andres Rodriguez <email address hidden> Wed, 20 Oct 2010 12:44:43 -0400

Changed in redhat-cluster (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers