Please remove redhat-cluster (main) from the blacklist and sync from Debian

Bug #1033660 reported by Jeremy Bicha on 2012-08-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
redhat-cluster (Ubuntu)
High
Unassigned

Bug Description

Please remove redhat-cluster (main) from the blacklist and sync from Debian

Explanation of the Ubuntu delta and why it can be dropped:
The Ubuntu packaging has been incorporated into Debian's packaging.

  * New upstream release
  * debian/control:
    - add xsltproc to cman's deps
  * debian/cman.install:
    - install ccs_update_schema and it's man page
  * debian/cman.dirs:
    - create /var/lib/cluster
  * (LP: #956383)
  * debian/control: Depends on gfs2-utils.
  * debian/control: Depends on gfs2-utils.
  * New upstream release
  * debian/control:
    - Drop Build-Depends on pacemaker and cluster-glue.
    - Bump Build-Depends on corosync and openais.
    - Drop Depends on gfs-tools and gfs2-tools.
    - Build-Depends on libdbus-1-dev, openais-dev.
    - remove duplicated Section and Priority fields.
  * debian/rules:
    - Drop unnecessary configure flags
    - Drop drbd related rules.
    - Drop manual installation of cluster.rng.
  * Drop dlm-pcmk and gfs-pcmk.
    - debian/control: Drop control rules for such packages.
    - debian/{gfs,dlm}-pcmk.install: Dropped
  * Drop gfs-tools and gfs2-tools packages.
    - debian/control: Drop control rules for such packages.
    - debian/rules: Drop all related rules.
    - debian/{gfs,gfs2}-tools.*: Drop files.
    - debian/cman.install: Drop files; add missing.
  * Drop redhat-cluster-source package.
    - debian/control: Drop package
    - debian/redhat-cluster-source.*,redhat-cluster-modules-_KVERS_.postinst,
      debian/modass.redhat-cluster-source: Dropped.
    - debian/rules: Drop related rules.
  * debian/cman.install:
    - install cluster.rng, cluster.rng.in{tail|head}.
  * debian/rgmanager.install:
    - specify which files install on usr/share/cluster.
  * debian/patches:
    - 0001-add-dlm-kernel-headers.patch: Updated.
    - 0002-Fix-Default-Start-Stop-for-dependency-based-boot.patch: Updated.
    - 0003-Don-t-rely-on-chkconfig-and-check-for-network-manage.patch: Dropped.
    - 0004-Depend-on-remote_fs.patch: Refreshed.
    - 0005-Remove-bashisms-from-resource-scripts.patch: Dropped.
  * debian/copyright: Updated
  * debian/control: Depends on fence-agents and resource-agents.
  * Rebuild for Perl 5.14.
  * debian/cman.install: Install missing fence_node and fence_tools binaries
    and its manpages.
  * debian/cman.install: Install missing fenced binaries.
  * debian/control: Build-Depends on openais-dev.
  * debian/rgmanager.install: Drop installation of resource agents as they
    are now shipped in resource-agents package.
  * debian/cman.install: Drop installation of fence agents as they are now
    shipped in fence-agents package.
  * debian/rgmanager.install: Drop installation of resource agents as they
    are now shipped in resource-agents package.
  * debian/cman.install: Drop installation of fence agents as they are now
    shipped in fence-agents package.
  * Rebuild for Perl 5.12.
  * Enable pacemaker support. (LP: #702013)
  * debian/control: Add Build-Depends on cluster-glue-dev to prevent FTBFS.
  * Enable pacemaker support. (LP: #702013)
  * debian/control: Add Build-Depends on cluster-glue-dev to prevent FTBFS.
  * Disable pacemaker support. Fixes FTBFS (LP: #635884)
  * Disable pacemaker support. Fixes FTBFS (LP: #635884)
  * Resync from debian unstable. Fixes FTBFS (LP: #600984)
  * debian/gfs2-tools.links: Fix symlinks.
  * debian/control: Build-Depends on libltdl7-dev.

Changelog entries since current quantal version 3.1.8-0ubuntu1:

redhat-cluster (3.1.8-1) unstable; urgency=low

  [ Andres Rodriguez ]
  * New upstream release
  * Apply all the changes from Ubuntu.
  * Bump Standards Version.
  * debian/source/format: 3.0 (quilt).
  * Switch to dh 7.
    - debian/control: Bump debhelper build-dep.
    - debian/rules: Switch.

  [ Martin Loschwitz ]
  * Thanks a lot to Andres Rodrigues for all the great work he did on this!
  * Removed debian/control.modules.in and debian/upgrade.txt due to
    being unnecessary now or hopelessly outdated
  * Add myself to Uploaders: in debian/control
  * Switch to dh 9.
 -- Martin Loschwitz <email address hidden> Sun, 05 Aug 2012 08:13:00 +0000

Jeremy Bicha (jbicha) on 2012-08-06
Changed in redhat-cluster (Ubuntu):
importance: Undecided → Wishlist
Changed in redhat-cluster (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
Andres Rodriguez (andreserl) wrote :

ACK.

All my changes to this package in Ubuntu have been applied upstream and the package is ready to be removed from the backlist so we can start auto-sync it again.

Changed in redhat-cluster (Ubuntu):
assignee: Andres Rodriguez (andreserl) → nobody
importance: Wishlist → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in redhat-cluster (Ubuntu):
status: New → Confirmed
Changed in redhat-cluster (Ubuntu):
status: Confirmed → Fix Released
Dave Walker (davewalker) wrote :

I have merged the blacklist removal and performed a sync from Debian. I believe this resolved this bug.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers