recordmydesktop not compiled with jack

Bug #448027 reported by Fabus on 2009-10-10
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
recordmydesktop (Debian)
Fix Released
Unknown
recordmydesktop (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: recordmydesktop

recording audio with recordmydesktop using JACK is not possible
it says
"not compiled with Jack support"

note: gtk-recordMyDesktop allows for specifying the JACK params.

so the solutions would be: compile with JACK support (check using recordmydesktop --print-config afterwards) or strip JACK support from gtk-recordMyDesktop

but if you drop the JACK support, make sure it's supporting PulseAudio. Otherwise, and that's the current situation, you can either not record sound at all or have choppy sound (when it's using ALSA).

ProblemType: Bug
Architecture: i386
Date: Sat Oct 10 15:39:37 2009
DistroRelease: Ubuntu 9.10
Package: recordmydesktop 0.3.8.1-0ubuntu1
ProcEnviron:
 LANGUAGE=en_DK.UTF-8
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.43-generic
SourcePackage: recordmydesktop
Uname: Linux 2.6.31-13-generic i686
XsessionErrors:
 (gnome-settings-daemon:2969): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:3085): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:3064): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:3058): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.2/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

Fabus (fabian-gebert-hh) wrote :
produnis (schlarmann-uni-wh) wrote :

produnis@Smeargol:~$ recordmydesktop --print-config

recordMyDesktop was compiled with the following options:

Jack :Disabled
Default Audio Backend :ALSA

[Temporary Fix]
If you go back to version 0.3.7.3-1 of recordMyDesktop, which you can do by temporarily re-enabling the jaunty repositories in /apt/sources.list and using aptitude, you will find:

consultant@dell-laptop:~$ recordmydesktop --print-config

recordMyDesktop was compiled with the following options:

Jack :Enabled
Default Audio Backend :ALSA

I also reverted gtkRecordMyDesktop to version 0.3.7.2-2ubuntu2, but I'm not sure if that is neccessary. Suffice it to say that it all seems to work OK.

If you have the multiverse repository enabled your system might keep wanting to upgrade to the present vesrions which is a bit annoying.

Pablo Angulo (pablo-angulo) wrote :

I've tried to download the recordmydesktop source code and compile it with jack support:

-------
~$ ./configure --enable-jack=yes
~$ make
~$ sudo make install
-------

but recordmydesktop compiles without jack support:

------
src/./recordmydesktop --print-config

recordMyDesktop was compiled with the following options:

Jack :Disabled
Default Audio Backend :OSS
------

I've installed all dev libraries, including libjack-dev, of course. There's no error message during configure or make. After I run "./configure --enable-jack=yes", I get the following message:

****************************************

Audio driver that will be used: ALSA

Compile with Jack support: Enabled

****************************************

I've also tried compiling with OSS without success.

Pablo Angulo (pablo-angulo) wrote :

Found this problem in the recordmydesktop forum (2009/02):

http://sourceforge.net/projects/recordmydesktop/forums/forum/590957/topic/2989612

but no solution was found.

Pablo Angulo (pablo-angulo) wrote :

I'm glad to report I was wrong: in the link above a solution is found. Some people reported it didn't work for them, but calling:

./configure --prefix=/usr --enable-jack=yes LIBS=-ljack CFLAGS=-DHAVE_LIBJACK

got me a fully jack-compatible recordmydesktop.

MMarking (cpt-mocha) wrote :

Thanks Pablo.

autostatic (autostatic) wrote :

Please fix JACK support for recordMyDesktop. A patch can be found here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=544699#10
And maybe the following patch is useful too, it's a patch to make recordMyDesktop use sane defaults because 0.3.8 doesn't: https://bugzilla.redhat.com/show_bug.cgi?id=525155#c16

Best,

Jeremy

autostatic (autostatic) wrote :

And the patch for the sane defaults.

autostatic (autostatic) wrote :

It's been over a week I posted the patches. Has anybody taken a look at them yet? I've uploaded a patched version to my own PPA and it compiles just fine. Please pick this up, thanks!

Best,

Jeremy

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package recordmydesktop - 0.3.8.1+svn602-1ubuntu1

---------------
recordmydesktop (0.3.8.1+svn602-1ubuntu1) lucid; urgency=low

  * Merge from Debian unstable, remaining changes:
    + config.guess: Retain compatibility secion, can be dropped
      post-10.04
    + src/rmd_types.h: Use 'default' as the standard ALSA virtual
      device to work both with and without PulseAudio (Ubuntu and
      Kubuntu/Xubuntu, respectively).
  * Separated Ubuntu changes into dpatches.
  * This version is compiled with jack support (LP: #448027).

recordmydesktop (0.3.8.1+svn602-1) unstable; urgency=low

  * New version from upstream svn (Closes: #549263, #544699)
  * Added build dependency on dpatch to apply different patches
  * Modified debian/rules to use dpatch
  * debian/patches/01_update_includes.dpatch update Xorg includes
  * debian/patches/02_fix_new_theora.dpatch (Closes: #548631, #559648)
  * debian/control: bumped standards version to 3.8.4.
 -- Ilya Barygin <email address hidden> Wed, 10 Feb 2010 22:04:02 +0300

Changed in recordmydesktop (Ubuntu):
status: New → Fix Released
autostatic (autostatic) wrote :

Thanks! And before the freeze so hopefully this will make it in the final version of Lucid.

Thanks again,

Jeremy

Changed in recordmydesktop (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.