Recoll crashing during initial index scan

Bug #994228 reported by T_W on 2012-05-03
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
recoll (Ubuntu)
Undecided
Unassigned

Bug Description

Recoll is crashing during the initial index scan with an error:

terminate called after throwing an instance of 'std::ios_base::failure'
  what(): basic_ios::clear
Aborted (core dumped)

Recoll was indexing files in .thunderbird when the crash occurred. It seemed to be indexing the INBOX file on disk.

~$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

~$ apt-cache policy recoll
recoll:
  Installed: 1.16.2-1
  Candidate: 1.16.2-1
  Version table:
 *** 1.16.2-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: recoll 1.16.2-1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia wl
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Thu May 3 16:15:40 2012
ExecutablePath: /usr/bin/recoll
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: recoll
UpgradeStatus: No upgrade log present (probably fresh install)

T_W (walshtc) wrote :

Hi,

I'm the Recoll developer.

Does the crash reoccur if you restart indexing ? At the same place ?

Were you doing something else with the GUI apart from indexing when it crashed (1.16 was a bit touchy about this) ?

Can you reproduce this with the recollindex command line program or is it only a GUI thing ?

The last messages from the debug log would be very useful. There are indications about collecting useful Recoll crash data here: https://bitbucket.org/medoc/recoll/wiki/ProblemSolvingData

I'll be away for the following week, but willing to help as soon as I'm back.

jf

T_W (walshtc) wrote :

Thank you Jean-Francois.

The issue was fully reproducible in the GUI and always seemed to crash in the same place. I worked around it by excluding the .thunderbird directory from the indexing.

I will attempt to reproduce with the command line and capture debugging.

I wanted to try out the recoll lense and upgraded to the 1.17.0 version from the PPA. I will see if the issue still occurs in 1.17.0 and downgrade if necessary.

If you want to try out the Lens, make sure that you have the 1.17.1 package from the PPA (should be default), it has a small Lens-related improvement. The GUI will still say 1.17.0 (known fixed bug).

Hi,

I just released recoll 1.17.3 which fixes an email indexing crash, hopefuly the same as yours.

The packages on the recoll PPA will be updated when the build servers get to it, it would be nice if you could try 1.17.3 and tell if it fixes your crash.

jf

T_W (walshtc) wrote :

I upgraded to 1.17.3 and did both an "Update Index" and a full "Rebuild Index" without issue. The process fully scanned my .thunderbird directory and I see the messages in search results.

Looks like your fix is working for me.

Thank you

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in recoll (Ubuntu):
status: New → Confirmed
T_W (walshtc) wrote :

Fixed in 1.17.3

Changed in recoll (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers