Ubuntu wont boot or install due to incorrect monitor detection - bad EDID

Bug #991068 reported by doobydave on 2012-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
read-edid (Ubuntu)
Medium
Unassigned

Bug Description

As summary, monitor displays dark purple flashing screen.

Am unable to use console ctrl+alt+f1 - though maybe it's merely invisible rather than not there. - I could possibly test this via a blind login and reset command

Video card is an nvidia 8800 gtx, monitor is an iiyama vision master pro 510 being used with a dvi to rgb converter.

Tested on 12.04 x64, but this issue has been the same for all releases since 10.04
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: doobz 1576 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfb000000 irq 45'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,1458a002,00100101'
   Controls : 38
   Simple ctrls : 20
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=0a9ea90a-360a-4888-bdd7-3636cb0f9232
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Gigabyte Technology Co., Ltd. P35-S3G
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=e57566a6-35f9-48d4-854b-68e581f05406 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic-pae N/A
 linux-backports-modules-3.2.0-23-generic-pae N/A
 linux-firmware 1.79
RfKill:

SourcePackage: linux
Tags: precise precise
Uname: Linux 3.2.0-23-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/28/2007
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F3a
dmi.board.name: P35-S3G
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF3a:bd12/28/2007:svnGigabyteTechnologyCo.,Ltd.:pnP35-S3G:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP35-S3G:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: P35-S3G
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/991068/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 991068

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

I am unable to run any commands.

I did switch to another monitor after hitting ctrl-alt-f1, and surprising there was a flashing cursor with which I could type. There was no login prompt.. Ctrl-alt-f7 yielded a portion of what appears to be the hung loading screen.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: lucid natty oneiric precise
doobydave (dooby-dave) wrote :

Hi.

It would appear that 12.04 CD boots with acpi=off specified.

I am now at the stage where I have an installed OS that won't boot. I get to a flashing grey screen now. The upside is that I can now perform a blind login and issue a shutdown (I have tried switching monitors to see command line, but it is a basic one and reports an incorrect resolution).

If I can setup ssh (blindly, of course), I should be able to login remotely and run the apport command.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

It turns out I can boot the system using the 'nomodeset' flag. All is not well, however - the machine will hang if I use ctrl-alt-f1 to jump to a terminal.

doobydave (dooby-dave) wrote :

Looking through Xorg.0.log (attached) it appears that many resolutions are set at 0.0Hz

doobydave (dooby-dave) wrote :

Just realised I made an error describing the adapter I am using. It is a DVI to VGA rather than DVI to RGB.

So sorry if it's caused any confusion.

doobydave (dooby-dave) wrote :

Just to add, I have a thread about this bug over here
http://ubuntuforums.org/showthread.php?t=1981935

doobydave (dooby-dave) on 2012-05-19
summary: - Ubuntu wont boot or install due to incorrect monitor setup
+ Ubuntu wont boot or install due to incorrect monitor detection - bad
+ EDID
doobydave (dooby-dave) wrote :

I'm taking it upon myself to say the bug resides within the read-edid software.

affects: linux (Ubuntu) → read-edid (Ubuntu)
doobydave (dooby-dave) wrote :

I imagine I'm going to keep bothering you every year or two until either myself or my monitor dies. (or this issue gets resolved.)

My monitor is incorrectly identified as it's slightly smaller brother. No biggie, you might think - except that all modern distros refuse to play nice. Add a dvi to vga converter and they try to drive it as though it were an LCD.

On what basis you state that this is read-edid's fault ? It is just a tools, it has nothing to do with X starting or system boot.

It is not read-edid's fault.

Changed in read-edid (Ubuntu):
status: Confirmed → Incomplete
Changed in read-edid (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers