rdesktop has black cursor instead of white cursor

Bug #385974 reported by fireworld2406 on 2009-06-11
186
This bug affects 34 people
Affects Status Importance Assigned to Milestone
rdesktop
Unknown
Unknown
rdesktop (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by nsrderooy

Bug Description

1) I am using Ubuntu 904
2) The version of rdesktop is 1.6.0-2ubuntu1
3) I expected a white cursor
4) I got a black cursor

The black cursor can make it hard to use some of the programs!

It isn't a problem with the terminal server; accessing from a Windows Remote Desktop Connection client works fine.

Please let me know if you need any more information!

Anyone?

David Tombs (dgtombs) wrote :

Which cursor? The default, pointer cursor? Is your standard Ubuntu cursor black?

I have an issue with cursors not being updated correctly, but it's only in special circumstances, such as a black I-Beam cursor on a black text box.

Yes, the default, pointer cursor is what is black. The standard Ubuntu cursor is white.

It seems that the cursor colors are inverted. When the cursor should be a black I-beam (ie. when over text), it is white, and when the cursor should be white, it is black.

David Tombs (dgtombs) wrote :

That's a different bug than mine, sorry.

David Tombs (dgtombs) wrote :

Perhaps can you post the command line you use to start rdesktop?

I tend to use the tsclient gui frontend more than the command line, but when I do use the command line, I use the following:

rdesktop 192.168.2.111 -f -a 16

I am pretty sure that also roughly corresponds to the options I choose in tsclient.

David Tombs (dgtombs) wrote :

Can't reproduce with those settings here. Can you reproduce connecting to a different server?

What is your root window's bit depth? (xdpyinfo | grep "depth of root window")

Not that I know anything about rdesktop, just pulling at straws. :)

>Can't reproduce with those settings here. Can you reproduce connecting to a different server?

The best I can do is to reboot my terminal server into Server 2008. There is no way I can test on another Server 2003 terminal server (I got Server 2003 & 2008 through Microsoft's Dreamspark program, and only one license is provided for each).

>What is your root window's bit depth? (xdpyinfo | grep "depth of root window")

I'll check that, but I am pretty sure it is 24-bits.

>Not that I know anything about rdesktop, just pulling at straws. :)
Better than nothing!

Thank you for your help so far!

OK. Here is what I can tell you:

>Can't reproduce with those settings here. Can you reproduce connecting to a different server?

I rebooted my server into Server 2008 and got the same results: inverted cursor.

>What is your root window's bit depth? (xdpyinfo | grep "depth of root window")

Output is: depth of root window: 24 planes

robled (robled) wrote :

I can reproduce this bug on Jaunty while connecting to Windows 7. The default "Aero" cursor on Windows 7 shows the proper white color but has a very bad lag to it. The solution to this problem is to change the cursor theme to "none", which fixes the lag but the cursor color turns black even though it's supposed to be white.

art (art-poorcoding) wrote :

I'm experiencing the same as NTolerance.

I'd like to add that if I change the Windows 7 Cursors to Inverted, it becomes outlined in black, with an invisible body. It also looks garbled with some other cursors, with "garbage pixels" around the cursor. Worse still, the text input cursor is mangled no matter which cursor theme is chosen, to the point of barely being able to see/use it.

Painful!

robled (robled) wrote :

See this ubuntuforums post for a partial workaround I found:

http://ubuntuforums.org/showpost.php?p=7840208&postcount=13

Note that it fixes the default Aero pointer, but the text input and other context cursors are still black.

Jesse Gilles (jesse-gilles) wrote :

I have this problem using rdesktop on Jaunty to connect to an XP workstation. Cursor colors are inverted. The default white Windows cursor shows up as black and if I switch the cursor scheme in Windows to black, the cursor appears as white in rdesktop. This probably started for me after switching from Hardy to Jaunty. The workaround mentioned for Windows 7 had no effect (unsurprisingly).

Changed in rdesktop (Ubuntu):
status: New → Confirmed
Ryan Ticer (ryan8613) wrote :

I am also having this issue:

Client Machine:

Linux Alexia 2.6.28-15-generic #52-Ubuntu SMP Wed Sep 9 10:48:52 UTC 2009 x86_64 GNU/Linux

ryty@Alexia:~$ rdesktop 10.2.4.35
Autoselected keyboard map en-us
WARNING: Remote desktop does not support colour depth 24; falling back to 16

I also tried -z and -x 0x80 with no positive result.

the Terminal Server is Windows Server 2008 R2.

Thanks!

Ryan Ticer

Sam Powers (sam-rm-r) wrote :

Windows 7 or Windows Server 2008 R2 both have this issue with cursor masking. I don't think it's inverted. The screenshot shows a black cursor with no white outline. If it were inverted, the outline would be present.

What we're getting is the shape of the cursor, but not the bitmap that would normally go with it. I tried switching to various cursors and all of them were just showing the mask.

I tried configuring the server to allow all types of color depths, and tried connecting at my native desktop depth of 24 bits, and this did not fix the issue. I also tried 15, 16, and 32 combinations.

This issue doesn't exist when connecting to a Server 2008 R1 server, so it's some R2/Win7 change that did it. Hoping for an upstream fix soon.

>This issue doesn't exist when connecting to a Server 2008 R1 server, so it's some R2/Win7 change that did it. >Hoping for an upstream fix soon.

It exists in 2008 R1 also (at least for me). I created this bug because of this issue being present in R1.

as well as Server 2003

m-briosi (m-briosi) wrote :

Here's the upstream bug on rdesktop's sf.net page:

http://sourceforge.net/tracker/index.php?func=detail&aid=2858665&group_id=24366&atid=381347

I can confirm this bug on Win 2008 R2 but, strangely enough, not on Win 7.

lordmundi (frankieg) wrote :

I can confirm on windows 7... same history as others. Extremely laggy mouse on windows 7... switched mouse scheme to "None" and got performance back but now have corrupted mouse pointer exactly as described by others.

David Burgess (apt-get) wrote :

Confirmed here connecting from Ubuntu 9.04 and 10.04 alpha3 to Windows Server 2008 R2 with Desktop Experience installed and Aero theme active. Mouse pointer appears all black. Choosing another pointer theme yields all black or all white pointer, sometimes with noise.

Petri Kutvonen (kutvonen) wrote :

I can confirm this on Ubuntu 9.10 with Win 2008 R2 server.
There is a patch on sf.net which fixes the bug (with some limitations):

http://sourceforge.net/tracker/?func=detail&aid=2884937&group_id=24366&atid=381349

I applied this patch on yesterday's CVS version (succeeds with fuzz).
The resulting rdesktop with the new -M command line option seems to work
perfectly.

ricolai (ricolai) wrote :

Confirmed on Ubuntu 10.04 with the repository version, trying to connect to a Windows Server 2008 R2.

Solved by using the last CVS version (rev1593), with no need to apply the patch mentionned by #21.

David Tombs (dgtombs) wrote :

fireworld2406, can you also confirm it's fixed from CVS version?

ricolai (ricolai) wrote :

For convenience and simplicity of reuse, I've put rdesktop rev1593 in my PPA.
Binaries available for i386 and amd64.

ppa:ricolai/ppa

Simply add it with apt-add-repository and update your packages.

m-briosi (m-briosi) wrote :

ricolai -> Thank you very much for the .deb

I confirm that rev1593 solves the problem.

nsrderooy (nsrderooy) wrote :

Thanks for the fix hope it get's accepted soon

thefluxster (buy-ikentech) wrote :

ricolai's fix worked great for me. Thanks for making it easier to workaround. Here's to hoping it gets dropped to the main repos soon too!

Hi ricolai.

You have to send me a link to download the rdesktop. Deb?

10.04 I'm using Ubuntu server.

Thank you.

Fernando Guse.

thefluxster (buy-ikentech) wrote :

Noticed that ricolai's PPA has been emptied so I updated my blog post to point to the DL'ed binaries. Full blog post is here:
http://linuxforkeysers.blogspot.com/2010/08/black-cursors-on-win72008-r2-using.html

Robert (anon-razza) wrote :

Bug is still around in Maverick.

I can confirm that I have the same bug in Maverick. I have noticed it only on windows 7 edition. Connecting to xp or server 2003 is ok.

Morten Abildgaard (mortn) wrote :

Confirming black pointer when connecting to Win 2008 R2 (Win 2008 is okay) with rdesktop version 1.6.0-3ubuntu2 (current version for out-of-the-box Maverick). I'd rather wait for the bug to be fixed in main repos than adding PPA's.

Steve Kerrison (stevekerrison) wrote :

#29's binary has fixed the problem for me.

jsass (sass-joel) wrote :

This bug is still here, and #29's fix hosted on his web site just fixed my problem.

eduardo (eddy-paredes) wrote :

The bug is still there on Ubuntu 11.04 Natty Narwhal (updated to)

Chris Horry (zerbey) wrote :

It's a bug in tsclient and rdesktop, download the 1.7.0 version of rdesktop and compile from source. I don't think it's fixed in tsclient.

ssepiro (ssepiro) wrote :

rdekstop 1.7.1 fixed all without drawing aero theme.

Mikael Hjelm (j-m-hjelm) wrote :

I am having this issue with rdesktop 1.7.0 is that expected or do i have another problem?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.