Ubuntu

rdesktop not compiled with smartcard support

Reported by Corey Seliger on 2008-05-05
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
rdesktop (Debian)
Fix Released
Unknown
rdesktop (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: rdesktop

Trying to run rdesktop as so:

  rdesktop -r scard my.terminal.server

It returns:
  WARNING: Not compiled with smartcard support

Smartcard support is supported in rdesktop 1.5.0, but the compile time option below needs
to be run during configure:

  --enable-smartcard

More Info:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"

rdesktop:
  Installed: 1.5.0-3+cvs20071006
  Candidate: 1.5.0-3+cvs20071006
  Version table:
 *** 1.5.0-3+cvs20071006 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

cornelinux (cornelius-koelbel) wrote :

I'd like to see this, too! :)

It is really no big hassle.

karaluh (karaluh) wrote :

Still not fixed in Jaunty

Changed in rdesktop (Ubuntu):
status: New → Confirmed
karaluh (karaluh) wrote :

Still not fixed in Karmic

Fabian Köster (maestro-alubia) wrote :

I filed a bug in the Debian bug-tracker.

Although I am not the maintainer of this package, I assume this is not a trivial change due to the fact that one need to split the binary-package into two packages: rdesktop and rdesktop-smartcard. I think most people will not use smartcard support and do not want rdesktop-smartcard because of the extra dependency to pcsc.

Changed in rdesktop (Debian):
status: Unknown → New
cyril (mescheryakov) wrote :

still not fixed in Lucid

please do at least something

version of maestro_alubia seems to me a good

Changed in rdesktop (Debian):
status: New → Fix Released
Fabian Köster (maestro-alubia) wrote :

Is it possible to get Debian's fix into Precise or is it too late?

Derek (bugs-m8y) wrote :

+1 for this.
BTW, I installed the debian sid .deb into Oneiric and it worked fine with the smartcard (ActivIdentity) after installing pcscd

Fabian Köster (maestro-alubia) wrote :

I can confirm that the following steps fix this problem:

1.) wget http://ftp.de.debian.org/debian/pool/main/r/rdesktop/rdesktop_1.7.1-1_amd64.deb
2.) sudo dpkg -i http://ftp.de.debian.org/debian/pool/main/r/rdesktop/rdesktop_1.7.1-1_amd64.deb
3.) sudo apt-get install pcscd
4.) Edit /etc/init.d/pcscd and comment out line "exit 0"
5.) sudo /etc/init.d/pcscd restart

tags: added: patch precise
Fabian Köster (maestro-alubia) wrote :

I created a PPA for rdesktop-with smartcard support. It is just a rebuild of rdesktop in Debian.

https://launchpad.net/~maestro-alubia/+archive/rdesktop-smartcard

With Debian sync this fix is now in Quantal.

Changed in rdesktop (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.