Ubuntu

tsclient generates System pointer message 0x7f00

Reported by Zaheer Dollie on 2005-09-27
38
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rdesktop
Unknown
Unknown
rdesktop (Ubuntu)
Medium
Unassigned
tsclient (Ubuntu)
Undecided
Unassigned

Bug Description

When closing the tsclient down(with alt + F4 or the "x") i keep getting the
following error message: "NOT IMPLEMENTED : System pointer message 0x7f00"
I installed edubuntu preview edition(ubuntu 5.10) as a workstation install type,
inside vmware workstation.

http://sourceforge.net/tracker/index.php?func=detail&aid=1306611&group_id=24366&atid=381347: http://sourceforge.net/tracker/index.php?func=detail&aid=1306611&group_id=24366&atid=381347

Zaheer Dollie (h1d3ki) wrote :

Created an attachment (id=4124)
tsclient error on close

screenshot of error message when i close tsclient.

Craig Box (craig.box) wrote :
yht (jopaqwe) wrote :

Similar mistake in kerberos, but rdesktop -E

Aaron Whitehouse (luna-tick) wrote :

I think that the duplicate status of this bug (of Bug 8422) is incorrect.

This bug relates to System pointer message 0x7f00, which is not addressed in the other bug. More importantly, the other bug is related to VNC while this bug is related to RDP connections to Windows 2003. The upstream bugs are completely different and are not duplicates.

Aaron Whitehouse (luna-tick) wrote :

Note that, if I connect to the same server with rdesktop from the command line, the only error that I get is:
WARNING: Remote desktop does not support colour depth 24; falling back to 16
and nothing about 0x7f00.

Aaron Whitehouse (luna-tick) wrote :

I am getting this error on an up-to-date Gobuntu Gutsy install.

Aaron Whitehouse (luna-tick) wrote :

Also, see Bug #66997

Changed in tsclient:
assignee: dholbach → nobody
Changed in tsclient:
status: New → Confirmed
marco.pallotta (marco-pallotta) wrote :

Same error appears in Hardy Heron x86_64. I 'm posting a screenshot of the error.

Laurent Bigonville (bigon) wrote :

this is a rdesktop issue, reassigning

Rob (robklg) wrote :

I also always get this error on Intrepid when connecting to Windows 2003 server (many different servers).

When I change the protocol to 'RDP' instead of 'RDPv5', no error.

Rob (robklg) wrote :

Sorry.. accidentally clicked on the button 'this problem also needs fixing here', thereby undoing Laurent's change... sorry.

pierpmi (pierbrun) wrote :

when launched from command line :
** (tsclient:21413): WARNING **:
WARNING: Remote desktop does not support colour depth 24; falling back to 16

(tsclient:21413): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.18.2/gobject/gsignal.c:2384: instance `0xa0af108' has no handler with id `1251'

dominix (dominix-pub) wrote :

Same problem for me with "system pointer message at 0x7f00" on ubuntu 8.10. this problem does not appear on Debian Lenny

Mike Chaberski (mchaberski) wrote :

I'm on Lenny and I get this every time. Always connecting to a Windows Server 2003 box. (I don't have any other remote Windows servers to try it on, so I can't say what happens otherwise.) I connect through grdesktop.

The message is:
---
Autoselected keyboard map en-us
WARNING: Remote desktop does not support colour depth 24; falling back to 16
NOT IMPLEMENTED: System pointer message 0x7f00
X Error of failed request: BadAtom (invalid Atom parameter)
  Major opcode of failed request: 23 (X_GetSelectionOwner)
  Atom id in failed request 0x0
  Serial number of failed request: 78591
  Current serial number in output stream: 78591
---

Some info about me:

$ dpkg -l grdesktop rdesktop
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-====================-====================
ii grdesktop 0.23+d040330-1 GNOME frontend for the rdesktop client
ii rdesktop 1.6.0-2 RDP client for Windows NT/2000 Terminal Server

$ cat /proc/version
Linux version 2.6.26-1-amd64 (Debian 2.6.26-13) (<email address hidden>) (gcc version 4.1.3 20080704 (prerelease) (Debian 4.1.2-24)) #1 SMP Sat Jan 10 17:57:00 UTC 2009

AndreK (andre-k) wrote :

same problem still on 10.04
- the color bug can be solved by forcing 16bit colors in "display" tab.
- tha "badatom" problem remains anyway - and produces the error..

everon (metare-cicleiro) wrote :

Same problem appear in ubuntu 10.10 i386.

I solved this problem changing the protocol RDP to RDPv5.

It`s works perfectly now.

Jeremy Bicha (jbicha) on 2011-08-14
Changed in tsclient (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.