rdesktop ctrl key gets stuck on randomly

Bug #179846 reported by Matthew Saunders on 2008-01-02
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
remmina
Unknown
Unknown
rdesktop (Debian)
New
Undecided
Unassigned
rdesktop (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: rdesktop

When using rdesktop the ctrl key gets stuck at random times. The work around to the problem is to minimize rdesktop and then maximize it. The problem is realised when I double click programs as this pops up the properties page instead of launching the App.

I have a German keyboard mapped on the Ubuntu Gutsy PC, hence the -k en-gb parameter. The keyboard layout works fine on the hosts I connect to. I usually have around 5 remote desktop sessions open all day long, so rdesktop gets some good use. I have a script that launches rdesktop which is below.

Parameters used with rdesktop:

rdesktop HOSTNAME -g 1280x1024 -a 24 -u administrator -k en-gb -D -0 -r sound:local -p-

MountainX (dave-mountain) wrote :

I can confirm this bug. I'm using a US en keyboard and Gutsy. I thought the problem was because I had swapped the capslock and ctrl keys.

The problems with keyboard layout options and rdesktop are worse in Hardy than they were in Gutsy. I will make separate bug reports on the other issues.

cse (cseres) wrote :

I can confirm the bug. I am using the following command:

rdesktop -T Machine1 -rsound:local -b 10.0.0.1 -r disk:desktop=/home/cse/Desktop/ -u administrator

Alex (akruth) wrote :

I had this bug on gutsy and it is also on hardy.

Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in rdesktop:
assignee: nobody → andreas-moog
status: New → Incomplete
Andreas Moog (ampelbein) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in rdesktop:
assignee: andreas-moog → nobody
status: Incomplete → Invalid
Ronan (ronan-rocketmail) wrote :

I confirm the bug. I am using the last available version to Ubuntu Hardy 8.04 and keyboard pt-br:
ii grdesktop 0.23+d040330-1 GNOME frontend for the rdesktop client
ii rdesktop 1.5.0-3+cvs20071006 RDP client for Windows NT/2000 Terminal Server

Sometime ctrl key works and sometime doesn't.

Ronan

Changed in rdesktop:
status: Invalid → Confirmed
Thomas Jagoditsch (tja) wrote :

confirmed on a Hardy LTSP Server with german Keyboard connecting a w2k3 terminal server.
25 users have problems with ctrl usually trying to cut&paste.
3 users have problems using a applikation which often will interpret repeating cursor-down's as return-key.
all users are located in the same lan - users on a remote location connected via openvpn have no such problems but are using a gutsy ltsp server.
will try to downgrade to gutsy's rdesktop version and report.

David Oftedal (rounin) wrote :

I've had a stuck ctrl key that may be related the "hotkeys-setup" service. The following messages appeared in dmesg:

[4335062.871000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
[4335063.546000] atkbd.c: Unknown key pressed (translated set 2, code 0xaa on isa0060/serio0).
[4335063.546000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
[4335063.607000] atkbd.c: Unknown key released (translated set 2, code 0xaa on isa0060/serio0).
[4335063.607000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
[4335073.996000] atkbd.c: Unknown key pressed (translated set 2, code 0xaa on isa0060/serio0).
[4335073.996000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
[4335074.114000] atkbd.c: Unknown key released (translated set 2, code 0xaa on isa0060/serio0).
[4335074.114000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.

Disabling hotkeys-setup took care of the error messages, and appears to have solved the problem.

David Oftedal (rounin) wrote :

No wait, it's back again. It just took a little longer than usual. The error messages are back, too.

Mathias (mathias-me) wrote :

This bug also affects me.
Kernel: 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux
Using rdesktop through remmina
rdesktop 1.6.0-2ubuntu2
remmina 0.7.3-0~ppa1
remmina-gnome 0.7.1-0~ppa1

tinahouse (tinahouse) wrote :

Any body affected by this bug could try to compile rdesktop from latest SVN? Looks like there were related fixes upstream but rdesktop haven't get a release version for a very long time.

Mathias (mathias-me) wrote :

tinahouse: Sorry, did not notice that the build on the rdesktop page is rather old.
I just compiled it and will test it the next days.

Mathias (mathias-me) wrote :

Problem still exists.
The rdesktop SVN version of the 2nd feb 2010 has still the same problem.
Sometimes (around 5 times a day) a key got "stuck" and when hitting the alt, ctrl or windows key several times it works again.
Is there anything I can do to give you more information to debug the problem ?

I still have this problem on 10.10 using remmina. Hitting ctrl several times works around the problem

DaleEMoore (daleemoore) wrote :

Ubuntu 11.04 still has this same bug with both rdesktop and remmina.

root@RyCycle:~# dpkg -l rdesktop
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii rdesktop 1.6.0-3ubuntu4 RDP client for Windows NT/2000 Terminal Serv

root@RyCycle:~# dpkg -l remmina
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii remmina 0.9.3-2 remote desktop client for GNOME desktop envi

Seeing this too, in 12.04. It seems to happen much more often with remmina 1.0.0. Going to have to go back to older remmina and try that - this bug is VERY distracting and time-wasting. Haven't found a workaround yet. Minimize didn't seem to work.

It seems to happen most often when clicking and activating the Remmina window after having had focus on another window.
(And Remmina jumps to a different workspace half the time - which adds to the aggravation but that's a different issue I think.)

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-===========================-===========================-======================================================================
ii rdesktop 1.7.0-1ubuntu2 RDP client for Windows NT/2000 Terminal Server
--------------------------------------------------------------------------------------------------------------------------- 15:17:39
rgd@ComposerDevZPro:~$ dpkg -l remmina
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-===========================-===========================-======================================================================
ii remmina 1.0.0-1ubuntu6.1 remote desktop client for GNOME desktop environment
--------------------------------------------------------------------------------------------------------------------------- 15:17:46
rgd@ComposerDevZPro:~$

(See also https://bugs.launchpad.net/ubuntu/+source/remmina/+bug/993432 - about workspace jumping issue, but it also mentions Super key getting stuck.)

I'm guessing that changes made in rdesktop xwin.c (1512) for 1.7.0 (adding set_keypress_keysym and reset_keypress_keysym) were meant to address this issue but don't quite catch all the problem cases. Anyone able to build rdesktop in with debug (configure --help for info) and see if the debug messages around lines 2341 and 2358 ( http://rdesktop.svn.sourceforge.net/viewvc/rdesktop/rdesktop/trunk/xwin.c?revision=1512&view=markup ) reveal anything useful? Is it reapplying the modifiers in situations it shouldn't be, e.g. For me it seems to be when activating the window.

Andre Haas (andre-ca3t8a) wrote :

I have this bug frequently with KRDC, only workaround I've found is to unfullscreen then re-fullscreen, which is quite tedious and annoying.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.