rax-nova-agent causes a systemd ordering cycle on boot

Bug #1788716 reported by Dan Watkins on 2018-08-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rax-nova-agent (Ubuntu)
Critical
Balint Reczey
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

 * Booting a cloud instance first time in Rackspace's Cloud fails due to systemd breaking the service ordering cycle and not running cloud-init to provision the instance.
 * Without backporting the fix new instances can't boot.

[Test Case]

 * Prepare an instance image with rax-nova-agent preinstalled and boot in Rackspace's network.

[Regression Potential]

 * The fix may drop too many service dependencies resulting an image that does not boot.

[Original Bug Text

When booting an instance with it installed, I see the following in the log:

Aug 23 20:37:29 ubuntu systemd[1]: nova-agent.service: Found ordering cycle on basic.target/start
Aug 23 20:37:29 ubuntu systemd[1]: nova-agent.service: Found dependency on sockets.target/start
Aug 23 20:37:29 ubuntu systemd[1]: nova-agent.service: Found dependency on uuidd.socket/start
Aug 23 20:37:29 ubuntu systemd[1]: nova-agent.service: Found dependency on sysinit.target/start

(I believe the source of the issue is https://github.com/Rackspace-DOT/nova-agent/commit/73d8ef1a6256ff05151603ff53bcb018bfdfcc9b, which changes the ordering with respect to cloud-init-local.service.)

Balint Reczey (rbalint) on 2018-08-24
Changed in rax-nova-agent (Ubuntu):
assignee: nobody → Balint Reczey (rbalint)
status: New → In Progress
Balint Reczey (rbalint) on 2018-08-24
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rax-nova-agent - 2.1.15-0ubuntu2

---------------
rax-nova-agent (2.1.15-0ubuntu2) cosmic; urgency=medium

  * Drop dependency on python3-systemd, it is not needed with latest upstream
  * Use DefaultDependencies=no to prevent forming service ordering cycles
    (LP: #1788716)

 -- Balint Reczey <email address hidden> Fri, 24 Aug 2018 19:45:45 +0200

Changed in rax-nova-agent (Ubuntu):
status: In Progress → Fix Released
tags: added: id-5b353428bfb7efec1f1c6e8d
Balint Reczey (rbalint) wrote :

Rackspace reported success in testing the updated package.

Hello Dan, or anyone else affected,

Accepted rax-nova-agent into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rax-nova-agent/2.1.15-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rax-nova-agent (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Dan, or anyone else affected,

Accepted rax-nova-agent into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rax-nova-agent/2.1.15-0ubuntu1~16.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rax-nova-agent (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
tags: added: id-5b8703f921e7ee34fc8eb547
Łukasz Zemczak (sil2100) wrote :

Hello Dan, or anyone else affected,

Accepted rax-nova-agent into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rax-nova-agent/2.1.15-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Balint Reczey (rbalint) wrote :

Verification of LP: #1783614 for Xenial included verification steps of this bug, thus setting tags accordingly.

tags: added: verification-done verification-done-bionic verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-xenial

The verification of the Stable Release Update for rax-nova-agent has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rax-nova-agent - 2.1.15-0ubuntu1~16.04.1

---------------
rax-nova-agent (2.1.15-0ubuntu1~16.04.1) xenial; urgency=medium

  * debian/rules: Use dh --with systemd to add .service handling to maintainers cripts

rax-nova-agent (2.1.15-0ubuntu1~16.04.0) xenial; urgency=medium

  * Rebuild for Xenial
  * Use compat level 9 build-depending on debhelper (>= 9) and dh-systemd
  * Use DefaultDependencies=no to prevent forming service ordering cycles
    (LP: #1788716)
  * Clean up after rax-openstack-guest-agents in postinst

rax-nova-agent (2.1.15-0ubuntu1) cosmic; urgency=medium

  * New upstream version 2.1.15 (LP: #1783614)
  * debian/gbp.conf: Declare repository layout
  * Refresh patches

rax-nova-agent (2.1.13-0ubuntu3) bionic; urgency=medium

  * Drain the events queue, until there are no more events, for at least 3
    iterations, before sending started notification. LP: #1765057

rax-nova-agent (2.1.13-0ubuntu2) bionic; urgency=medium

  * Drop xenstore-utils dependency, in favor of ordering after
    proc-xen.mount.
  * Demote xe-guest-utilities to Suggests, until after MIR is done.

rax-nova-agent (2.1.13-0ubuntu1) bionic; urgency=medium

  * Switch to watching upstream releases on GitHub
  * New upstream version 2.1.13
    - Added Netplan support
  * Build-depend on python3-yaml
  * Skip tests newly failing due to lack of proper netplan support
  * Make python3-novaagent depend on xenstore-utils (LP: #1762718)
    Thanks to Dimitri John Ledkov
  * Depend on needed packages: xe-guest-utilities, xenstore-utils and cloud-init
  * Pick configuration files shipped originally in rax-openstack-guest-agents.
    Disable cloud-init network configuration, as nova-agent will do it.
    Override xe-daemon.service unit so that it also avoids default dependencies
    creating systemd's dependency loops with cloud-init.
    Give syslog write access to the kernel logs
  * Don't restart nova-agent service on upgrade
  * Fix nova-agent.service using upstream patches, using notify and local
    .service changes, thanks to Dimitri John Ledkov from some of the patches
  * Depend on python3-systemd which is needed but requiring it as a module
    breaks

rax-nova-agent (2.1.12-0ubuntu2~16.04.0) xenial; urgency=medium

  * Rebuild for Xenial (LP: #1753943)
  * Use compat level 9 build-depending on debhelper (>= 9) and dh-systemd

rax-nova-agent (2.1.12-0ubuntu2) bionic; urgency=medium

  * Make transitional package to be Architecture: all and move it to oldlibs
  * Make the transitional package depend on misc:Depends instead of
    overriding Lintian error

rax-nova-agent (2.1.12-0ubuntu1) bionic; urgency=low

  * Initial release (LP: #1751847)

 -- Balint Reczey <email address hidden> Mon, 03 Sep 2018 13:35:58 +0200

Changed in rax-nova-agent (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rax-nova-agent - 2.1.15-0ubuntu1~18.04.1

---------------
rax-nova-agent (2.1.15-0ubuntu1~18.04.1) bionic; urgency=medium

  * Use DefaultDependencies=no to prevent forming service ordering cycles
    (LP: #1788716)

 -- Balint Reczey <email address hidden> Fri, 24 Aug 2018 19:58:05 +0200

Changed in rax-nova-agent (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers