Update rax-nova-agent to 2.1.15

Bug #1783614 reported by Balint Reczey on 2018-07-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rax-nova-agent (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

nova-agent is provided by Rackspace for installation within guests that run on Rackspace Cloud. It is a collection of tools and daemons, packaged as rax-nova-agent, that ensure that the Ubuntu images published to Rackspace run properly on their platform.

Cloud platforms evolve at a rate that can't be handled in six-month increments, and they will often develop features that they would like to be available to customers who don't want to upgrade from earlier Ubuntu releases. As such, updating rax-nova-agent to more recent upstream releases is required within all Ubuntu releases, so they continue to function properly in their environment.

[Test Case]

* Ensure that upgrading from the previous version works in Rackspace's cloud including rebooting the instance
* Ensure that images created with the updated rax-nova-agent boot and operate properly in Rackspace's cloud including rebooting the instance.
* Additional tests may be performed by the CPC team, please contact them before marking the package verified.

[Regression Potential]

Latest changes included changing system initialization and networking setup which may break instance booting and setting up network connectivity potentially making the instance unreachable. The testing aims at revealing problems in those areas if there are regressions.

tags: added: upgrade-software-version
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rax-nova-agent - 2.1.15-0ubuntu1

---------------
rax-nova-agent (2.1.15-0ubuntu1) cosmic; urgency=medium

  * New upstream version 2.1.15 (LP: #1783614)
  * debian/gbp.conf: Declare repository layout
  * Refresh patches

 -- Balint Reczey <email address hidden> Thu, 26 Jul 2018 17:57:26 +0800

Changed in rax-nova-agent (Ubuntu):
status: New → Fix Released
Balint Reczey (rbalint) on 2018-07-26
description: updated
tags: added: id-5b353428bfb7efec1f1c6e8d

Hello Balint, or anyone else affected,

Accepted rax-nova-agent into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rax-nova-agent/2.1.15-0ubuntu1~18.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rax-nova-agent (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Dave Kludt (dkludt) wrote :

Tested and confirmed new agent is working as expected on Ubuntu 18.04 with multiple IP addresses on the same interface.

Robert C Jennings (rcj) on 2018-08-17
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

That probably has been done as part of validation in #3, but could we get some information whether the first two tests in the Test Case section have been performed? I assume the first one was done, but what about the freshly created image?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rax-nova-agent - 2.1.15-0ubuntu1~18.04.0

---------------
rax-nova-agent (2.1.15-0ubuntu1~18.04.0) bionic; urgency=medium

  * Rebuild for Bionic.

rax-nova-agent (2.1.15-0ubuntu1) cosmic; urgency=medium

  * New upstream version 2.1.15 (LP: #1783614)
  * debian/gbp.conf: Declare repository layout
  * Refresh patches

 -- Balint Reczey <email address hidden> Thu, 26 Jul 2018 18:16:53 +0800

Changed in rax-nova-agent (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for rax-nova-agent has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Balint, or anyone else affected,

Accepted rax-nova-agent into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rax-nova-agent/2.1.15-0ubuntu1~16.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rax-nova-agent (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done
tags: added: id-5b8703f921e7ee34fc8eb547
Łukasz Zemczak (sil2100) wrote :

Hello Balint, or anyone else affected,

Accepted rax-nova-agent into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rax-nova-agent/2.1.15-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Francis Ginther (fginther) wrote :

Our partner has completed verification on xenial.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rax-nova-agent - 2.1.15-0ubuntu1~16.04.1

---------------
rax-nova-agent (2.1.15-0ubuntu1~16.04.1) xenial; urgency=medium

  * debian/rules: Use dh --with systemd to add .service handling to maintainers cripts

rax-nova-agent (2.1.15-0ubuntu1~16.04.0) xenial; urgency=medium

  * Rebuild for Xenial
  * Use compat level 9 build-depending on debhelper (>= 9) and dh-systemd
  * Use DefaultDependencies=no to prevent forming service ordering cycles
    (LP: #1788716)
  * Clean up after rax-openstack-guest-agents in postinst

rax-nova-agent (2.1.15-0ubuntu1) cosmic; urgency=medium

  * New upstream version 2.1.15 (LP: #1783614)
  * debian/gbp.conf: Declare repository layout
  * Refresh patches

rax-nova-agent (2.1.13-0ubuntu3) bionic; urgency=medium

  * Drain the events queue, until there are no more events, for at least 3
    iterations, before sending started notification. LP: #1765057

rax-nova-agent (2.1.13-0ubuntu2) bionic; urgency=medium

  * Drop xenstore-utils dependency, in favor of ordering after
    proc-xen.mount.
  * Demote xe-guest-utilities to Suggests, until after MIR is done.

rax-nova-agent (2.1.13-0ubuntu1) bionic; urgency=medium

  * Switch to watching upstream releases on GitHub
  * New upstream version 2.1.13
    - Added Netplan support
  * Build-depend on python3-yaml
  * Skip tests newly failing due to lack of proper netplan support
  * Make python3-novaagent depend on xenstore-utils (LP: #1762718)
    Thanks to Dimitri John Ledkov
  * Depend on needed packages: xe-guest-utilities, xenstore-utils and cloud-init
  * Pick configuration files shipped originally in rax-openstack-guest-agents.
    Disable cloud-init network configuration, as nova-agent will do it.
    Override xe-daemon.service unit so that it also avoids default dependencies
    creating systemd's dependency loops with cloud-init.
    Give syslog write access to the kernel logs
  * Don't restart nova-agent service on upgrade
  * Fix nova-agent.service using upstream patches, using notify and local
    .service changes, thanks to Dimitri John Ledkov from some of the patches
  * Depend on python3-systemd which is needed but requiring it as a module
    breaks

rax-nova-agent (2.1.12-0ubuntu2~16.04.0) xenial; urgency=medium

  * Rebuild for Xenial (LP: #1753943)
  * Use compat level 9 build-depending on debhelper (>= 9) and dh-systemd

rax-nova-agent (2.1.12-0ubuntu2) bionic; urgency=medium

  * Make transitional package to be Architecture: all and move it to oldlibs
  * Make the transitional package depend on misc:Depends instead of
    overriding Lintian error

rax-nova-agent (2.1.12-0ubuntu1) bionic; urgency=low

  * Initial release (LP: #1751847)

 -- Balint Reczey <email address hidden> Mon, 03 Sep 2018 13:35:58 +0200

Changed in rax-nova-agent (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers