Ubuntu

corrupt preview of rw2 images

Reported by Dave Gilbert on 2010-06-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
RawTherapee
Fix Released
Undecided
Philip Rinn
rawstudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: rawstudio

Looking at a directory full of RW2 files from a Panasonic FZ-28, I'm seeing mush for the previews, selecting one works and displays the image - see attached screen shot.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: rawstudio 1.2-5
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
CheckboxSubmission: f2d10bd9f943a85b486a282e7840a570
CheckboxSystem: 0531969bcfd4f03af7405c98dc94a948
Date: Sun Jun 27 18:09:51 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: rawstudio

Dave Gilbert (ubuntu-treblig) wrote :
Changed in rawstudio (Ubuntu):
status: New → Confirmed
mmu2s (ykpmusicstudio) wrote :

It looks like having side effects in rawtherapee, nautilus and fspot as well.

Previews are corrupted in nautilus and fspot while rawtherapee shows the preview properly but crashes as soon as I try to open the file for processing.

Strangely, ufraw works well on those files.

Anders Kvist (akv) wrote :

This have been fixed in Rawstudio 2.0 - please update. I think the data for previews are bad in Panasonic, so we load the RAW and resize it for thumbnail instead...

Philip Rinn (rinni) wrote :

Hi,

could you please check if this bug is still presend int the current rawtherapee package (3.0.0~dfsg1-1)?

Changed in rawtherapee:
assignee: nobody → Philip Rinn (rinni)
Dave Gilbert (ubuntu-treblig) wrote :

Hi Philip,
  I can confirm this is fixed in rawtherapee 3.0.0~dfsg1-1 - thanks.

Note that Ubuntu still has rawstudio 1.2-5ubuntu2 - and that's still broken.

Dave

Philip Rinn (rinni) on 2011-08-25
Changed in rawtherapee:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers