yelp crashes on start

Bug #375896 reported by Vicente Ruiz on 2009-05-13
64
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Rarian
Confirmed
Medium
rarian (Ubuntu)
High
Loïc Minier

Bug Description

Binary package hint: yelp

When I try to start yelp, it crashes

More info:
$ dpkg -l yelp
Desired=Unknown/Install/Remove/Purge/Hold
| Estado=No/Instalado/Config-files/Desempaquetado/Fallo-config/Medio-inst/espera-disparo/pendiente-disparo
|/ Err?=(ninguno)/Retenido/Requiere-reinst/X=ambos problemas (Estado,Err: mayúsc.=malo)
||/ Nombre Versión Descripción
+++-==============-==============-============================================
ii yelp 2.25.1-0ubuntu Help browser for GNOME 2

$ dpkg -l *-dbgsym
Desired=Unknown/Install/Remove/Purge/Hold
| Estado=No/Instalado/Config-files/Desempaquetado/Fallo-config/Medio-inst/espera-disparo/pendiente-disparo
|/ Err?=(ninguno)/Retenido/Requiere-reinst/X=ambos problemas (Estado,Err: mayúsc.=malo)
||/ Nombre Versión Descripción
+++-==============-==============-============================================
ii libc6-dbgsym 2.9-9ubuntu1 debug symbols for package libc6
ii libglib2.0-0-d 2.21.0-0ubuntu debug symbols for package libglib2.0-0
ii libgtk2.0-0-db 2.16.1-0ubuntu debug symbols for package libgtk2.0-0
ii librarian0-dbg 0.8.1-2ubuntu1 debug symbols for package librarian0
ii yelp-dbgsym 2.25.1-0ubuntu debug symbols for package yelp

ProblemType: Bug
Architecture: amd64
Date: Wed May 13 10:59:55 2009
DistroRelease: Ubuntu 9.10
Package: yelp 2.25.1-0ubuntu5
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.28-11-generic x86_64

Related branches

Vicente Ruiz (uve) wrote :
Pedro Villavicencio (pedro) wrote :

looks like a rarian crash, could you install the dbgsym packages for it and get a new backtrace? , thanks.

affects: yelp (Ubuntu) → rarian (Ubuntu)
Changed in rarian (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Vicente Ruiz (uve) wrote :

I had installed it (librarian0-dbgsym). However, I installed rarian-compat-dbgsym and others more:

$ dpkg -l *-dbgsym | grep ii
ii libc6-dbgsym 2.9-9ubuntu1 debug symbols for package libc6
ii libglib2.0-0-dbgsym 2.21.0-0ubuntu1 debug symbols for package libglib2.0-0
ii libgtk2.0-0-dbgsym 2.16.1-0ubuntu3 debug symbols for package libgtk2.0-0
ii libicu40-dbgsym 4.0.1-2 debug symbols for package libicu40
ii libpth20-dbgsym 2.0.7-12 debug symbols for package libpth20
ii librarian0-dbgsym 0.8.1-2ubuntu1 debug symbols for package librarian0
ii libstartup-notification0-dbgsym 0.10-1 debug symbols for package libstartup-notific
ii libx11-6-dbgsym 2:1.1.99.2-1ubuntu2 debug symbols for package libx11-6
ii libx11-xcb1-dbgsym 2:1.1.99.2-1ubuntu2 debug symbols for package libx11-xcb1
ii libxcb1-dbgsym 1.2-1ubuntu1 debug symbols for package libxcb1
ii rarian-compat-dbgsym 0.8.1-2ubuntu1 debug symbols for package rarian-compat
ii xulrunner-1.9-dbgsym 1.9.0.10+nobinonly-0ubuntu1.respin1 debug symbols for package xulrunner-1.9
ii xulrunner-1.9-gnome-support-dbgsym 1.9.0.10+nobinonly-0ubuntu1.respin1 debug symbols for package xulrunner-1.9-gnom
ii yelp-dbgsym 2.25.1-0ubuntu5 debug symbols for package yelp

$ update-alternatives --config xulrunner

Hay 3 alternativas que proveen `xulrunner'.

  Selección Alternativa
-----------------------------------------------
 + 1 /usr/bin/xulrunner-1.9.2
* 2 /usr/bin/xulrunner-1.9
          3 /usr/bin/xulrunner-1.9.1

Hi

Yelp currently crashes for everybody in Ubuntu on startup due to the introduciton by some package of /usr/share/gnome/help/libs/shipped-docs. For some reason, librarian walks over this file and crashes because it has no dot in the filename.

I don't think rarian is supposed to parse this file, so I'll just attach a patch which doesn't crash and skips the file (just like it skips file with other extensions than .document and .section.

This is Launchpad bug https://bugs.launchpad.net/ubuntu/+source/rarian/+bug/375896

Bye

Created an attachment (id=26951)
Fix crash on filenames without extensions (skip, just like unknown extensions)

Loïc Minier (lool) wrote :

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f40212da950 (LWP 32511)]
0x00007f4032af2730 in ?? () from /usr/lib/librarian.so.0
Current language: auto; currently asm
(gdb) bt
#0 0x00007f4032af2730 in ?? () from /usr/lib/librarian.so.0
#1 0x00007f4032af2827 in ?? () from /usr/lib/librarian.so.0
#2 0x00007f4032af2ab0 in ?? () from /usr/lib/librarian.so.0
#3 0x00007f4032af2d57 in rrn_for_each_in_category (
    funct=0x4212e0 <rrn_add_document>, category=0x27cb730 "Core",
    user_data=0x222d4f0) at rarian-main.c:126
#4 0x00000000004209e5 in toc_process (toc=<value optimized out>)
    at yelp-toc.c:572
#5 0x00007f4032d6c5c4 in ?? () from /usr/lib/libglib-2.0.so.0
#6 0x00007f4031c4d3ba in start_thread () from /lib/libpthread.so.0
#7 0x00007f40319ba1bd in clone () from /lib/libc.so.6
#8 0x0000000000000000 in ?? ()

That's the best I can get for now.

Changed in rarian (Ubuntu):
importance: Medium → High
milestone: none → ubuntu-9.10-beta
status: Incomplete → Confirmed
Loïc Minier (lool) wrote :

After a debug build of rarian, I see:
(gdb) bt
#0 0x00007fd3763337b0 in strcmp () from /lib/libc.so.6
#1 0x00007fd3774d23fe in ?? () from /usr/lib/librarian.so.0
#2 0x00007fd3774d24a7 in ?? () from /usr/lib/librarian.so.0
#3 0x00007fd3774d21ff in ?? () from /usr/lib/librarian.so.0
#4 0x00007fd3774d1e0a in ?? () from /usr/lib/librarian.so.0
#5 0x00007fd3774d1e97 in rrn_for_each_in_category (
    funct=0x4212e0 <rrn_add_document>, category=0x237fb00 "Core",
    user_data=0x1de9160) at rarian-main.c:126
#6 0x00000000004209e5 in toc_process (toc=<value optimized out>)
    at yelp-toc.c:572
#7 0x00007fd3777515c4 in ?? () from /usr/lib/libglib-2.0.so.0
#8 0x00007fd37662c3ba in start_thread () from /lib/libpthread.so.0
#9 0x00007fd3763991bd in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Loïc Minier (lool) wrote :

Rebuilding yelp with noopt nostrip didn't help either, backtrace is still awful.

I straced -f yelp and it would open /usr/share/gnome/help/libs/shipped-docs last, but commenting out everythingin this file didn't help it get any further in the strace.

Loïc Minier (lool) on 2009-06-19
Changed in rarian (Ubuntu):
assignee: nobody → Loïc Minier (lool)
status: Confirmed → Fix Committed
Changed in rarian:
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rarian - 0.8.1-2ubuntu2

---------------
rarian (0.8.1-2ubuntu2) karmic; urgency=low

  * New patch, 60_no-doc-extension, fixes crash with documents without an
    extension; LP: #375896.

 -- Loic Minier <email address hidden> Fri, 19 Jun 2009 11:48:51 +0200

Changed in rarian (Ubuntu):
status: Fix Committed → Fix Released

JFTR, The same bug was opened on Debian and this patch was confirmed to fix the crash.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=535433

Changed in rarian:
importance: Unknown → Medium

There are two new bugs that appear similar to this one -- Bug 433504 (recently resurrected) and Bug 644025. Inspection of their stack traces reveals the apparent similarity. I don't think they're duplicates of this...but in case they are, or the similarity is otherwise useful to fixing them, I'm posting here to indicate the possible relation.

(I've already commented on those bugs to indicate this.)

Changed in rarian:
importance: Medium → Unknown
Changed in rarian:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.