yelp crashed with SIGSEGV in strlen()

Bug #130822 reported by sam tygier on 2007-08-07
14
Affects Status Importance Assigned to Milestone
rarian (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: yelp

yelp 2.19.1-0ubuntu1 crashed on startup when going to System->Help and Support

ProblemType: Crash
Architecture: amd64
Date: Tue Aug 7 10:25:10 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.19.1-0ubuntu1
PackageArchitecture: amd64
ProcCmdline: yelp
ProcCwd: /home/sam
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: yelp
StacktraceTop:
 strlen () from /lib/libc.so.6
 vfprintf () from /lib/libc.so.6
 vsprintf () from /lib/libc.so.6
 sprintf () from /lib/libc.so.6
 process_check_file () from /usr/lib/librarian.so.0
Title: yelp crashed with SIGSEGV in strlen()
Uname: Linux oberon 2.6.22-9-generic #1 SMP Fri Aug 3 00:20:35 GMT 2007 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Related branches

sam tygier (samtygier) wrote :

StacktraceTop:?? ()
?? ()
?? ()

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in yelp:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
sam tygier (samtygier) wrote :

there are still lots of question marks in the trace, should i install more debug packages?

Sebastien Bacher (seb128) wrote :

Could you install librarian0-dbgsym and get a new one?

sam tygier (samtygier) wrote :
Daniel Hahler (blueyed) on 2007-08-11
Changed in yelp:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in yelp:
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

rarian (0.5.8-0ubuntu1) gutsy; urgency=low

  * New upstream version:
    - Fix build on FreeBSD and Solaris (mostly)
    - rarian-example now goes through man and info pages again
    - Add MAINTAINER file, since someone asked for it
    Bug fixed:
    - Missing argument to sprintf added (bug #11976 and #11957) (LP: #130822)
    - Fix crashes on invalid info files (bug #11896)
    - Fix crashes on man pages with no section (bug #11901)
    - Fix update script when not reading OMF's directly
    - Don't free environment variables - they don't belong to us
    - Fix categoried with omf files (the one everyone complained about)
  * debian/patches/90_from_svn_fix_omf_categories.patch:
    - dropped, fixed with the new version

 -- Sebastien Bacher <email address hidden> Mon, 13 Aug 2007 23:17:41 +0200

Changed in rarian:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.