Mouse cursor gets stuck in "drag and drop" mode

Bug #402892 reported by nxThron
This bug affects 79 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
X.Org X server
chromium-browser (Ubuntu)
firefox (Ubuntu)
rapidsvn (Ubuntu)

Bug Description

Binary package hint: rapidsvn

When clicking on the Bookmark root or on one of the bookmarks below the mouse cursor gets stuck in "drag n drop" mode, blocking all keyboard entry and also mouse clicks for the the whole GUI (systemwide).

Unfortunately I cannot provide any debug or other information, as I have to reboot everytime.

I am running Ubuntu 9.04 with compiz enabled.

Many thanks in advance for your help with this problem,

Revision history for this message
takaji (takaji) wrote :

You don't have to restart your computer. You can switch from graphical tty to a console tty, login then kill the process of rapidsvn then switch back to graphical tty.
To switch between tty, you can use Ctrl + Alt + Fx (x = 1, 2, 3, ...). Usually, graphical tty is Ctrl + Alt + F7 :)
You can try this command to kill rapidsvn process

kill -9 `pidof rapidsvn`

Revision history for this message
Stefan Müller (smu-blackbox) wrote :

As far as I can say this bug is not dependent on RapidSVN but must a general GNOME Problem. I had this behaviour often when using Epiphany and get it now when I am using my Wacom tablet. Once an drag&drop operation is triggered by accident, the cursor is stuck in the drop mode: i.e. it shows the little arrow beside an icon. The system will not respond to ESC or the like. If you are lucky, you can type into some textfield which provides some popup text (like the epiphany adress bar). If the popup of this textfield shows up, the cursor is reset.

The suggested solution given above does not work in Lucid Lynx since changing to another terminal using Alt+Ctrl+NR does not work quite well. Often it is impossible to change back to terminal 7. You will only see the X Log.

Revision history for this message
Jeroen Lodder (lodderj) wrote :

I've this problem too... I was not dragging any file on purpose, of that I'm sure. But it happened.

I tried a lot, I can get kind of "Execute" windows from Gnome, but I can't type there, grr.

Anyways, I have a VMware Virtual Machine in Sleep with this bug "active"...
Any one interested?

Revision history for this message
Jeroen Lodder (lodderj) wrote :

*You can fix it by pressing the power button, en use arrows to go to "Hibernate", go down, boot up, done.

Revision history for this message
another_sam (anothersam) wrote :

This bug is affecting me right now. Is quite annoying since it apparently implies to restart the session. This is the second time today. Third or fourth during the last 5 days if I don't recall wrongly.

Revision history for this message
another_sam (anothersam) wrote :

I saw this
In my case the touchpad is the id=13. Next time I will try
xinput set-prop 13 "Device Enabled" 0
xinput set-prop 13 "Device Enabled" 1
to see if it works.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rapidsvn (Ubuntu):
status: New → Confirmed
Revision history for this message
Emerica (blendz) wrote :

Oneiric - Linux 3.0.0-23-generic #39-Ubuntu SMP Thu Jul 19 19:19:11 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Had this problem using connected to SFTP server in nautilus, accidently made a drag operation and it stuck.
I don't and haven't used rapidsvn, but I did have gedit running and trying to open a rather large file.
I changed to tty1 and killed gedit, switched back and the drag operation stopped, able to click again without killing the session.

Revision history for this message
Igor Zinovyev (zinigor) wrote :

Is there maybe a newer version of this bug? I have had a similar episode on my machine running 64-bit Precise on Linux 3.2.0-32-generic kernel.

I had been dragging and dropping files from Nautilus to Totem when this had happened.

Revision history for this message
Mike Gilbert (mjgilbert) wrote :

I just experienced the same exact thing as Igor running 64-bit Precise Ubuntu 12.04.2 3.2.0-39-generic. I was repeatedly dragging files to Totem from Nautilus as well.

Revision history for this message
breezer (jgbreezer) wrote :

I'm also seeing it semi-regularly in 12.10 when dropping files from nautilus (think its nautilus, gnome 3 desktop anyway) to Totem. I killed totem from the terminal and the pointer stayed like that and I couldn't click on anything else, xkill couldn't even grab the cursor to kill the file/directory-browser window.

So perhaps its not totem but the dir. browser (assuming its Nautilus on mine). Or part of the internal drag/drop mechanism in X or other clipboard handling app that dies or locks up.

Revision history for this message
breezer (jgbreezer) wrote :

Yep, "pkill nautilus" from a text terminal (press Ctrl+Alt+F1 together to get a terminal or use an existing one on your desktop if you can via Alt+Tab/guake/other, once you have one logged in, type the pkill command mentioned earlier, then use Ctrl+D or type "logout"(enter) to log out of terminal; then press Ctrl+Alt+F7 together on this ubuntu version to switch back to the graphical mode) fixed it.

Revision history for this message
Avi Marcus (avi-amarcus) wrote :

I'm on 14.04 with gnome, and "pkill nautilus" in a terminal worked for me. Thanks!

Revision history for this message
Chaoscode (dennis-restle) wrote :

i tried to drag'n'Dropp a Directory from a ZipFile to my Downloads Directory.
i had to kill file-roller to get my cursor back.
After that, the same Drag'n'Drop function worked

Revision history for this message
Ragnar Kurm (2-ragnar) wrote :

Got stuck into dnd -- Ubuntu 12.04.5 LTS -- pkill nautilus -- worked for me.

Revision history for this message
Liz Av (liz4v) wrote :

Dragging files from the desktop while my chrome browser had WhatsApp Web open. Worked several times until I got this bug. "killall nautilus" got my mouse back.

Revision history for this message
Saji Nediyanchath (saji89) wrote :

This is what worked for me:

sudo gsettings set org.gnome.settings-daemon.plugins.cursor active false

If that doesn't work, please try this too:

sudo gsettings set org.gnome.settings-daemon.plugins.cursor active true


Revision history for this message
Dirk Mcbratney (djmcbratney) wrote :

Dragging from and to the desktop is doing this to me recurringly on both my laptop and desktop. I've seen something like this happen before, but it's getting absurd. This is an extremely embarrassing bug and should be considered critical.

Revision history for this message
Stephane Poinsart (s-poinsart) wrote :

Same problem with firefox 41 (trusty / LXDE), when accidentally drag & dropping a selected text. Was able to work around without a reboot by using the address bar (CTRL+L) for this time. But when it happen, it's extremely annoying because even if i could go to a terminal, i was not sure exactly what to kill... Highly detrimental to the user experience.

Revision history for this message
Albert Zeyer (albertzeyer) wrote :

I have the same (or very similar) problem. I'm on KDE. It happened somehow by clicking on the application window bar from KDE and it wanted to drag&drop some window tab. For me, all keyboard input still works, and I can move the mouse, but the mouse stays in the drag-state and it ignores all clicks.

Revision history for this message
trevi (ermin-trevisan) wrote :

Please forget my erranous comment #21

Revision history for this message
spoolboyy (spoolboyy) wrote :

I'm seeing this same problem on xubuntu 14.04. It seems to happen in various applications including Firefox, Terminal Emulator and Pycharm Community Edition 2016.1.

I am unable to type anything and clicking the mouses buttons (right, left or center) seems to do nothing.

Since I'm seeing this issue on a notebook computer, I can confirm that it occurs with both a wired USB mouse when using the touchpad. When it happens with the mouse, if I unplug it and plug it back in it functions as expected again.

Revision history for this message
spoolboyy (spoolboyy) wrote :

To further clarify my remark in #23, when this happens when I am using a USB mouse, if I right-click using the touchpad, all is back to normal. It does not matter if I unplug the USB mouse or not.

I was assuming that unplugging the external mouse was making it work again, but that is not the case. It seems that using my touchpad mouse instead seems to shock the system back into working properly.

Revision history for this message
bikkanati prabhakar (prabhakar-9885) wrote :

I am facing this issue in 14.04 and also in 16.04.

Thanks to breezer(jgbreezer)'s comment. Whenever I face this issue, I am running this command to fix it.

"pkill nautilus"


Revision history for this message
sanette (sanette-linux) wrote :

on linux mint kde 17.3 freshly installed I have the same problem with the Firefox file dialog:
as soon as I click on a file, it behaves as in the drag-and-drop mode.
I need to drag it back to its original place and click again to stop this.
Of course this is very annoying. No clue how to solve this ?

Revision history for this message
sanette (sanette-linux) wrote :

Ah, at least for KDE I found a way to solve it.
In systemconfigs => applications appearance => GTK,
change the GTK3 theme from oxygen-gtk (my default settings) to something else. For instance, Mint-X-blue seems to work.

Revision history for this message
Francis Chin (chinf) wrote :

Just got this when dragging a file from file-roller to a nautilus window on Ubuntu 16.04 64-bit. Nautilus would scroll its window up and down in response to the vertical position of the mouse pointer, but no button events appeared to take effect in any application. Had to Alt-F2 and pkill file-roller to get control back.

It's unlikely to be a fault in a specific application, more likely a flaw in the desktop inter-process signalling system, for which there are several bugs open. It's difficult to pin down though as it seems hard to produce a useful test case for this intermittent problem - I'm a regular Ubuntu user and this occurs very rarely (in my experience so far).

Revision history for this message
Lucas Silva (lcss) wrote :

Same problem when dragging a file on Arch Linux using the latest version (currently 3.22.3-1). It happens a lot and is very annoying.

Revision history for this message
yolen (plasmajens) wrote :

On ubuntu 17.04 my mouse pointer constantly get stuck in various modes (write, drag-and-drop etc). Only way to get the operational again is to close all applications or sometimes restarting the system

Revision history for this message
Paul Müller (8-mail-g) wrote :

I have the same problem in Ubuntu 16.04.3, but only for certain applications (jabref and texmaker so far).

The comment by @spoolboyy helped: I was using a USB mouse and clicking with the touchpad stopped the drag-and-drop mode.

I am using a Thinkpad X1 Carbon laptop.

Revision history for this message
Paul Müller (8-mail-g) wrote :

Turns out disabling the touch screen with ``xinput --disable 12`` ("ELAN Touchscreen" listed as "id=12" in ``xinput``) solved the problem for me. In my case, this is either a malfunction of the touch screen or a system software problem.

Revision history for this message
Flavio Henrique Bastos (bastosfh) wrote :

Disabling the touch screen (as recommended by @Paul Müller) solved the problem in my notebook as well (Dell Vostro 5480 - Ubuntu 16.04.3).

Revision history for this message
Roland (roland-breedveld) wrote :

same problem with Ubuntu 17.10 with gnome3

Revision history for this message
Sergey Karapetyan (karapetyan.s) wrote :

Same problem on Lubuntu 14.04
Touchscreen: (MasterTouch MT-500 USB), supports only single touch.
Mouse not connected.

problem appears in next apps:
- Chromium: 62.0.3202.75
- Firefox 28.0

Sometimes MouseUp just not firing:

then i close Chromium / Firefox with ALT+F4

but mouse still stuck in "MouseDown" state _systemwide_ :

Even if I connect the mouse to the computer after the problem occurs - the left mouse button will not work.

But mtpaint works fine! There is some difference in how mtpaint and (chromium, firefox) works with mousedown / mouseup events.

Any ideas? I need use touchscreen and don't need mouse. So i can't disable the touchscreen as recommended, because this will make the whole system unusable.


Changed in chromium (Ubuntu):
status: New → Confirmed
Changed in firefox (Ubuntu):
status: New → Confirmed
Revision history for this message
Steven Regester (egeste) wrote :

I disabled the touchscreen by adding `blacklist hid-multitouch` to `/etc/modprobe.d/hid_multitouch.conf`, rebooted, and within 15 minutes the bug was back.

It appears as though the super key gets "stuck".
 * I have super + e bound to open nautilus, and if I press e when my computer gets into this state, it does indeed open nautilus.
 * The behavior of the mouse when holding down `super` is consistent with the described behavior.

Please advise as soon as possible. This bug has rendered my linux installation unusable.

Revision history for this message
Steven Regester (egeste) wrote :

New information:

I've been using my ubuntu installation for several days since I posted my last comment, and had not encountered the bug until I used the `Super + FN + Up Arrow`/`Super + FN + Down Arrow` to change workspaces. As soon as I did that, the bug returned. Will attempt to re-create and report back again.

Revision history for this message
Steven Regester (egeste) wrote :

Update from previous comment:

I was able to get the gnome environment into this erroneous state by using the aforementioned `Super + FN + UP/DN` shortcut to move back and forth between my workspaces. At this point I think it's reasonable to call this bug reproducible.

Revision history for this message
Jeb E. (jebeld17) wrote :

The same happens for me, all the way on Ubuntu 17.10 x64. Issue happens moreso when multitasking between Openshot and Firefox.

Wes (wesinator)
affects: chromium (Ubuntu) → chromium-browser (Ubuntu)
Revision history for this message
kecsap (csaba-kertesz) wrote :

Similar to @Flavio Henrique Bastos, @Paul Müller, it happened on my Lenovo X1 Yoga, running the touchscreen with libinput driver (

Disabling/enabling the touch screen resolved the problem:

xinput --set-prop "Wacom Pen and multitouch sensor Finger" "Device Enabled" 0
xinput --set-prop "Wacom Pen and multitouch sensor Finger" "Device Enabled" 1

Revision history for this message
Adrianna Pińska (confluence) wrote :

I've encountered this or a similar bug in Ubuntu 18.04 on a Dell XPS 13 with a touchscreen. I observed that the touchpad seemed to be stuck in mouse down mode, but only in KDE apps (specifically, Kate and Quassel). I found this bug report, saw that the bug may be touchscreen-related, and tried touching the touchscreen to see if that would unstick the touchpad -- but this made my cursor disappear completely, and I had to reboot. Next time this happens I will try disabling and re-enabling the touchscreen to confirm whether this fixes the problem (but given that I never use the touchscreen I should probably just disable it permanently).

Revision history for this message
Bill Werner (wernerb) wrote :

Using xubuntu 18.04.2 remote login from Win7 x64 using Turbo VNC Viewer. Cut/Paste from linux folder to another folder on same remote linux system.

Cursor frozen with 'Cross' icon. Able to return to Windows, but can't control Linux anymore. NEITHER SYSTEM HAS A TOUCHPAD OR TOUCHSCREEN!

Linux is headless & Win 7 is connected to 48 TV & SD Monitor. Alt-F4 works to close active window, but makes no change in cursor or control.

Screen refreshes do nothing; having to shutdown/reboot with Putty. Still can access system, just can't do anything in GUI with cursor locked.

Revision history for this message
Peter Ludwig (peter-ludwig) wrote :

Same problem here.
System: Mint 18.3 with kernel 4.15.0-55-generic
(Problem seems not to be dependent on kernel version. Had this effect with earlier kernel versions too)
Desktop: MATE with lightdm

Reproduction: Open two folders in default file manager of mate. Then drag files from one folder to another folder in a seperate window while pressing the shift key. After ~ 10 files copied the problem occurs.

Reproduction 2: Open a folder and drag and drop files (small .mp4 video clips) from a folder to XPlayer (Medienwiedergabe). Problem occurs after around 10 files or sooner. (VLC seems to run fine though).

Mouse can be moved but klicks do not work. No left, right, middle, scrolling ... nothing. Keyboard works fine. Unplugging and plugging mouse does not help.

How to solve the problem: Reboot. Nothing else worked for me. Monitor has no touch screen. "Gesettings" command did not help. Killing nautilus, file-roller, rapidsvn, nautilus-desktop, nemo is not applicable (but still tried it) and/but did not help too.

During the copy process the default mouse icon changes from normal mouse pointer to this hand symbol with an arrow on the bottom right side pointing to the left top corner and the file icon symbol of the file that was to be copied (grabbed).

Hope this gets fixed soon. The problem began 2009??? Very annoying bug renders the system more or uselesse useless. Reboot is the only fix for me right now. :((

Revision history for this message
MasterCATZ (mastercatz) wrote :

extremely annoying bug

decided to leave 18.04 LTS and try 19.10 to see if it goes away

for me happens when ever dragging something in-between monitors

can tab and move mouse nothing else works

Revision history for this message
Colin Watson (cjwatson) wrote :

@mevsme: This isn't acceptable in Launchpad; please see the Ubuntu Code of Conduct. I've hidden this comment.

Revision history for this message
peterfrank (zengmao) wrote :

I confirm that Paul Müller's workaround works for me on Ubuntu 20.04. I need to read off the touchscreen ID from the output of "xinput". After that, I disable the touchscreen, and enable it again after I swipe gently on the screen. This usually makes the problem go away, without leaving the touchscreen disabled.

Revision history for this message
peterfrank (zengmao) wrote :

The problem never appears when I install and use KDE plasma desktop within the same OS, even though the underlying hardware and drivers are unchanged. So the problem seems specific to GNOME.

Revision history for this message
peterfrank (zengmao) wrote :

Another update: I've installed the Cinnamon desktop within Ubuntu 20.04 and used it for several days. Again the problem never appears, like in KDE. Only GNOME has this problem, at least on my laptop.

Revision history for this message
Mark Jeronimus (mark-jeronimus) wrote :

I experience this problem on Unity though

On average once per week, and usually when I drag file(s) to a Nautilus window (either from another Nautilus or File-roller)

Revision history for this message
Ploni Almoni (ploni-deactivatedaccount) wrote :

I discovered a way to consistently trigger this. I don't know if all these steps are necessary, but it works for me consistently this way.

- Ubuntu MATE 20.10
- caja version 1.24.0
- Evolution version 3.38.1-1

Steps to Reproduce:
1. In Evolution, open the 'Compose Message' window. I have it set by default to 'Plain Text' editing mode, and attachment bar collapsed.
2. Open caja and navigate to the desired file.
3. drag & drop the file in the message body. This should result in the full file path URI being displayed as the message.
4. press `CTRL+Z` (Undo).
5. Now drag the same file again, over the message body, into the (collapsed) attachment bar.
6. Your mouse should now be stuck in DND mode, requiring `pkill caja` to release it.

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

Happens very frequently for me on a default ubuntu 20.10 desktop. I basically have to kill my desktop to fix it, and lose all unsaved work. It's quite problematic.

Revision history for this message
Guillaume Carles (gcarles) wrote :

Happens very frequently for me also on a vanilla 18.04 (Thinkpad), but only on a small subset of applications. What's strange is that the bug appeared a few days ago after years without problem.

I do not use any external peripheral (nothing connected to the laptop except the power supply).

An easy solution to solve this without rebooting the whole system is to disable then enable the TouchScreen (disabling alone is not sufficient).

Following Paul Müller's steps:
- find your TouchScreen input ID with ``xinput`` (in my case ``Melfas LGDisplay Incell Touch id=9``
- ``xinput --disable 9``
- ``xinput --enable 9``

If you want to automate this in a script/alias, you can easily retrieve the ID once you know the name of the TouchScreen:
- ``xinput list --id-only 'Melfas LGDisplay Incell Touch'``

Revision history for this message
Bob Briscoe (m-bob-q) wrote :

I'm adding the following, so searches of this symptom will also find this thread:

Once the bug is triggered, it also repeatably affects LibreOffice Calc - if you click-select a worksheet tab or drag-select a set of cells then release mouse, it enters drag-and-drop mode, and (strangely) draws a thick border around the selection, which you cannot undo or reformat.

I can exit DND mode with ESC. And temporarily remove the problem with the xinput solution, but
I agree with #53 that disabling touch screen is insufficient - you need to re-enable too.

System details:
Lenovo Yoga 3 Pro with ATML1000:00 03EB:8A10 touch screen
20.04.1-Ubuntu (although this bug has been affecting previous versions for me)
Linux kernel 5.8.0-48-generic

Revision history for this message
testing_things (test-bugs) wrote (last edit ):

This also affects Chromium:

Steps to reproduce:

This is a video of how to reproduce it:

1. Go to
2. Click the Google logo, move the logo as little as possible but enough to cause dragging and then release as soon as possible after you see that your mouse started dragging. Eventually you could just do it extremely quickly like in the video:
3. Sometimes the cursor would get stuck in the drag mode with the Google logo attached to it (even though the mouse button is no longer pressed).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.