raidutils FTBFS with "error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments"

Bug #334551 reported by Fabrice Coutadeur on 2009-02-25
2
Affects Status Importance Assigned to Milestone
raidutils (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: raidutils

Hi,

raidutils FTBFS in Jaunty:
 i486-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -O3 -DMESSAGES -D_DPT_ACTIVE_ALIGNMENT -Dtrue=1 -Dfalse=0 -DHORIZONTAL -DNEW_RSC_MGR -DNEW_RSC_HDR -D_DPT_FLASH -DNEW_LOGGER -DI_WANT_SNI_DEBUG -D__UNIX__ -I../include -Wall -g -O2 -MT libraidutil_la-lockunix.lo -MD -MP -MF .deps/libraidutil_la-lockunix.Tpo -c lockunix.c -fPIC -DPIC -o .libs/libraidutil_la-lockunix.o
lockunix.c: In function 'MkLock':
lockunix.c:91: warning: ignoring return value of 'write', declared with attribute warn_unused_result
lockunix.c:102: warning: ignoring return value of 'read', declared with attribute warn_unused_result
lockunix.c: In function 'ChLock':
lockunix.c:157: warning: ignoring return value of 'write', declared with attribute warn_unused_result
lockunix.c: In function 'IsLock':
lockunix.c:185: warning: ignoring return value of 'read', declared with attribute warn_unused_result
In function 'open',
    inlined from 'ChLock' at lockunix.c:155:
/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments
In function 'open',
    inlined from 'MkLock' at lockunix.c:85:
/usr/include/bits/fcntl2.h:51: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments
make[3]: *** [libraidutil_la-lockunix.lo] Error 1

Related branches

Changed in raidutils:
assignee: nobody → fabricesp
status: New → In Progress
Changed in raidutils:
assignee: fabricesp → nobody
status: In Progress → Confirmed
Fabrice Coutadeur (fabricesp) wrote :

debdiff with the fix

Changed in raidutils:
importance: Undecided → Medium
assignee: nobody → quadrispro
status: Confirmed → In Progress
Alessio Treglia (quadrispro) wrote :

Uploaded, thanks.

Changed in raidutils:
assignee: quadrispro → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package raidutils - 0.0.6-8ubuntu1

---------------
raidutils (0.0.6-8ubuntu1) jaunty; urgency=low

  * debian/patches/fix_FTBFS_gcc_4.3.patch: fix FTBFS in gcc 4.3 because of
    calls of open function without rights. Defaulted to 0644. (LP: #334551)
  * debian/control: added dependency on quilt
  * debian/rules: included call of quilt makefile and patch and unpatch target

 -- Fabrice Coutadeur <email address hidden> Fri, 27 Feb 2009 19:49:31 +0000

Changed in raidutils:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers