radiotray crashes on start

Bug #766560 reported by Malky on 2011-04-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
radiotray (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: radiotray

radiotray crashed with AttributeError in bookmark_callback(): 'NoneType' object has no attribute 'startswith'

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: radiotray 0.6.1-1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Tue Apr 19 23:42:42 2011
ExecutablePath: /usr/bin/radiotray
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413.2)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/radiotray
ProcEnviron:
 LANGUAGE=ru_UA:en
 LANG=ru_UA.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/radiotray']
SourcePackage: radiotray
Title: radiotray crashed with AttributeError in bookmark_callback(): 'NoneType' object has no attribute 'startswith'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout dip lpadmin plugdev sambashare

Malky (malky-ua) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #703613, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
Malky (malky-ua) wrote :

I had used my own bookmarks.xml from older version of Ubuntu (10.04, 10.10) so I decided to try clean radiotray after

 sudo aptitude purge radiotray
sudo aptitude install radiotray

and found that it worked.

So I compared my old bookmarks.xml and new default one and found couple of " <bookmark/> " tags and the " </group> " tag closed the "root" group before other bookmarks. So I've fixed it manually and now it works but this config was generated before with the radiotray so I think this problem may be found on upgrade from the earlier version of Ubuntu in future.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers