Ubuntu

radiotray should default to indicator in ubuntu

Reported by Jan Schürmann on 2011-02-12
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
radiotray (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: radiotray

the Radio Tray 0.6.2/.3 should support appindicator said the release notes but it is still only using the notification area as the default in the preferences is the notification area icon. An ubuntu-specific patch should be made to default to indicator on Ubuntu, as starting from Natty, notification area icons are not visible by default, thus people can not access radiotray at all after starting it.

Robert Roth (evfool) wrote :

It really does have support for indicators, but the default is the notification area version, it can be changed in the preferences file. The default for Ubuntu with indicator support should be the appindicator version.

Changed in radiotray (Ubuntu):
status: New → Confirmed

ok, and where do i found the preferences file?

Robert Roth (evfool) wrote :

You should find it in your home directory under .local/share/radiotray/config.xml

that worked...BUT it should have the option in preferences...i think

integrate applications into the sound indicator is described here:

http://theravingrick.blogspot.com/2011/02/easily-support-sound-menu-in-python.html

it would be great if Radio Tray supports the sound menu...

In Natty B1 it is installable but doesn't work.

Robert Roth (evfool) wrote :

@Achim: the radiotray version with app-indicator support is not available from the repositories yet, you have to download the deb and install it manually.

Martin Pool (mbp) wrote :

http://askubuntu.com/q/35141/1116 has instructions for how to work around this.

Changed in radiotray (Ubuntu):
importance: Undecided → High
Robert Roth (evfool) on 2011-05-20
summary: - radio tray is not using indicator
+ radiotray should default to indicator in ubuntu
description: updated
Robert Roth (evfool) on 2011-05-20
Changed in radiotray (Ubuntu):
status: Confirmed → Triaged
Julian Taylor (jtaylor) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Oneiric Ocelot with version 0.6.4 which now asks on first start which indicators to use (default selection appindicators)

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

 [1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in radiotray (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers