uninstallable due to unsatisfiable dependency on gtkdialog

Bug #530496 reported by Niall Creech
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
radare (Debian)
Fix Released
Unknown
radare (Ubuntu)
High
Andrew Starr-Bochicchio

Bug Description

Binary package hint: radare

radare-gtk has an uninstallable dependency on gtkdialog

$ sudo apt-get install radare-gtk

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  radare-gtk: Depends: gtkdialog but it is not installable
E: Broken packages

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 716d1b0e0549c96a138b059317db58fe
CheckboxSystem: d7486a0cf4dbe4bfdbdc5f2407943d41
Date: Tue Mar 2 05:54:18 2010
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: radare-gtk (not installed)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: radare
Uname: Linux 2.6.32-14-generic x86_64

Related branches

Changed in radare (Ubuntu):
assignee: nobody → SevenMachines (sevenmachines)
Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :

radare (1:1.4-1ubuntu1) lucid; urgency=low

  * 10_drop-gtkdialog-usage.dpatch:
    - import radare r1204, r1210, r1211 from mercurial repository to remove
    any use of gtkdialog and so allow dropping all gtkdialog dependencies
    altogether (LP: #530496)
  * Move libreadline5-dev build-dep to libreadline-dev to fix conflict with
    lua5.1

Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :
Changed in radare (Ubuntu):
assignee: SevenMachines (sevenmachines) → nobody
Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :
Revision history for this message
Sebastian Reichel (sre) wrote :

Hi,

I'm the Debian maintainer. FYI I'm just switching to radare2, which does not longer depend on gtk*.

-- Sebastian

Changed in radare (Debian):
status: Unknown → New
Changed in radare (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: New → In Progress
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

I'm going to go ahead and sponsor this into Lucid as its obviously not acceptable in its current state, but of course we'd rather stay close as possible to Debian. Sebastian, do you have a time frame for radare2 entering Debian? We are already well past Ubuntu's Feature Freeze and we're coming up on Final Freeze.

Thanks both of you for your work on this!

Changed in radare (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package radare - 1:1.4-1ubuntu1

---------------
radare (1:1.4-1ubuntu1) lucid; urgency=low

  * 10_drop-gtkdialog-usage.dpatch:
    - import radare r1204, r1210, r1211 from mercurial repository to remove
    any use of gtkdialog and so allow dropping all gtkdialog dependencies
    altogether (LP: #530496)
  * Move libreadline5-dev build-dep to libreadline-dev to fix conflict with
    lua5.1
 -- Niall Creech <email address hidden> Tue, 06 Apr 2010 19:28:03 +0100

Changed in radare (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Sebastian Reichel (sre) wrote :

yes of course - as soon as possible. The current package in Debian is very old and has different bugs on each arch. I already prepared a package:

http://git.debian.org/?p=collab-maint/radare.git;a=summary

Current status:

On Fri, Mar 26, 2010 at 19:45:50 (CET), Sebastian Reichel wrote:
> Reinhard Tartler: Can you sponsor the package?

I had a look at the package, but this "Format 3.0 (quilt)" gives me
headaches:

$ gbp-clone git://git.debian.org/collab-maint/radare.git
$ cd radare
$ git-buildpackage -S

seems to work. however, now the working copy is dirty (check git status)
and a file debian/patches/debian-changes-0.4-1 is created with this as
comment:

Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :

if its possible to get radare2 in that would be great, for all the reasons Sebastian mentions. The radare patch is a 'at least get it working' patch, radare2 is very much the actively developed version these days as i understand it

Changed in radare (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.