Menus not shown in DrRacket GUI

Bug #1065997 reported by Yann Salmon on 2012-10-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
racket (Ubuntu)
Undecided
Unassigned

Bug Description

When I run drracket, the main window is displayed but its menu titles and Execute/verify buttons are not drawn. They exist and are clickable : clicking in the space where they would appear causes the program to be verified or the menu entries to be displayed. I was able to open the Preferences window this way, but it also has drawing glitches and I was not able to find an option tha would be relevant.

Please note that I am talking about the DrRacket GUI itself, not the GUI of a program that I would have written using the racket language.

I am running Ubuntu 12.04 with XFCE.

I downloaded and compiled DrRacket v5.3 : that version displays the menubar correctly.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: racket 5.1.3+dfsg1-1
ProcVersionSignature: Ubuntu 3.2.0-31.50~ppa1-generic-tuxonice 3.2.28
Uname: Linux 3.2.0-31-generic-tuxonice x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu14
Architecture: amd64
Date: Fri Oct 12 16:01:13 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
SourcePackage: racket
UpgradeStatus: Upgraded to precise on 2012-07-01 (102 days ago)

Yann Salmon (yannsalmon) wrote :
Erik Ferguson (muraiki) wrote :

I am having the same problem with this package on 12.10 with Unity. But if I use the binary installer from the Racket language website, the program runs without any problems.

Erik Ferguson (muraiki) wrote :

Oops, I made a mistake -- it turns out that I'm on 12.04! I forgot that I hadn't updated Ubuntu to 12.10 on this computer yet.

I tried this package on a 12.10 machine and it worked fine under Unity.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in racket (Ubuntu):
status: New → Confirmed
nadrimajstor (ipejic) wrote :

Bug has been resolved upstream.
DrRacket version 5.3.4--2013-05-08(-/f) looks ok to me.

Workaround for 12.04:
sudo add-apt-repository ppa:plt/racket
sudo apt-get update
sudo apt-get install racket

Thanks, nadrimajstor! Installing from plt/racket repository solved this probelm for me.

Jakukyo Friel (weakish) wrote :

Some items in menu are missing. For example, in Edit, Keybinding & Mode's submenu disappears. In View, enlarge/decrease text size label does not show (shortcuts do show though).

I am on Ubuntu 14.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers