Racket package is missing dependency

Bug #1049353 reported by Nisstyre56 on 2012-09-11
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
racket (Ubuntu)
Undecided
Unassigned

Bug Description

Hello, the racket package is missing a dependency.

Description: Ubuntu 12.04.1 LTS
Release: 12.04

I installed racket via "apt-get install racket"

When I run drracket from the terminal:

wes@Sagan:~$ drracket
ffi-lib: couldn't open "libjpeg.so.62" (libjpeg.so.62: cannot open shared object file: No such file or directory)

DrRacket seems to depend on libjpeg62, so I install that via apt-get as well, which solves this issue.

dpkg -l racket
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=============================-=============================-==========================================================================
ii racket 5.1.3+dfsg1-1 extensible programming language in the Scheme family
wes@Sagan:~/Downloads$ apt-cache depends racket
racket
  Depends: libc6
  Depends: libffi6
  Depends: racket-common
  Recommends: racket-doc
  Breaks: plt-scheme
  Breaks: <plt-scheme:i386>
  Replaces: plt-scheme
  Replaces: <plt-scheme:i386>
  Conflicts: racket:i386

So it seems to me that libjpeg62 should be listed as a dependency.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in racket (Ubuntu):
status: New → Confirmed
Moritz Bruder (muesli4) wrote :

Well, i tried installing libjpeg62, but it already was installed, same with libffi6. (/usr/lib/x86_64-linux-gnu/libjpeg.so.62)

Maybe the problem is caused by racket itself.

Moritz Bruder (muesli4) wrote :

Nevermind, now it works, which is very strange, but at least I can confirm that is a dependency problem.

Victor Engmark (victor-engmark) wrote :

Looks like a duplicate of bug #977848.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers