Ubuntu

rabbitvcs crashes Nautilus when overwriting files/merging folders

Reported by sblatt on 2010-11-21
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Undecided
Unassigned
RabbitVCS
Unknown
Unknown
rabbitvcs (Ubuntu)
Low
Daniel O'Connor

Bug Description

Binary package hint: nautilus

1) lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

2) apt-cache policy nautilus
nautilus:
  Installed: 1:2.32.0-0ubuntu1.1
  Candidate: 1:2.32.0-0ubuntu1.1
  Version table:
 *** 1:2.32.0-0ubuntu1.1 0
        500 http://ch.archive.ubuntu.com/ubuntu/ maverick-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:2.32.0-0ubuntu1 0
        500 http://ch.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

3) Expected: old file(s) get overwritten by the new ones
4) as soon as the dialogue pops up, asking if I want to merge folder/replace file, nautilus is crashed - clicking replace does nothing. If I click the x (close-button) Ubuntu asks me if I want to force-close nautilus (that's what I normally do in this situation).
This error occurs EVERY TIME!
On askubuntu you can find my detailed description including a video of the bug and a nautilus-debug-log:
http://askubuntu.com/questions/14290/nautilus-crash-when-merging-overwriting-files

Copied from http://askubuntu.com/questions/14290/nautilus-crash-when-merging-overwriting-files:

On my Ubuntu 10.10, whenever I want to copy some files/folders over some other files/folders, or when I try to empty the trash, nautilus crashes!

Example:
I have a folder with some files. Now I want to overwrite this folder with a folder with the same name, same files, but some additional files, the merge window comes up, I choose merge and nautilus crashes (does not respond, when I press the close button I can force close it). Some times it even does the copying/emptying (trash), but it always crashes!

This happens when copying to the same partition/ntfs partition/netshares, but not when I make a new folder and copy the files/folders into that (without overwriting anything). On a netshare, it's even possible to merge these files afterwards with another computer!

dmesg/syslog/messages does not show any entry related to that problem.

Does anyone have a solution for this very annoying problem?

EDIT:

    dpkg -l nautilus* (see output in pastebin)

EDIT2:
I found out, nautilus already crashes before clicking replace/merge (as soon as the question appeares. In the video it's not entirely clear, that i click the cross before the force-close dialog appeares.

    * Video of problem
    * nautilus-debug-log.txt

sblatt (stefan-blatter) wrote :
sblatt (stefan-blatter) wrote :
wolferl (isabamail) wrote :

I can confirm exactly the same problem in UNE 10.04. I update weekly and it started some 3 weeks ago (?)

sblatt (stefan-blatter) wrote :

A workaround is to use any other file manager. I just tested rox, xfe and gnome-commander, they all work.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
salva84 (salva-ms) wrote :

same problem, same bug, same behavior looking the video.... any solution? is there any debug mode for nautilus?

eclipsenet (eclipse-net2k) wrote :

I am also having this issue now. I did not have this problem on Monday when I was running 10.10 that had been upgraded from the release candidate version to the stable release. I replaced my HDD and loaded with the newest image available on Tuesday and now I have this error. I am fully up to date on my packages.

Omer Akram (om26er) wrote :

could anyone get a backtrace as suggested above?

sblatt (stefan-blatter) wrote :

Sorry, but I already reinstalled Ubuntu (10.04 now), because I was unable to work with this bug. Now my system works fine, but I won't be able to do a backtrace.

eclipsenet (eclipse-net2k) wrote :

I installed the debug symbols for nautilus and I tried running gdb. I attached it to an active nautilus process and ran the commands listed in the backtrace instructions. When nautilus gets "hung" I attempted to cntrl+c in gdb to be able to enter the commands to grab the backtrace but I am unable to get gdb to beak out now.

sblatt (stefan-blatter) wrote :

I just got this bug again with Ubuntu 10.04.1 and I think I found out what caused it: rabbitvcs!
I don't know why and how, but it started some-when after i Installed rabbitvcs-core and rabbitvcs-nautilus from http://ppa.launchpad.net/rabbitvcs/ppa/ubuntu. So I uninstalled those two packages and did nautilus -q and now it's working perfectly again! Just wondering if the others have rabbitvcs installed too...

I'll post this the the rabbitvcs issues tracker now

eclipsenet (eclipse-net2k) wrote :

Doh! I have rabbitVCS installed as well! I had noticed that I had gotten a newer version with GIT support too ... I'll try an older version. To verify I will remove it first though. Good Call!

sblatt (stefan-blatter) wrote :

SOLVED -> installed rabbitvcs 0.14.1.1 from tarbal (which includes the official fix for this problem), now it works like a charm :D
However the ppa version still breaks nautilus.

affects: nautilus (Ubuntu) → rabbitvcs (Ubuntu)
Changed in rabbitvcs (Ubuntu):
status: Incomplete → Confirmed
Changed in nautilus:
status: New → Invalid
summary: - Nautilus crashes when overwriting files/merging folders
+ rabbitvcs crashes Nautilus when overwriting files/merging folders

http://code.google.com/p/rabbitvcs/issues/detail?id=481 - at least one individual claims using the current releases resolved this specific issue.
Can others confirm?

Changed in rabbitvcs (Ubuntu):
assignee: nobody → Daniel O'Connor (daniel-oconnor)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.