Context menu missing in Nautilus - RabbitVCS

Bug #1093533 reported by Cristian Aravena Romero on 2012-12-24
110
This bug affects 24 people
Affects Status Importance Assigned to Milestone
RabbitVCS
Unknown
Unknown
rabbitvcs (Ubuntu)
Undecided
Unassigned

Bug Description

I'm working with Ubuntu developed 13.04 see bug #1012865

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: rabbitvcs-nautilus 0.15.2-1
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.7-0ubuntu2
Architecture: amd64
Date: Mon Dec 24 19:39:43 2012
InstallationDate: Installed on 2012-11-27 (27 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20121126)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: rabbitvcs
UpgradeStatus: No upgrade log present (probably fresh install)

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rabbitvcs (Ubuntu):
status: New → Confirmed
khalidchawtany (khalidchawtany) wrote :

This also affects me I have no context menu integration.

I get this when I run nautilus from terminal

Traceback (most recent call last):
  File "/usr/share/nautilus-python/extensions/RabbitVCS.py", line 470, in get_background_items_full
    window.set_data("base_dir", path)
  File "/usr/lib/python2.7/dist-packages/gi/overrides/GObject.py", line 555, in _unsupported_data_method
    raise RuntimeError('Data access methods are unsupported. '
RuntimeError: Data access methods are unsupported. Use normal Python attributes instead

cuc (cuc+) wrote :

sudo ln -s /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0 /usr/lib/libpython2.7.so.1.0

is the fix for me (for now)

"nautilus --no-desktop -q" gave me the hint

cuc (cuc+) wrote :

spoke too soon, it just restores the icons.. context menu still missing

Christian Domsch (mail-landrus) wrote :

How can I try this out? If I just replace that file with the one in my installation (13.04 amd64 installation) under /usr/share/nautilus-python/extensions, I get a lot of python exception, when I startup nautilus (see

nautilus-rabbitvcs.trace)

cuc (cuc+) wrote :

i just made the symlink #4 and replaced the RabbitVCS.py with the one from #6 and its working for me...

"i just made the symlink #4 and replaced the RabbitVCS.py with the one from #6 and its working for me..."

Yeah! Work for my (Ubuntu 13.04 Development)

Thanks for the fix! It's working for me now as well.

Tomas 'tt' Krag (tt) wrote :

For me it was

sudo ln -s /usr/lib/i386-linux-gnu/libpython2.7.so.1.0 /usr/lib/libpython2.7.so.1.0

since i run a 32bit version of 13.04

but that together with the trynk version of RabbitVCS.py worked for me as well. thanks

Maache Mehdi (mehdi-maache) wrote :

Thanks ! With the symbolic link and the trunk's version of RabbitVCS.py, it works for me.

James Padel (izehouze) wrote :

symlink and truck code... Fixed me.

LCID Fire (lcid-fire) wrote :

All the above does not work for me.
Still no menu.

fisharebest (fisharebest) wrote :

The context menus on a fresh install of 13.10 are still missing.

The two changes in #4 and #6 still fix the problem.

Changed in rabbitvcs (Ubuntu):
status: Confirmed → Fix Committed
Xavier L. (xav0989) wrote :

Just a heads up that it hasn't been fixed in 14.04, but that the two changes (#4 & #6) fix the problem. It has been fixed in trunk upstream since last year.

Id2ndR (id2ndr) wrote :

I can confirm that it hasn't been fixed in 14.04 (x64) in base repository. The change #6 fixes the problem in my case (#4 is useless). Here is a patch that correspond to the diff between trunk and 0.15.2-1

The attachment "rabbitvcs.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Hans Deragon (deragon) wrote :

Confirming that the problem still persists in 14.04.

Changed in rabbitvcs (Ubuntu):
status: Fix Committed → New
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.