Merge rabbitmq-server from Debian unstable for 22.04

Bug #1946894 reported by Bryce Harrington
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rabbitmq-server (Ubuntu)
Undecided
Utkarsh Gupta

Bug Description

Upstream: 3.9.7
Debian: 3.9.4-1.2
Ubuntu: 3.8.9-3ubuntu1

Debian does new releases regularly, so it's likely there will be newer versions available before FF that we can pick up if this merge is done later in the cycle.

### New Debian Changes ###

rabbitmq-server (3.9.4-1.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Add a superficial autopkgtest.
    It just tests that the service is active after installation. This is not
    great test coverage, but it will at least stop new erlang versions from
    migrating before rabbitmq-server is fixed to work with it.
  * debian/changelog: add missing Closes: tag in the previous upload.
    I have just closed the actual bug via a separate control email.

 -- Antonio Terceiro <email address hidden> Sat, 25 Sep 2021 06:38:37 -0300

rabbitmq-server (3.9.4-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Depends: fix typo in erlang version that makes rabbitmq-server
    uninstallable (s/1:24.4/1:24.0/) (Closes: #993138)

 -- Antonio Terceiro <email address hidden> Fri, 27 Aug 2021 15:30:41 -0300

rabbitmq-server (3.9.4-1) unstable; urgency=medium

  * New upstream release:
    - Works with Erlang 24 (Closes: #992609).
  * Remove debian/patches/Upstream_PR2965_fixing_rabbitmqctl_parsing applied
    upstream.
  * Remove hunk from lets-use-python3-not-python-binary.patch as one upstream
    file is gone.
  * (build-)depends on erlang >= 1:24.0 and elixir >= 1.12.2.

 -- Thomas Goirand <email address hidden> Sun, 22 Aug 2021 17:32:09 +0200

rabbitmq-server (3.8.9-3) unstable; urgency=medium

  [ Adam Cecile ]
  * Merge upstream PR #2965 fixing rabbitmqctl parsing bug. (Closes: #986734)

 -- Thomas Goirand <email address hidden> Sat, 10 Apr 2021 22:59:57 +0200

rabbitmq-server (3.8.9-2) unstable; urgency=medium

  * Do not use the /usr/sbin/rabbitmq-server wrapper in systemd service file
    (Closes: #947873).
  * Use logrotate daily instead of weekly, and do not override the number of
    logs, so we don't keep too much of them.
  * Do not use a sharedscripts, as rabbitmq-server detects the log rotation
    by itself (LP: #1921425).

 -- Thomas Goirand <email address hidden> Fri, 26 Mar 2021 14:24:52 +0100

rabbitmq-server (3.8.9-1) unstable; urgency=medium

  * New upstream release.
  * Rebased lets-use-python3-not-python-binary.patch.

 -- Thomas Goirand <email address hidden> Thu, 01 Oct 2020 09:30:46 +0200

rabbitmq-server (3.8.5-1) unstable; urgency=medium

  * New upstream release:
    - Ships new version of the Prometheus plugin that works with Erlang
      version 23 (Closes: #964038).
  * Re-add debian/gbp.conf as the package is using pristine-tar.
  * Rebased lets-use-python3-not-python-binary.patch.
  * Add rabbitmq-dist.mk.patch to fix build with make 4.3 (Closes: #964636).

 -- Thomas Goirand <email address hidden> Fri, 10 Jul 2020 12:57:57 +0200

rabbitmq-server (3.8.3-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Remove gbp.conf, not used anymore or should be specified in the
    developers dotfiles.

  [ Thomas Goirand ]
  * Resolve issues with startup of RabbitMQ with erlang provided
    epmd daemon. See Ubuntu bug:
    https://bugs.launchpad.net/ubuntu/+source/rabbitmq-server/+bug/1808766

  [ James Page ]
  * Merge changes from Ubuntu.
  * New upstream release (3.8.2):
    - d/rules: Install new scripts.
  * d/rules: Drop --parallel usage, no longer needed.
  * d/control: Bump minimum erlang version inline with upstream
    requirements.

  [ Nicolas Bock ]
  * New upstream release (3.8.3).
  * d/watch: Fix watch file to download from GitHub
  * Fix timeout discrepancy between SysV and systemd (LP: #1874075)
    upstream, rabbitmq-server-release - 694540270c8
    - d/rabbitmq-server.init: Add RABBITMQ_STARTUP_TIMEOUT and default
      to 600.
    - d/rabbitmq-server.service: Default TimeoutStartSec to 600

  [ James Page ]
  * d/rules: Drop use of --with=systemd as its no longer needed.
  * d/rabbitmq-server.postinst,rabbitmq-server.postrm: Drop execute
    permission - debhelper deals with this as part of package build.

### Old Ubuntu Delta ###

rabbitmq-server (3.8.9-3ubuntu1) impish; urgency=medium

  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2021-22116.patch: treat arrays with extra or
      missing input as fatal errors in src/amqp10_binary_parser.erl,
      test/binary_parser_SUITE.erl.
    - CVE-2021-22116

 -- Leonidas Da Silva Barbosa <email address hidden> Tue, 22 Jun 2021 15:13:26 -0300

Utkarsh Gupta (utkarsh)
Changed in rabbitmq-server (Ubuntu):
assignee: nobody → Utkarsh Gupta (utkarsh)
Bryce Harrington (bryce)
description: updated
Changed in rabbitmq-server (Ubuntu):
milestone: none → ubuntu-22.01
Revision history for this message
Bryce Harrington (bryce) wrote :

I believe this package might have the "empty dirs" git issue. If so, see the ubuntu maintainers' handbook for workflow in handling it in git ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers