Please merge rabbitmq-server 2.8.2 from Debian

Bug #1004373 reported by Sidnei da Silva on 2012-05-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rabbitmq-server (Ubuntu)
Medium
Marc Cluet

Bug Description

The 2.8 series has several improvements related to performance, memory pressure and monitoring. Ideally this should be backported to precise-backports and lucid-backports as well once it hits the archive. The upstream version builds unchanged in lucid.

Related branches

Dave Walker (davewalker) wrote :

@sidnei .. Thanks for the bug report.

You have requested a sync, but comparing the changelogs there appears to be a reasonably large delta. This being the case, can you either comment on why the Ubuntu delta can be dropped.. Or should this be a merge request?

(btw, 'requestsync' from ubuntu-dev-tools is a useful command line tool for requesting sync's)

Thanks.

Changed in rabbitmq-server (Ubuntu):
status: New → Incomplete
Sidnei da Silva (sidnei) wrote :

To be fair I don't know the difference between a sync and a merge request.

John Lenton (chipaca) wrote :

We're using 2.8 from debian in a ppa (by using backportpackage) in both lucid and precise, and it passes all our tests. A sync seems to be what we want.

John Lenton (chipaca) wrote :

2.8.2-2, to be precise.

Scott Moser (smoser) on 2012-05-31
Changed in rabbitmq-server (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Scott Moser (smoser) on 2012-05-31
Changed in rabbitmq-server (Ubuntu):
assignee: nobody → Marc Cluet (lynxman)
Marc Cluet (lynxman) on 2012-06-20
Changed in rabbitmq-server (Ubuntu):
status: Triaged → In Progress
summary: - Please sync rabbitmq-server 2.8.2 from Debian
+ Please merge rabbitmq-server 2.8.2 from Debian
Emile Joubert (pawnstar) wrote :

Could 2.8.3 be synced from Debian instead of 2.8.2?
The patches for version 2.7.1-0ubuntu4 have all been fixed upstream.

Emile Joubert (pawnstar) wrote :

Actually, v2.8.3 is a bad choice. A bug has just been discovered that could cause the logfile to exhaust disk space. v2.8.4 would be a better choice.

Marc Cluet (lynxman) on 2012-06-26
Changed in rabbitmq-server (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers