r8168-dkms 8.041.00-1: r8168 kernel module failed to build [error: ‘NETIF_F_ALL_CSUM’ undeclared]

Bug #1635824 reported by Steve Roome on 2016-10-22
398
This bug affects 24 people
Affects Status Importance Assigned to Milestone
r8168 (Ubuntu)
High
Unassigned

Bug Description

This occurred while trying to build the latest mainline kernel as requested when reporting another bug.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: r8168-dkms 8.041.00-1
ProcVersionSignature: Ubuntu 4.4.0-45.66-generic 4.4.21
Uname: Linux 4.4.0-45-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
DKMSKernelVersion: 4.9.0-040900rc1-generic
Date: Sat Oct 22 12:48:03 2016
DuplicateSignature: dkms:r8168-dkms:8.041.00-1:/var/lib/dkms/r8168/8.041.00/build/r8168_n.c:4212:30: error: ‘NETIF_F_ALL_CSUM’ undeclared (first use in this function)
InstallationDate: Installed on 2016-02-21 (243 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
PackageArchitecture: all
PackageVersion: 8.041.00-1
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: r8168
Title: r8168-dkms 8.041.00-1: r8168 kernel module failed to build
UpgradeStatus: Upgraded to xenial on 2016-08-19 (63 days ago)

Steve Roome (s-j-roome) wrote :
summary: - r8168-dkms 8.041.00-1: r8168 kernel module failed to build
+ r8168-dkms 8.041.00-1: r8168 kernel module failed to build [error:
+ ‘NETIF_F_ALL_CSUM’ undeclared]
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in r8168 (Ubuntu):
status: New → Confirmed
Changed in r8168 (Ubuntu):
importance: Undecided → High
Eglefino (ruudino-k) wrote :

Below text came during installation and are only the error-lines.

Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.8.0-46-generic /boot/vmlinuz-4.8.0-46-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/r8168-dkms.0.crash'
Error! Bad return status for module build on kernel: 4.8.0-46-generic (x86_64)
Consult /var/lib/dkms/r8168/8.041.00/build/make.log for more information.

make.log:

DKMS make.log for r8168-8.041.00 for kernel 4.8.0-46-generic (x86_64)
wo 19 apr 2017 18:34:16 CEST
make: Map '/usr/src/linux-headers-4.8.0-46-generic' wordt binnengegaan
  LD /var/lib/dkms/r8168/8.041.00/build/built-in.o
  CC [M] /var/lib/dkms/r8168/8.041.00/build/r8168_n.o
/var/lib/dkms/r8168/8.041.00/build/r8168_n.c: In function ‘rtl8168_fix_features’:
/var/lib/dkms/r8168/8.041.00/build/r8168_n.c:4212:30: error: ‘NETIF_F_ALL_CSUM’ undeclared (first use in this function)
                 features &= ~NETIF_F_ALL_CSUM;
                              ^
/var/lib/dkms/r8168/8.041.00/build/r8168_n.c:4212:30: note: each undeclared identifier is reported only once for each function it appears in
/var/lib/dkms/r8168/8.041.00/build/r8168_n.c: In function ‘rtl8168_start_xmit’:
/var/lib/dkms/r8168/8.041.00/build/r8168_n.c:24599:12: error: ‘struct net_device’ has no member named ‘trans_start’
         dev->trans_start = jiffies;
            ^
scripts/Makefile.build:289: recept voor doel '/var/lib/dkms/r8168/8.041.00/build/r8168_n.o' is mislukt
make[1]: *** [/var/lib/dkms/r8168/8.041.00/build/r8168_n.o] Fout 1
Makefile:1491: recept voor doel '_module_/var/lib/dkms/r8168/8.041.00/build' is mislukt
make: *** [_module_/var/lib/dkms/r8168/8.041.00/build] Fout 2
make: Map '/usr/src/linux-headers-4.8.0-46-generic' wordt verlaten

Eglefino (ruudino-k) wrote :

forgot to give:

LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial

Guy Stone (stoneguy3) wrote :

The patch enables the module to compile correctly and produce a functioning driver. I derived it by analogy with other fixes for the r8168/9. I claim no understanding of this module or the underlying chipset problem!

Kernel 4.4 appears to be the last version where the original code is applicable.

The attachment "r8168-dkms compile failure (with possible fix)" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Eglefino (ruudino-k) wrote :

@crichton

How do I become a patch, because now by every kernel-update I get the same faults/errors about the failures with 'r8168-dkms' and I like to know if my NIC is still working as Gigabit connection?

Eglefino (ruudino-k) wrote :

I should find here the possibility to download a patch for my Realtek NIC r8168 despite of R8168, there is nothing here to find, why do I have ti write a message too?

By-the way my e-mail-address by Yahoo will stop. I use it to login here, where can I change in to an new address? Can somebody help me

Martin Chait (chaitmartin89) wrote :

You can download drivers, link: https://goo.gl/neQe.

Unpack the tarball :
  # tar vjxf r8168-8.aaa.bb.tar.bz2

 Change to the directory:
  # cd r8168-8.aaa.bb

 If you are running the target kernel, then you should be able to do :

  # ./autorun.sh (as root or with sudo)

Following those steps everything will work. Tested with Ubuntu 16.04 (x64)

Andreas Beckmann (anbe) wrote :

fixed in 8.041.01-1

Changed in r8168 (Ubuntu):
status: Confirmed → Fix Released
manish sirohi (manis.sirohi) wrote :

no network adapter is working either ethernet nor wifi

suyash (suyash-ryuk) on 2018-05-06
Changed in r8168 (Ubuntu):
assignee: nobody → suyash (suyash-ryuk)
assignee: suyash (suyash-ryuk) → nobody
vikas (vikasduhun) wrote :

NA

information type: Public → Public Security
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers