qwtplot3d version 0.2.7+svn191-5 failed to build on armel

Bug #791301 reported by Ricardo Salveti on 2011-06-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qwtplot3d (Ubuntu)
Undecided
Unassigned

Bug Description

qwtplot3d version 0.2.7+svn191-5 failed to build on armel
Link to failed build: https://launchpad.net/ubuntu/+source/qwtplot3d/0.2.7+svn191-5/+build/2470747

Direct link to the build log: https://launchpad.net/ubuntu/+source/qwtplot3d/0.2.7+svn191-5/+build/2470747/+files/buildlog_ubuntu-oneiric-armel.qwtplot3d_0.2.7%2Bsvn191-5_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 905 lines into the build log:

include/qwt3d_openglhelper.h:120:95: error: 'gluProject' was not declared in this scope
src/qwt3d_axis.cpp: In member function 'virtual void Qwt3D::Axis::draw()':
src/qwt3d_axis.cpp:120:43: error: 'glColor4d' was not declared in this scope
src/qwt3d_axis.cpp: In member function 'void Qwt3D::Axis::drawBase()':
src/qwt3d_axis.cpp:177:20: error: 'glBegin' was not declared in this scope
src/qwt3d_axis.cpp:178:37: error: 'glVertex3d' was not declared in this scope
src/qwt3d_axis.cpp:180:8: error: 'glEnd' was not declared in this scope
src/qwt3d_axis.cpp: In member function 'Qwt3D::Triple Qwt3D::Axis::drawTic(Qwt3D::Triple, double)':
src/qwt3d_axis.cpp:281:20: error: 'glBegin' was not declared in this scope
src/qwt3d_axis.cpp:284:43: error: 'glVertex3d' was not declared in this scope
src/qwt3d_axis.cpp:288:8: error: 'glEnd' was not declared in this scope
make[1]: *** [tmp/qwt3d_axis.o] Error 1
make[1]: Leaving directory `/build/buildd/qwtplot3d-0.2.7+svn191/build/qt4'
make: *** [build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110510-1212
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/qwtplot3d-0.2.7+svn191

Marcin Juszkiewicz (hrw) on 2011-06-15
tags: added: opengles
Alexander (alexander-mezon) wrote :

Any fixes?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qwtplot3d (Ubuntu):
status: New → Confirmed
Torsten Harenberg (harenberg) wrote :

very old bug, but these packages are still not available under armel preventing gnuradio to build

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers