Ubuntu

Package libqwt-dev wants to upgrade every time

Reported by Nikolay Morozov on 2012-01-25
152
This bug affects 36 people
Affects Status Importance Assigned to Milestone
qwt (Debian)
Fix Released
Unknown
qwt (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Every time package libqwt-dev wants to upgrade, apt-get aptitude, update manager. It always updates and ask again :(

Test case:
1. install the new version from -proposed
2. refresh update-manager
-> see that qwt-dev doesn't need any update anymore.

Regression potential:
This should not change anything as it only changes the packaging metadata in a very obvious way.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libqwt-dev 6.0.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Wed Jan 25 11:25:34 2012
EcryptfsInUse: Yes
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111011)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: qwt
UpgradeStatus: No upgrade log present (probably fresh install)

Nikolay Morozov (nmorozov) wrote :
Nikolay Morozov (nmorozov) wrote :

nmorozov@nmorozov:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  libqwt-dev
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/99.8 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 233996 files and directories currently installed.)
Preparing to replace libqwt-dev 6.0.0-1ubuntu1 (using .../libqwt-dev_6.0.0-1ubuntu1_i386.deb) ...
Unpacking replacement libqwt-dev ...
Setting up libqwt-dev (6.0.0-1ubuntu1) ...

After yhis i can make it again and again...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qwt (Ubuntu):
status: New → Confirmed
Christian Kindel (iceman81292) wrote :

I also have this Issue on Ubuntu 11.10 using the update manager. After selecting 'install updates' it seems to work normally (no errors), but if update manager is opened again it shows that it still needs to be installed.

Diego Schulz (dschulzg) wrote :

Same problem here, Ubuntu 12.04 x86_64.

Filipe Roque (flip-roque) wrote :

After upgrading to 12.04 this bug still occurs.

It seems fixed in Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=631816

The control file has
Replaces: libqwt5-qt4-dev (<< 6.0.0-)

but
"6.0.0-" is not a valid version number.

Please update the package.

tags: added: precise
tags: added: amd64
Changed in qwt (Debian):
status: Unknown → Fix Released
Paulo Matias (paulo-matias) wrote :

Can someone please just pull the fix from Debian? This bug is already driving me crazy.

SteveZalek (zaleksf) wrote :

This is still a problem. The isssue is that libqwt-dev has a dependency as itself listed as itself, which it cannot resolve. How hard is it to update the dependency list?

Hans Meine (hans-meine) wrote :

It also drives me crazy, and I hoped all the time that it would dissolve with the update to 12.04 precise – but it did not.

For the meantime, I am using this to get rid of the "update available" icons in the tray:

  sudo perl -pi -e 's,(Replaces: libqwt5-qt4-dev \(<< 6.0.0)\),\1-),' /var/lib/dpkg/status && sudo apt-get update

Leo Iannacone (l3on) on 2012-05-26
Changed in qwt (Ubuntu):
assignee: nobody → Leo Iannacone (l3on)
Leo Iannacone (l3on) on 2012-05-26
Changed in qwt (Ubuntu):
assignee: Leo Iannacone (l3on) → nobody
Julian Taylor (jtaylor) on 2012-05-26
Changed in qwt (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-05-30
description: updated
description: updated

Hello Nikolay, or anyone else affected,

Accepted qwt into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in qwt (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Dave Gilbert (ubuntu-treblig) wrote :

Looks good here; libqwt-dev 6.0.0-1ubuntu1.12.04.1 and it's no longer asking for an update.

Dave

tags: added: verification-done verification-done-precise
Nikolay Morozov (nmorozov) wrote :

Precise works good

msbealo (msbealo) wrote :

Thanks for the fix as this is a very annoying problem.

Could you please either give detailed instructions of how to implement this, or could you fix the problem in such a way that does not require any special procedure. Thanks.

the problem persist, it is the DEBIAN/control line 9:

Replaces: libqwt5-qt4-dev (<< 6.0.0-)

which should be

Replaces: libqwt5-qt4-dev (<< 6.0.0-1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qwt (Ubuntu Precise):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qwt - 6.0.0-1ubuntu1.12.04.1

---------------
qwt (6.0.0-1ubuntu1.12.04.1) precise-proposed; urgency=low

  * Imported patch from debian to fix the typo in
    debian/control.Replaces: added the missing debian revision.
    (LP: #921430, Closes: #631816)
 -- Leo Iannacone <email address hidden> Sat, 26 May 2012 23:32:19 +0200

Changed in qwt (Ubuntu Precise):
status: Confirmed → Fix Released
Scott Kitterman (kitterman) wrote :

Still needs testing for oneiric.

tags: removed: verification-done
André Rummler (andre-rummler) wrote :

Hi Clint,

installed 6.0.0-1ubuntu1.11.10.1 from oneiric-proposed as explained at https://wiki.ubuntu.com/Testing/EnableProposed and the permanent demand for updating is gone. The patch works for me. Please include it in the regular updates.

Andre

tags: added: verification-done-oneiric
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qwt - 6.0.0-1ubuntu1.11.10.1

---------------
qwt (6.0.0-1ubuntu1.11.10.1) oneiric-proposed; urgency=low

  * Imported patch from debian to fix the typo in
    debian/control.Replaces: added the missing debian revision.
    (LP: #921430, Closes: #631816)
 -- Leo Iannacone <email address hidden> Sat, 26 May 2012 23:32:19 +0200

Changed in qwt (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.